MDM occasional segfault on boot?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Statik
Level 2
Level 2
Posts: 81
Joined: Sat Jan 14, 2012 9:27 pm

MDM occasional segfault on boot?

Post by Statik »

Hi all,
I've been noticing lately that the login manager occasionally doesn't show up. Rather than the nice photo background I'm used to, I instead get the black screen with a little login window. Everything still works fine, but I thought I'd post it here to see if anyone knows what the trouble is. I ran a dmesg immediately after login and I noticed this line:

Code: Select all

[   18.087370] mdmwebkit[2015]: segfault at 8 ip 00007fd19f8109cd sp 00007ffdbc2dd920 error 4 in libGL.so.384.111[7fd19f75f000+cb000]
so perhaps that's the problem?

Statik
Capella
Level 1
Level 1
Posts: 22
Joined: Tue Nov 01, 2016 11:48 pm

Re: MDM occasional segfault on boot?

Post by Capella »

I was following this post--and have the same thing happening. Today I got the alternate login and checked dmesg and noticed the same line. I noticed both have a reference to nvidia driver 384.111.

Code: Select all

14.253935] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   14.253966] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   14.253980] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   14.253993] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   14.254319] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   14.254483] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   14.254498] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   14.255059] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   14.285392] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   14.596419] nvidia-modeset: Allocated GPU:0 (GPU-a4e48616-9702-d9e6-022e-95b1552515a1) @ PCI:0000:01:00.0
[   16.886966] mdmwebkit[1986]: segfault at 8 ip 00007fa09cbff9cd sp 00007ffc3a6d1370 error 4 in libGL.so.384.111[7fa09cb4e000+cb000]
[   19.195633] nvidia-modeset: Freed GPU:0 (GPU-a4e48616-9702-d9e6-022e-95b1552515a1) @ PCI:0000:01:00.0
[   19.217962] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   20.293672] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   20.293703] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   20.293717] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   20.293730] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   20.294150] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   20.294315] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   20.294330] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   20.294895] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   20.337443] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20170531/nsarguments-95)
[   20.643649] nvidia-modeset: Allocated GPU:0 (GPU-a4e48616-9702-d9e6-022e-95b1552515a1) @ PCI:0000:01:00.0
Post Reply

Return to “Newbie Questions”