Wi-Fi Access point on Mint 18.1

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
turtlebay
Level 5
Level 5
Posts: 608
Joined: Mon Apr 01, 2013 12:33 pm

Wi-Fi Access point on Mint 18.1

Post by turtlebay » Fri Mar 16, 2018 10:03 pm

I was looking for help in setting up a wifi hotspot in my room using my laptop running Mint 18.1 connected by ethernet so that another PC could access the internet by wifi. My room is too far from the Sky router's wifi signal so I need to create a local hotspot.

I found the thread ' How to enable Wi-Fi Access point on Mint 17' but got a bit lost in step 2 where someone wrote " Do sudo vi /etc/NetworkManager/system-connections/YOUR_CONNECTION_NAME and change mode=infrastructure to mode=ap and save it." where I couldn't figure out which bit referred to /YOUR_CONNECTION_NAME.

Code: Select all

pete@pete-LM-1545 ~ $ inxi -Fxz
System:    Host: pete-LM-1545 Kernel: 4.4.0-112-generic i686 (32 bit gcc: 5.4.0)
           Desktop: MATE 1.16.2 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.1 Serena
Machine:   System: Dell (portable) product: Inspiron 1545
           Mobo: Dell model: 0G848F Bios: Dell v: A14 date: 12/07/2009
CPU:       Single core Intel Celeron 900 (-UP-) cache: 1024 KB
           flags: (lm nx pae sse sse2 sse3 ssse3) bmips: 4388 speed/max: 1200/2200 MHz
Graphics:  Card: Intel Mobile 4 Series Integrated Graphics Controller bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: (unloaded: fbdev,vesa) Resolution: 1366x768@60.06hz
           GLX Renderer: Mesa DRI Mobile Intel GM45 Express x86/MMX/SSE2
           GLX Version: 2.1 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-112-generic
Network:   Card-1: Marvell 88E8040 PCI-E Fast Ethernet Controller driver: sky2 v: 1.30 port: de00 bus-ID: 09:00.0
           IF: enp9s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Broadcom BCM4312 802.11b/g LP-PHY driver: wl bus-ID: 0c:00.0
           IF: wlp12s0 state: dormant mac: <filter>
Drives:    HDD Total Size: 250.1GB (21.6% used) ID-1: /dev/sda model: ST9250315AS size: 250.1GB
Partition: ID-1: / size: 66G used: 47G (76%) fs: ext4 dev: /dev/sda5
           ID-2: swap-1 size: 3.93GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 50.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 145 Uptime: 20 min Memory: 664.4/2988.7MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 

User avatar
kc1di
Level 13
Level 13
Posts: 4787
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: Wi-Fi Access point on Mint 18.1

Post by kc1di » Sat Mar 17, 2018 6:29 am

The connection name is what ever name is given to your computer usually.
on mine it's "auto +my usr name "
I would suggest you use xed instead of VI misapply because it will be easier for you. so use this command instead of the above.

Code: Select all

gksudo xed
then open the file

Code: Select all

/etc/NetworkManager/system-connections/<Whatever your connection is called> 
Make the change mentiond above and save the file. continue with the setup.
the name of the connection is the actual file you need to modify. Good Luck.
Last edited by kc1di on Sat Mar 17, 2018 6:54 pm, edited 1 time in total.
Easy tips : https://sites.google.com/site/easylinuxtipsproject/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

turtlebay
Level 5
Level 5
Posts: 608
Joined: Mon Apr 01, 2013 12:33 pm

Re: Wi-Fi Access point on Mint 18.1

Post by turtlebay » Sat Mar 17, 2018 5:15 pm

" The connection name is what ever name is given to your computer usually. " Where would I find that?

" the open the file "? Typo?

More confused than ever now!

User avatar
Sir Charles
Level 7
Level 7
Posts: 1827
Joined: Thu Jan 04, 2018 1:00 pm

Re: Wi-Fi Access point on Mint 18.1

Post by Sir Charles » Sat Mar 17, 2018 5:30 pm

In /etc/NetworkManager/system-connections you will find the "config" files for all the networks that you have been connected to.
Then:
gksudo xed /etc/NetworkManager/system-connections/<config-file for the network you want to edit> as per your first post.
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

turtlebay
Level 5
Level 5
Posts: 608
Joined: Mon Apr 01, 2013 12:33 pm

Re: Wi-Fi Access point on Mint 18.1

Post by turtlebay » Sat Mar 17, 2018 5:37 pm

In that address I just have a file called 'wired connection 1' with a cross on the icon, but can't work out which program opens it. Text editor won't.

It doesn't show config-file for ' the network you want to edit ' at that address.
Last edited by turtlebay on Sat Mar 17, 2018 5:45 pm, edited 1 time in total.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1827
Joined: Thu Jan 04, 2018 1:00 pm

Re: Wi-Fi Access point on Mint 18.1

Post by Sir Charles » Sat Mar 17, 2018 5:43 pm

Just run xed (text editor) with root privilege from terminal:

Code: Select all

gksudo xed /etc/NetworkManager/system-connections/wired connection 1
Type your password and there you go!
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

turtlebay
Level 5
Level 5
Posts: 608
Joined: Mon Apr 01, 2013 12:33 pm

Re: Wi-Fi Access point on Mint 18.1

Post by turtlebay » Sat Mar 17, 2018 5:48 pm

I typed in (copy and pasted actually) ' xed /etc/NetworkManager/system-connections/wired connection 1' into a terminal but after inputting my password (+ Enter) the terminal just waits for another instruction. It doesn't display anything else. Perhaps it's because this system has never set up a wifi connection (because there isn't one available). Thus wanting to use my ethernet connected PC and making a wifi hotspot.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1827
Joined: Thu Jan 04, 2018 1:00 pm

Re: Wi-Fi Access point on Mint 18.1

Post by Sir Charles » Sat Mar 17, 2018 5:59 pm

That's odd!
Alright, go to /etc/NetworkManager/, righ-click on the folder: system-connections and from the menu choose "Open as Root". Now, you should be able to open the file as root in the text editor. Take care when editing!
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

turtlebay
Level 5
Level 5
Posts: 608
Joined: Mon Apr 01, 2013 12:33 pm

Re: Wi-Fi Access point on Mint 18.1

Post by turtlebay » Sat Mar 17, 2018 6:32 pm

OK that worked but I cannot see any named connection in the opened file that I made myself:

Code: Select all

[connection]
id=Wired connection 1
uuid=2000795d-f9db-38a6-8027-648309d812d7
type=ethernet
autoconnect-priority=-999
permissions=
secondaries=
timestamp=1489612610

[ethernet]
duplex=full
mac-address=A4:BA:DB:CF:8A:25
mac-address-blacklist=
mtu=1500

[ipv4]
dns-search=
method=auto

[ipv6]
addr-gen-mode=stable-privacy
dns-search=
ip6-privacy=0
method=auto
BTW this is what I'm trying to follow https://community.linuxmint.com/tutorial/view/1832

User avatar
Sir Charles
Level 7
Level 7
Posts: 1827
Joined: Thu Jan 04, 2018 1:00 pm

Re: Wi-Fi Access point on Mint 18.1

Post by Sir Charles » Sat Mar 17, 2018 7:00 pm

Did you do this first:
Go to Main Menu -> Preferences -> Network Connections click on Add and choose Wi-Fi. Choose a network name (SSID), Infrastructure mode. Go to Wi-Fi Security and choose a WPA/WPA2 Personal and create a password. Go to IPv4 settings and check that it is shared with other computers.
If positive, then you should have another file besides "Wired connection 1" with the name you chose as per above instruction from the tutorial. That would be the file to be edited.
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

turtlebay
Level 5
Level 5
Posts: 608
Joined: Mon Apr 01, 2013 12:33 pm

Re: Wi-Fi Access point on Mint 18.1

Post by turtlebay » Sun Mar 18, 2018 2:27 pm

Thanks, I'll give that a go.

Post Reply

Return to “Newbie Questions”