[SOLVED] Dual screen doesn't work in MATE after restart

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Waka
Level 1
Level 1
Posts: 8
Joined: Mon Jun 05, 2017 2:44 pm

[SOLVED] Dual screen doesn't work in MATE after restart

Post by Waka »

Hi,

I recently switched to MATE desktop and everything works fine so far. Everything except for the dual screen setup after each start. The second screen shows nothing, but it doesn't complain about recieving no signal. The peculiar thing is that it shows the mouse cursor, but when I try to move any desktop window or program to the second screen it doesn't move past the borders of the first screen. The first screen (main screen) is connected via HDMI, the second screen via D-Sub to the Display Port (with the help of an adapter. I think the image is a lot better this way as if I connect it to the VGA port of my PC)

The fix I use now is really simple: I open the Display configuration, click "Apply" and then "Keep this configuration" and the second screen works as intended.

What could be the problem here? Why do I have to bring up the Display config to get the second screen working? And if all else fails, is there a way to automate my workaround, maybe per script?
Last edited by Waka on Fri Feb 14, 2020 2:48 pm, edited 1 time in total.

User avatar
kukamuumuka
Level 16
Level 16
Posts: 6657
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Dual screen doesn't work in MATE after restart

Post by kukamuumuka »

Install Arandr and make the configuration using Arandr

Code: Select all

apt install arandr

Waka
Level 1
Level 1
Posts: 8
Joined: Mon Jun 05, 2017 2:44 pm

Re: Dual screen doesn't work in MATE after restart

Post by Waka »

A first test using arandr was successful, both screens worked as they should after a restart. Thanks!

EDIT: However, a second restart showed the same problem as before. The second screen is blank until I click "Apply" in Display Settings. :(

User avatar
kukamuumuka
Level 16
Level 16
Posts: 6657
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Re: Dual screen doesn't work in MATE after restart

Post by kukamuumuka »

Waka wrote:
Sun Mar 18, 2018 11:41 am
A first test using arandr was successful, both screens worked as they should after a restart. Thanks!

EDIT: However, a second restart showed the same problem as before. The second screen is blank until I click "Apply" in Display Settings. :(
If you saved the layout, add that layout to the Startup Applications. :wink:

Waka
Level 1
Level 1
Posts: 8
Joined: Mon Jun 05, 2017 2:44 pm

Re: Dual screen doesn't work in MATE after restart

Post by Waka »

Just so I don't follow in the footsteps of DenverCoder9, here's a short follow up:
After I connected one screen to the PC via VGA and the other one via DisplayPort I haven't had any trouble with my dual screen setup. It seems that MATE is kind of picky if you connect one screen via HDMI and the other with DisplayPort. I didn't do any other tests with connecting one screen via HDMI, and one via VGA, though. Just thought I let any future users who face the same problem know that it may be possible your problems can be solved by connecting the screens differently. :)

Post Reply

Return to “Newbie Questions”