USB not showing up in File Manager (solved)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Wompoo
Level 5
Level 5
Posts: 857
Joined: Sat Dec 28, 2013 2:42 am

USB not showing up in File Manager (solved)

Post by Wompoo » Wed Apr 18, 2018 7:45 am

When I use a USB stick, it is not showing up in File Manager. Linux Mint 17.3 KDE.
It formerly appeared where I have indicated with the arrow in the screenshot.
I am able to open the USB stick by using the panel icon, but unable to find a way to select "safely remove USB" option before removing.
Can someone tell me what is going wrong please?
Attachments
ksnip_20180418-212407.png
Last edited by Wompoo on Wed Apr 18, 2018 7:02 pm, edited 1 time in total.
Desktop PC #2
Linux Mint 17.3 Rosa KDE desktop (64-bit), Asus
CPU E7500, 8 Gb RAM


Desktop #1
Dell Vostro 220 64 bit.
Linux Mint 17.3 Rosa KDE

Dell Inspiron 6000 laptop

Mute Ant
Level 13
Level 13
Posts: 4892
Joined: Tue Sep 03, 2013 7:45 pm

Re: USB not showing up in File Manager

Post by Mute Ant » Wed Apr 18, 2018 11:12 am

I have found the Mint 18.3 blkid command returns a '2' error code on some removable drives. No pattern detected, they just don't. I guess Nemo does something like a blkid command to see what's been plugged in, gets an error code and decides there is no volume to be mounted.

My possibly extreme solution to an accumulation of little niggles like this was to install Devuan ASCII as my base OS and only use Mint as a Live Session guest, just to see what's happening.
Data stored in an encrypted volume will only be accessible with the original password. Without this key, all the data will remain scrambled beyond hope of recovery.

User avatar
phd21
Level 16
Level 16
Posts: 6533
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: USB not showing up in File Manager

Post by phd21 » Wed Apr 18, 2018 1:19 pm

HI Wompoo,

I just read your post and the reply to it. Here are my thoughts on this as well.

I know that you have 3 older computers, 2 x 64-bit desktops and 1 x 32-bit laptop. Is this happening on all computers or just one, if just one, which one? Is this with your new USB 64gb stick or all USB sticks?

Assuming the drive is recognized by your system, there are usually 2 simple methods for mounting or unmounting a removable drive like a USB stick. One is using the "Device Notifier" system tray panel icon, and the other is using your File Manager. Of course, you can use a partition manager or "Disks", and there are console terminal commands as well. There are also removable drive options in the Linux Mint systems to automatically mount removable devices or not to; Tip: if you are making bootable USB sticks, it is best to turn off these automount options until you are finished.

"Device Notifier": When you first plug in a USB stick, the "Device Notifier" should automatically show a pop-up window where you can click actions or the "triangle" on the right of that drive (USB stick or drive) to mount it (make available) or to unmount it (eject it, safe to remove). If the USB device was already connected, then you can just click the "Device Notifier" to bring its pop-window to do this. If the "triangle" in the "Device Notifier" next to the USB drive is pointing up, then the drive is already mounted and available to your system, if the "triangle" is pointing down, then the drive is not mounted and safe to remove, or click the "triangle" to mount the drive and make it available.

"File Manager": If you bring up your file manager like "KDE's Dolphin", you can click the drive on the left side (may have to scroll up or down to see it) to mount it, or right-click it to click safely remove it (unmount it).

If you are having issues with one particular USB port, try another USB port...

Hope this helps ...
Mounting_UnMounting_RemovableDrives1.jpg
"Device Notifier"
.
Mounting_UnMounting_RemovableDrives2.jpg
"Device Notifier"
.
Mounting_UnMounting_RemovableDrives3.jpg
"File Manager"
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Wompoo
Level 5
Level 5
Posts: 857
Joined: Sat Dec 28, 2013 2:42 am

Re: USB not showing up in File Manager

Post by Wompoo » Wed Apr 18, 2018 7:01 pm

Thanks for the good reply phd21. And thanks also Mute Ant for you reply.
The problem was on my ASUS desktop computer.
From you text:
phd21 wrote:
Wed Apr 18, 2018 1:19 pm
.................................... you can click actions or the "triangle" on the right of that drive (USB stick or drive) to mount it (make available) or to unmount it (eject it, safe to remove). ............................
I am able to use this now to eject a USB.
I have been unaware of this option. My ignorance.
Problem solved.
Desktop PC #2
Linux Mint 17.3 Rosa KDE desktop (64-bit), Asus
CPU E7500, 8 Gb RAM


Desktop #1
Dell Vostro 220 64 bit.
Linux Mint 17.3 Rosa KDE

Dell Inspiron 6000 laptop

User avatar
phd21
Level 16
Level 16
Posts: 6533
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: USB not showing up in File Manager

Post by phd21 » Wed Apr 18, 2018 10:14 pm

HI Wompoo,

You are welcome...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Post Reply

Return to “Newbie Questions”