Issue with Mint Update. dpkg was interrupted

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Bobo-the-Cat
Level 2
Level 2
Posts: 99
Joined: Tue Jun 03, 2008 1:03 pm

Issue with Mint Update. dpkg was interrupted

Post by Bobo-the-Cat » Wed Apr 18, 2018 3:04 pm

Hi,
I've posted here as there seems no other better category. I installed a printer driver and that appears to have broken the Mint update. Now when I try to do a refresh, I get a series of errors. I have tried to follow another post as far as I can but my issue is still not fixed. I need a solution to this that does not involve re-installing Mint from scratch! The log is below:

Screen 1 from updater
---------------------------------
W: http://www.openprinting.org/download/pr ... elease.gpg: Signature by key F8897B6F00075648E248B7EC24CBF5474CFD1E2F uses weak digest algorithm (SHA1)
(I selected the close option on this screen - nothing else to do)

Screen 2 from updater
--------------------------------
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
E: _cache->open() failed, please report.
(I selected the close option on this screen - nothing else to do)

Attempt to sort issue following advice from another post
----------------------------------------------------------------------------------
mntuser@mntuser-OptiPlex-9020 ~/Desktop $ su
Password:
mntuser-OptiPlex-9020 Desktop # dpkg --configure -a
Setting up libjpeg62:amd64 (1:6b2-2) ...
Setting up gcc-6-base:i386 (6.0.1-0ubuntu1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
dpkg: dependency problems prevent configuration of libgcc1:i386:
libgcc1:i386 depends on libc6 (>= 2.2.4); however:
Package libc6:i386 is not installed.

dpkg: error processing package libgcc1:i386 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libgcc1:i386

Marziano
Level 6
Level 6
Posts: 1210
Joined: Thu Jan 04, 2018 1:00 pm

Re: Issue with Mint Update. dpkg was interrupted

Post by Marziano » Wed Apr 18, 2018 3:21 pm

Try installinglibc6

Code: Select all

sudo apt-get install libc6
and see if it solves the dependency problem.
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

Bobo-the-Cat
Level 2
Level 2
Posts: 99
Joined: Tue Jun 03, 2008 1:03 pm

Re: Issue with Mint Update. dpkg was interrupted

Post by Bobo-the-Cat » Wed Apr 18, 2018 5:22 pm

Hi,
Thanks. It looks like the dependency is sorted, leaving just the error below now:

W: http://www.openprinting.org/download/pr ... elease.gpg: Signature by key F8897B6F00075648E248B7EC24CBF5474CFD1E2F uses weak digest algorithm (SHA1)

Marziano
Level 6
Level 6
Posts: 1210
Joined: Thu Jan 04, 2018 1:00 pm

Re: Issue with Mint Update. dpkg was interrupted

Post by Marziano » Wed Apr 18, 2018 5:24 pm

If you have already installed the driver, you could open Software Sources and disable this source.
"Those are my principles, and if you don't like them...well, I have others." -Marx...
Groucho { Marx

Bobo-the-Cat
Level 2
Level 2
Posts: 99
Joined: Tue Jun 03, 2008 1:03 pm

Re: Issue with Mint Update. dpkg was interrupted

Post by Bobo-the-Cat » Mon Apr 23, 2018 2:18 pm

Thanks, I'll give this a try. But I've noticed with another update today - that it appears to have gone anyway!

Post Reply

Return to “Newbie Questions”