[SOLVED] Update not working

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
mathewmindfreak
Level 1
Level 1
Posts: 6
Joined: Thu Apr 19, 2018 11:53 am

[SOLVED] Update not working

Post by mathewmindfreak » Fri Apr 20, 2018 11:36 am

I just installed Linux mint 18.3 Cinnamon. I'm dual booting along with Windows 10. Soon after installing, I realized that updating Linux isn't working. I tried sudo apt-get update in terminal. I'm getting errors like failed to fetch some sites and some index files failed to download, They have been ignored, or old ones used instead. Help please
Last edited by mathewmindfreak on Fri Apr 27, 2018 7:26 am, edited 1 time in total.

User avatar
JerryF
Level 10
Level 10
Posts: 3012
Joined: Mon Jun 08, 2015 1:23 pm
Location: Rhode Island, USA

Re: Update not working

Post by JerryF » Fri Apr 20, 2018 11:49 am

Hi mathew,

Welcome.

First, check to make sure that you're connected to the internet. There should be an icon towards the right in the panel that lets you know.
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members.

User avatar
michael louwe
Level 9
Level 9
Posts: 2670
Joined: Sun Sep 11, 2016 11:18 pm

Re: Update not working

Post by michael louwe » Fri Apr 20, 2018 1:44 pm

Updating LM is done manually by default, ie not automatic by default like for Win 10/8.x/7.

Normally, you just click the ... >Update Manager icon on the bottom panel >Install Updates or >Refresh.
....... Or go to >Menu >Administration >Update Manager. The update settings should be properly set after installation of LM.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Update not working

Post by Cosmo. » Fri Apr 20, 2018 4:20 pm

Switching to another mirror might help.
If you have ppas added to the system, disable them temporarily.

Both to be done with software sources tool.

mathewmindfreak
Level 1
Level 1
Posts: 6
Joined: Thu Apr 19, 2018 11:53 am

Re: Update not working

Post by mathewmindfreak » Fri Apr 20, 2018 11:33 pm

JerryF wrote:
Fri Apr 20, 2018 11:49 am
Hi mathew,

Welcome.

First, check to make sure that you're connected to the internet. There should be an icon towards the right in the panel that lets you know.
I'm connected to Internet via WiFi dude. It's working I checked websites using Firefox. So I don't think Internet is the issue

mathewmindfreak
Level 1
Level 1
Posts: 6
Joined: Thu Apr 19, 2018 11:53 am

Re: Update not working

Post by mathewmindfreak » Fri Apr 20, 2018 11:38 pm

michael louwe wrote:
Fri Apr 20, 2018 1:44 pm
Updating LM is done manually by default, ie not automatic by default like for Win 10/8.x/7.

Normally, you just click the ... >Update Manager icon on the bottom panel >Install Updates or >Refresh.
....... Or go to >Menu >Administration >Update Manager. The update settings should be properly set after installation of LM.
i have done that. when i hit refresh, i get this error.
The repository 'http://mirrors.evowise.com/linuxmint/packages sylvia Release' does not have a Release file.Data from such a repository can't be authenticated and is therefore potentially dangerous to use.See apt-secure(8) manpage for repository creation and user configuration details.The repository 'http://security.ubuntu.com/ubuntu xenial-security Release' does not have a Release file.Data from such a repository can't be authenticated and is therefore potentially dangerous to use.See apt-secure(8) manpage for repository creation and user configuration details.The repository 'http://archive.canonical.com/ubuntu xenial Release' does not have a Release file.Data from such a repository can't be authenticated and is therefore potentially dangerous to use.See apt-secure(8) manpage for repository creation and user configuration details.The repository 'http://np.archive.ubuntu.com/ubuntu xenial Release' does not have a Release file.Data from such a repository can't be authenticated and is therefore potentially dangerous to use.See apt-secure(8) manpage for repository creation and user configuration details.The repository 'http://np.archive.ubuntu.com/ubuntu xenial-updates Release' does not have a Release file.Data from such a repository can't be authenticated and is therefore potentially dangerous to use.See apt-secure(8) manpage for repository creation and user configuration details.The repository 'http://np.archive.ubuntu.com/ubuntu xenial-backports Release' does not have a Release file.Data from such a repository can't be authenticated and is therefore potentially dangerous to use.See apt-secure(8) manpage for repository creation and user configuration details.Failed to fetch http://mirrors.evowise.com/linuxmint/pa ... 4/Packages 403 Forbidden [IP: 104.19.138.75 80]Failed to fetch http://security.ubuntu.com/ubuntu/dists ... 4/Packages 403 Forbidden [IP: 91.189.91.23 80]Failed to fetch http://archive.canonical.com/ubuntu/dis ... 4/Packages 403 Forbidden [IP: 91.189.92.191 80]Failed to fetch http://np.archive.ubuntu.com/ubuntu/dis ... 4/Packages 403 Forbidden [IP: 120.89.98.2 80]Failed to fetch http://np.archive.ubuntu.com/ubuntu/dis ... 4/Packages 403 Forbidden [IP: 120.89.98.2 80]Failed to fetch http://np.archive.ubuntu.com/ubuntu/dis ... 4/Packages 403 Forbidden [IP: 120.89.98.2 80]Some index files failed to download. They have been ignored, or old ones used instead

mathewmindfreak
Level 1
Level 1
Posts: 6
Joined: Thu Apr 19, 2018 11:53 am

Re: Update not working

Post by mathewmindfreak » Fri Apr 20, 2018 11:46 pm

Cosmo. wrote:
Fri Apr 20, 2018 4:20 pm
Switching to another mirror might help.
If you have ppas added to the system, disable them temporarily.

Both to be done with software sources tool.
no ppas is added to the system. and i have tried changing mirrors. i tried the top 5 mirrors with best speeds. it is still not working

User avatar
michael louwe
Level 9
Level 9
Posts: 2670
Joined: Sun Sep 11, 2016 11:18 pm

Re: Update not working

Post by michael louwe » Sat Apr 21, 2018 3:42 am

Try >Update Manager >Edit >Software Sources >Restore the default settings. Reboot. Then set the update settings properly and >Refresh >Install updates.

mathewmindfreak
Level 1
Level 1
Posts: 6
Joined: Thu Apr 19, 2018 11:53 am

Re: Update not working

Post by mathewmindfreak » Sat Apr 21, 2018 6:57 am

dude, i tried all this. this is the error i keep getting the error i posted above

mathewmindfreak
Level 1
Level 1
Posts: 6
Joined: Thu Apr 19, 2018 11:53 am

Re: Update not working

Post by mathewmindfreak » Fri Apr 27, 2018 7:12 am

the issue is resolved. I was using my university wifi. i think they have blocked the mirrors from which updates was being downloaded. I switched to another wifi and update worked smoothly. Sorry and thanks everyone who helped

Post Reply

Return to “Newbie Questions”