Hibernate breaks startup (laptop boots to black screen)

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
robined
Level 1
Level 1
Posts: 4
Joined: Mon Apr 23, 2018 10:48 am

Hibernate breaks startup (laptop boots to black screen)

Post by robined » Mon Apr 23, 2018 11:07 am

Suspend works fine, but after sudo pm-hibernate, when the laptop boots up I get grub, then the mint logo, then five dots go green and then a black screen. Turning the laptop off and on via the power button then gets me back to Cinnamon login screen, but obviously no saved state.

$ inxi -Fxz
System: Host: T460s Kernel: 4.13.0-38-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.3 Sylvia
Machine: System: LENOVO (portable) product: 20F9CTO1WW v: ThinkPad T460s
Mobo: LENOVO model: 20F9CTO1WW v: 0B98417 WIN
Bios: LENOVO v: N1CET62W (1.30 ) date: 11/27/2017
CPU: Dual core Intel Core i7-6600U (-HT-MCP-) cache: 4096 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11232
clock speeds: max: 3400 MHz 1: 2499 MHz 2: 2500 MHz 3: 2500 MHz
4: 2500 MHz
Graphics: Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 2560x1440@60.00hz
GLX Renderer: Mesa DRI Intel HD Graphics 520 (Skylake GT2)
GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio: Card Intel Sunrise Point-LP HD Audio
driver: snd_hda_intel bus-ID: 00:1f.3
Sound: Advanced Linux Sound Architecture v: k4.13.0-38-generic
Network: Card-1: Intel Ethernet Connection I219-LM
driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
IF: enp0s31f6 state: down mac: <filter>
Card-2: Intel Wireless 8260 driver: iwlwifi bus-ID: 04:00.0
IF: wlp4s0 state: up mac: <filter>
Drives: HDD Total Size: 256.1GB (16.6% used)
ID-1: /dev/sda model: SAMSUNG_MZNTY256 size: 256.1GB
Partition: ID-1: / size: 96G used: 23G (25%) fs: ext4 dev: /dev/sda5
ID-2: swap-1 size: 19.70GB used: 0.00GB (0%) fs: swap dev: /dev/sda6
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 44.0C mobo: N/A
Fan Speeds (in rpm): cpu: 0
Info: Processes: 223 Uptime: 15 min Memory: 2332.2/7706.4MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

jamesb7a
Level 3
Level 3
Posts: 100
Joined: Sat Jun 17, 2017 9:32 pm

Re: Hibernate breaks startup (laptop boots to black screen)

Post by jamesb7a » Mon Apr 23, 2018 11:20 am

Ive had the same problem, hibernate IMO should NEVER be used, either use suspend or shut down.

robined
Level 1
Level 1
Posts: 4
Joined: Mon Apr 23, 2018 10:48 am

Re: Hibernate breaks startup (laptop boots to black screen)

Post by robined » Wed May 02, 2018 2:15 am

Hibernate writes to disk, this saves battery and also means the information is not stored in a semi-volatile state, ie if you run out of battery whilst suspended to RAM you get artifacts when repowering and turning on IMHO hibernate is quite important. Anyone any ideas how to get it working?

User avatar
AZgl1500
Level 8
Level 8
Posts: 2315
Joined: Thu Dec 31, 2015 3:20 am
Location: Oklahoma where the wind comes sweeping down the plains
Contact:

Re: Hibernate breaks startup (laptop boots to black screen)

Post by AZgl1500 » Wed May 02, 2018 2:41 am

Hibernate and suspend both crash and lock up my ASUS laptop.
I have them both turned OFF

robined
Level 1
Level 1
Posts: 4
Joined: Mon Apr 23, 2018 10:48 am

Re: Hibernate breaks startup (laptop boots to black screen)

Post by robined » Mon Aug 20, 2018 1:57 am

Upgraded to Mint 19 and hibernate still doesn't work.Battery drain during suspend is high.

carum carvi
Level 3
Level 3
Posts: 192
Joined: Sun Apr 16, 2017 11:44 pm

Re: Hibernate breaks startup (laptop boots to black screen)

Post by carum carvi » Mon Aug 20, 2018 4:59 pm

Hibernation is disabled in LM19 as far as I know. Only suspend is available. Hibernation is one of the most complained issues by new users of Linux, because hibernation crashed many linux systems in the past years.

When suspend does work, as is your good luck, please try to comfort yourself with the idea that you are better off then many others.

There are some tips though from experienced forummembers, that can help in certain cases. Tweaking network drivers and changing kernel version might help some. One link with possibly helpful tips is found below.

viewtopic.php?f=46&t=274817

Post Reply

Return to “Newbie Questions”