[Solved] NTFS partition not working due to Windows 10

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
Aily
Level 1
Level 1
Posts: 38
Joined: Sat Jun 03, 2017 11:57 am
Location: Skaune

[Solved] NTFS partition not working due to Windows 10

Post by Aily »

Hello,

I'm using Linux Mint MATE 18.1 Serena 64-bit at the moment.

After several months, a week ago, I started my PC in Windows 10. It's poorly updated and when I started it it was updating only to have the screen turn black with just the pointer visible. I didn't care much about it and just left it and started in LM again.

My problem: Today though, when I wanted to open a NTFS-partition I couldn't due to this:

Code: Select all

[b]Unable to mount C-STORAGE[/b]

Error mounting /dev/sda3 at /media/aily/C-STORAGE: 
Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000" 
"/dev/sda3" "/media/aily/C-STORAGE"' exited with non-zero exit status 14: The disk 
contains an unclean file system (0, 0).
Metadata kept in Windows cache, refused to mount.
Failed to mount '/dev/sda3': Operation not permitted
The NTFS partition is in an unsafe state. Please resume and shutdown
Windows fully (no hibernation or fast restarting), or mount the volume
read-only with the 'ro' mount option.
As it is now, I can't start in windows at all. Is there a way around this, or do I need to remove windows? I've turned my PC off fully from LM a couple of times since I tried to open windows.

Also, if I need to remove windows or rather re-install it, since I use it now and then for some games, will it over-write my grub?

Thank you.

Edit: I ended up reinstalling windows 10.
Last edited by Aily on Sun Apr 29, 2018 9:53 am, edited 1 time in total.
I know how to start my computer. (IEC 60417-5009)
User avatar
Pierre
Level 20
Level 20
Posts: 10944
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: NTFS partition not working due to Windows 10

Post by Pierre »

so read the last part of that error : "The NTFS partition is in an unsafe state.".

which means that the windows system is most likely still in it's hibernation state.
- you will need to boot back into the windows system & Turn Off Fast Start ..

if you can't get back into the windows system, then you will need to either do a repair installation,
or a clean re-installation of the windows system.

if you do any installation of the windows system then that will overwrite the Grub Boot Loader,
and you will then need to re-install that Grub Boot Loader, from your LinuxMint installation media.

if you don't wish to do either of those, then there are ways to force-ably mount the windows system,
in order to recover any Data Files that you may need.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.
MintyUser
Level 1
Level 1
Posts: 2
Joined: Sat Oct 27, 2018 1:34 pm

Re: [Solved] NTFS partition not working due to Windows 10

Post by MintyUser »

Hi, This thread is a top result for "Linux Mint Windows 10 Drive Read Only", and I have this alternative solution:

After the April 2018 Windows 10 Update, Windows (re)enabled "fast startup".

Fast Startup leaves NTFS drives in a "hybrid hibernate mode". Turning off Fast Startup allowed Linux Mint 19 to load partitions Read\Write.

Steps:
  • Start
  • Control Panel
  • Power Options
  • Choose what the power buttons do
  • Change settings that are currently unavailable
  • Turn on fast startup (recommended) UNCHECK
  • Save changes.
Source 1 - https://www.windowscentral.com/how-disa ... st-startup
Source 2 - viewtopic.php?f=49&t=275899#p1514275
Post Reply

Return to “Newbie Questions”