Page 1 of 2

Spell Checker not working.

Posted: Mon May 14, 2018 10:42 am
by Andow
I selected hyphen en us, and mythes LibreOffice from synaptic for instillation, it seemed to install ok, Then rebooted, checked spell checker but no good not working. Any advice will be appreciated

User name-Lenovo-ideapad-100S ~ $ inxi -Szxx
System: Host: rpa3-Lenovo-ideapad-100S Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.3) dm: mdm
Distro: Linux Mint 18.1 Serena
User name-Lenovo-ideapad-100S ~ $

Re: Spell Checker not working.

Posted: Mon May 14, 2018 7:28 pm
by turtlebay
You must install a dictionary for it to work from in Synaptic Package Manager or Software Manager.

In Linux, it isn't normally necessary to restart the system when installing software, that is a Microsoft-only idiosyncrasy.

Re: Spell Checker not working.

Posted: Tue May 15, 2018 1:34 am
by cabbagetreemo
You could try to install

Code: Select all

myspell-en-us
and then use the following commands to create links

Code: Select all

sudo ln -s /usr/share/hunspell/en_US.dic /usr/share/myspell/dicts/

Code: Select all

sudo ln -s /usr/share/hunspell/en_US.aff /usr/share/myspell/dicts/
There may be a final setting in LibreOffice but this should provide a system wide dictionary. For example in TeXworks one would find the menu Edit>Spelling and after running the above commands there should be an option for US English. There are other languages available in myspell which you can find in Software Manager.

Note that you probably have to restart whatever editor you use (but not your whole system) to get the links to appear.

Re: Spell Checker not working.

Posted: Tue May 15, 2018 5:34 am
by Andow
cabbagetreemo wrote:
Tue May 15, 2018 1:34 am
You could try to install

Code: Select all

myspell-en-us
and then use the following commands to create links

Code: Select all

sudo ln -s /usr/share/hunspell/en_US.dic /usr/share/myspell/dicts/

Code: Select all

sudo ln -s /usr/share/hunspell/en_US.aff /usr/share/myspell/dicts/
There may be a final setting in LibreOffice but this should provide a system wide dictionary. For example in TeXworks one would find the menu Edit>Spelling and after running the above commands there should be an option for US English. There are other languages available in myspell which you can find in Software Manager.

Note that you probably have to restart whatever editor you use (but not your whole system) to get the links to appear.
[When you say system wide dictionary will that apply to Libreoffice writer and Thunderbird mailer and Firefox browser as well. ]

Re: Spell Checker not working.

Posted: Tue May 15, 2018 5:53 am
by cabbagetreemo
Yes, it will apply to everything but you may have to enable from within specific applications (i.e. my example for TeXworks, I don't use Libre or Thunderbird so I don't know the exact menus you need)

Re: Spell Checker not working.

Posted: Thu May 17, 2018 4:37 am
by Andow
cabbagetreemo wrote:
Tue May 15, 2018 5:53 am
Yes, it will apply to everything but you may have to enable from within specific applications (i.e. my example for TeXworks, I don't use Libre or Thunderbird so I don't know the exact menus you need)
[Hi cabbagetreemo. Thanks for the input, but ill bat on with Thunderbird]

Re: Spell Checker not working.

Posted: Thu May 17, 2018 5:39 am
by Andow
Andow wrote:
Tue May 15, 2018 5:34 am
cabbagetreemo wrote:
Tue May 15, 2018 1:34 am
You could try to install

Code: Select all

myspell-en-us
and then use the following commands to create links

Code: Select all

sudo ln -s /usr/share/hunspell/en_US.dic /usr/share/myspell/dicts/

Code: Select all

sudo ln -s /usr/share/hunspell/en_US.aff /usr/share/myspell/dicts/
There may be a final setting in LibreOffice but this should provide a system wide dictionary. For example in TeXworks one would find the menu Edit>Spelling and after running the above commands there should be an option for US English. There are other languages available in myspell which you can find in Software Manager.

Note that you probably have to restart whatever editor you use (but not your whole system) to get the links to appear.
[When you say system wide dictionary will that apply to Libreoffice writer and Thunderbird mailer and Firefox browser as well. ]

[When I entered myspell-en-us in the terminal it returned with "myspell-en-us: command not found" . When I check in software manager it shows myspell ticked, I presume that means its installed?.]

Re: Spell Checker not working.

Posted: Thu May 17, 2018 5:41 am
by cabbagetreemo
to install something you don't just type its name you have to use a package manager, often apt-get. So you would type

Code: Select all

sudo apt-get install myspell-en-us
It is possible that the en-us package is already installed in which case you only need to create the symbolic links

Re: Spell Checker not working.

Posted: Fri May 18, 2018 4:46 am
by Andow
cabbagetreemo wrote:
Thu May 17, 2018 5:41 am
to install something you don't just type its name you have to use a package manager, often apt-get. So you would type

Code: Select all

sudo apt-get install myspell-en-us
It is possible that the en-us package is already installed in which case you only need to create the symbolic links

sudo apt-get install myspell-en-us in terminal, unpacked OK,even though it was shown as installed in software manager before hand. It doesn't show up anywhere not in tools, option language setting, writing aids.
Then look under spell check options, writing aids, user defined dictionary, I see with an X check mark, standard English- Australian, X Technical all, X Ignore all lists.
Its creating the symbolic links that seems to be the issue, maybe its just broken!]

Re: Spell Checker not working.

Posted: Fri May 18, 2018 5:53 am
by cabbagetreemo
Did you type the commands I gave in my first reply exactly as I wrote them AFTER installing myspell-en-us?

Re: Spell Checker not working.

Posted: Fri May 18, 2018 10:46 pm
by Andow
cabbagetreemo wrote:
Fri May 18, 2018 5:53 am
Did you type the commands I gave in my first reply exactly as I wrote them AFTER installing myspell-en-us?

[Yes here is the output
User Name-Lenovo-ideapad-100S ~ $ sudo apt-get install myspell-en-us
[sudo] password for rpa3:
Reading package lists... Done
Building dependency tree
Reading state information... Done
myspell-en-us is already the newest version (1:5.1.0-1ubuntu2.2).
0 to upgrade, 0 to newly install, 0 to remove and 30 not to upgrade.
User Name-Lenovo-ideapad-100S ~ $ ]

I read somewhere that Myspell was designed OpenOffice ?

Re: Spell Checker not working.

Posted: Fri May 18, 2018 11:23 pm
by cabbagetreemo
That means you have mysepll-en-us installed, that's the first step.

Now can you post the output of

Code: Select all

ls /usr/share/myspell/dicts/

Re: Spell Checker not working.

Posted: Sat May 19, 2018 12:05 am
by Andow
cabbagetreemo wrote:
Fri May 18, 2018 11:23 pm
That means you have mysepll-en-us installed, that's the first step.

Now can you post the output of

Code: Select all

ls /usr/share/myspell/dicts/
[User Name-Lenovo-ideapad-100S ~ $ ls /usr/share/myspell/dicts/
en_US.aff hyph_en_CA.dic hyph_fi_FI.dic hyph_id_ID.dic
en_US.dic hyph_en_US.dic hyph_ga_IE.dic
User Name-Lenovo-ideapad-100S ~ $

Finger crossed]

Re: Spell Checker not working.

Posted: Sat May 19, 2018 12:13 am
by cabbagetreemo
It looks to me like you have set up the symbolic links correctly, whatever you need to do next is program specific. As I said, I don't use LibreOffice so I will not be able to help you further.

Re: Spell Checker not working.

Posted: Sat May 19, 2018 12:56 am
by Andow
cabbagetreemo wrote:
Sat May 19, 2018 12:13 am
It looks to me like you have set up the symbolic links correctly, whatever you need to do next is program specific. As I said, I don't use LibreOffice so I will not be able to help you further.

[I'm thinking its broken,I may uninstall LibreOffice and reinstall, it may fix it.
Thank you so much for your time and effort Cabbagetreemo
]

Re: Unresolved & abandoned Spell Checker not working.

Posted: Thu Jun 07, 2018 2:52 am
by Andow
Andow wrote:
Sat May 19, 2018 12:56 am
cabbagetreemo wrote:
Sat May 19, 2018 12:13 am
It looks to me like you have set up the symbolic links correctly, whatever you need to do next is program specific. As I said, I don't use LibreOffice so I will not be able to help you further.

[I'm thinking its broken,I may uninstall LibreOffice and reinstall, it may fix it.
Thank you so much for your time and effort Cabbagetreemo
]

Re: Unresolved & abandoned Spell Checker not working.

Posted: Thu Jun 07, 2018 2:53 am
by Andow
Andow wrote:
Mon May 14, 2018 10:42 am
I selected hyphen en us, and mythes LibreOffice from synaptic for instillation, it seemed to install ok, Then rebooted, checked spell checker but no good not working. Any advice will be appreciated

User name-Lenovo-ideapad-100S ~ $ inxi -Szxx
System: Host: rpa3-Lenovo-ideapad-100S Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.3) dm: mdm
Distro: Linux Mint 18.1 Serena
User name-Lenovo-ideapad-100S ~ $

Re:Spell Checker not working.

Posted: Thu Jun 07, 2018 2:54 am
by Andow
Andow wrote:
Thu Jun 07, 2018 2:53 am
Andow wrote:
Mon May 14, 2018 10:42 am
I selected hyphen en us, and mythes LibreOffice from synaptic for instillation, it seemed to install ok, Then rebooted, checked spell checker but no good not working. Any advice will be appreciated

User name-Lenovo-ideapad-100S ~ $ inxi -Szxx
System: Host: rpa3-Lenovo-ideapad-100S Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.3) dm: mdm
Distro: Linux Mint 18.1 Serena
User name-Lenovo-ideapad-100S ~ $

Re:Unresolved & abandone Spell Checker not working.

Posted: Thu Jun 07, 2018 2:55 am
by Andow
Andow wrote:
Mon May 14, 2018 10:42 am
I selected hyphen en us, and mythes LibreOffice from synaptic for instillation, it seemed to install ok, Then rebooted, checked spell checker but no good not working. Any advice will be appreciated

User name-Lenovo-ideapad-100S ~ $ inxi -Szxx
System: Host: rpa3-Lenovo-ideapad-100S Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.3) dm: mdm
Distro: Linux Mint 18.1 Serena
User name-Lenovo-ideapad-100S ~ $

Re:Spell Checker not working.

Posted: Thu Jun 07, 2018 2:56 am
by Andow
Andow wrote:
Thu Jun 07, 2018 2:55 am
Andow wrote:
Mon May 14, 2018 10:42 am
I selected hyphen en us, and mythes LibreOffice from synaptic for instillation, it seemed to install ok, Then rebooted, checked spell checker but no good not working. Any advice will be appreciated

User name-Lenovo-ideapad-100S ~ $ inxi -Szxx
System: Host: rpa3-Lenovo-ideapad-100S Kernel: 4.4.0-53-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Cinnamon 3.2.7 (Gtk 3.18.9-1ubuntu3.3) dm: mdm
Distro: Linux Mint 18.1 Serena
User name-Lenovo-ideapad-100S ~ $