[SOLVED] Slow shutdown on dual boot system

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
FuuFuu1337
Level 1
Level 1
Posts: 1
Joined: Wed May 16, 2018 1:56 pm

[SOLVED] Slow shutdown on dual boot system

Post by FuuFuu1337 » Sat May 19, 2018 5:05 am

Hello,

I just installed linux mint 18.3 alongside windows 10. Most things work as I want them to, except on shutdown / restart the system takes around 2-3 minutes to shut down.
Of course this is really annoying in a dual boot system because I frequently change OS for different tasks (multiple times a day).
As I've red in other posts in the internet this is a more or less common problem with Linux Mint / Ubuntu but I could not find any solutions that solved my problem.

Output of `inxi -Fxz`
System: Host: joro-ThinkPad-T480s Kernel: 4.16.9-041609-generic x86_64 (64 bit gcc: 7.3.0)
Desktop: Cinnamon 3.6.7 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia
Machine: System: LENOVO (portable) product: 20L8S02E00 v: ThinkPad T480s
Mobo: LENOVO model: 20L8S02E00 Bios: LENOVO v: N22ET35W (1.12 ) date: 04/09/2018
CPU: Quad core Intel Core i7-8550U (-HT-MCP-) cache: 8192 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 15936
clock speeds: max: 4000 MHz 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz 5: 800 MHz 6: 800 MHz
7: 800 MHz 8: 800 MHz
Graphics: Card-1: Intel Device 5917 bus-ID: 00:02.0
Card-2: NVIDIA Device 1d12 bus-ID: 01:00.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 2560x1440@60.00hz
GLX Renderer: Mesa DRI Intel Kabylake GT1.5 GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio: Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3 Sound: ALSA v: k4.16.9-041609-generic
Network: Card-1: Intel Ethernet Connection (4) I219-V driver: e1000e v: 3.2.6-k bus-ID: 00:1f.6
IF: enp0s31f6 state: down mac: <filter>
Card-2: Intel Device 24fd driver: iwlwifi bus-ID: 3d:00.0
IF: wlp61s0 state: up speed: N/A duplex: N/A mac: <filter>
Drives: HDD Total Size: NA (-) ID-1: /dev/nvme0n1 model: N/A size: 512.1GB
Partition: ID-1: / size: 330G used: 28G (9%) fs: ext4 dev: /dev/nvme0n1p4
ID-2: swap-1 size: 17.07GB used: 0.00GB (0%) fs: swap dev: /dev/nvme0n1p5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 42.5C mobo: N/A
Fan Speeds (in rpm): cpu: 3659
Info: Processes: 225 Uptime: 9:56 Memory: 1834.0/15935.1MB Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (zsh 5.1.1) inxi: 2.2.35

What I've tried so far:
1. https://askubuntu.com/questions/369613/ ... w-shutdown follow the accepted answer to debug what goes on on shutdown... It did not work as explained.. apport did not open any alter window nor did any .crash logs appear in the mentioned folder.
2. Install proprietary software (qshutdown)
3. Turn off wireless adapter before shutdown

I would be really grateful for any advice (being able to debug this would probably make it way easier for me to solve this problem)

E: I solved the problem for me, but I guess my problem was very specific.
So after digging for a while and trial and error shutting down processes before rebooting I found out that it was the chat messenger "Telegram" that was causing the system not to shut down properly.
Upon researching the cause I found that I had (without me knowing) two running telegram applications one called telegram and one called telegram-desktop, so upon shutdown only one instance was exited correctly, the other froze and was only killed after 300 seconds (I guess this is the default kill timeout for frozen applications upon shutdown in linux).

So yeah.. very specific but maybe it will help someone else.

Best Regards

deepakdeshp
Level 11
Level 11
Posts: 3796
Joined: Sun Aug 09, 2015 10:00 am

Re: [SOLVED] Slow shutdown on dual boot system

Post by deepakdeshp » Wed May 23, 2018 12:41 am

Thanks for sharing your experience.
If I have helped you solve a problem, please add [SOLVED] to your first post title, it helps other users looking for help, and keeps the forum clean.
I am using Mint 19 Cinnamon 64 bit with AMD A8/7410 processor . Memory 8GB

Post Reply

Return to “Newbie Questions”