Type Amharic on LM 18.3 Mate

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
tatariw
Level 1
Level 1
Posts: 4
Joined: Sun May 20, 2018 10:03 am

Type Amharic on LM 18.3 Mate

Post by tatariw » Sun May 20, 2018 10:18 am

Hello,

Installed ibus-m17n and configured Amharic keyboard.
Started to type Amharic and everything seems to work except only one thing. I have even logged out and restarted the PC.
The last letter in a word moves with a space-bar marker when I press a space to have a space between words.
There is no issue with Debian 8 and 9. Works perfect except on LM.

I have searched to find a solution but no success. For ex. on:
https://community.linuxmint.com/tutorial/view/1558
https://askubuntu.com/questions/606286/ ... untu-14-04
http://linux4abeshas.blogspot.no/2012/0 ... buntu.html
https://unix.stackexchange.com/question ... linux-mint
...and more.

I hope someone can help!

tatariw
Level 1
Level 1
Posts: 4
Joined: Sun May 20, 2018 10:03 am

Re: Type Amharic on LM 18.3 Mate

Post by tatariw » Tue May 22, 2018 12:44 pm

Hello,
Just in case, here is more information. Typing in Amharic works just fine on Debian 8 and 9 Cinnamon, Mate and XFCE.
I want to use LM because of some hardware issue. When it comes to typing in Amharic, I think something is changed in IBUS functionality and behavior in LM or Ubuntu. I can't think of other reason right now.
Hope this can be seen as a problem in LM community which should be solved.

What i meant by: "The last letter in a word moves with a space-bar marker"
For ex. if writing " What is going on? "
The output looks like this:
Wha ti sgoin go n? (happens only when typing in Amharic)

Should be like this: ምን እየተካሄደ ነው?
I get this: ም ንእየተካሄ ደነው?
Pressing right arrow and then space helps but that is not the way it should be.
Thanks for you time.

User avatar
GS3
Level 4
Level 4
Posts: 264
Joined: Fri Jan 06, 2017 7:51 am

Re: Type Amharic on LM 18.3 Mate

Post by GS3 » Sat May 26, 2018 6:12 am

My experience with non-Latin alphabet inputs is that they are buggy and that you will find almost no useful support because very few people use them. This is in contrast with Windows which has very good support since Win XP and even in Win 98 you could install it and it worked. You can see I have an ongoing thread asking about problems with Chinese input.

Does it happen in all programs alike? I assume several keystrokes are required for each character. Maybe if you explain how the input is done someone can try to help.

It seems to me when you have a situation where several keystrokes are needed to complete one character the input handler needs to know where one input ends and the next begins and sometimes this is programmed wrong. It seems like when one character follows another character it is getting it right but somehow when it is followed by a space it puts the space before the character. It seems like a bug of the input handler.

I wish you luck but you might have to just find a work-around.
HP Compaq Elite 8300 CMT - Linux Mint 18.2 Sonya - Kernel 4.4.0-116-generic X64 - Cinnamon 3.4.4 - Nemo

tatariw
Level 1
Level 1
Posts: 4
Joined: Sun May 20, 2018 10:03 am

Re: Type Amharic on LM 18.3 Mate [Solved]

Post by tatariw » Tue May 29, 2018 9:41 am

GS3 wrote:
Sat May 26, 2018 6:12 am
It seems to me when you have a situation where several keystrokes are needed to complete one character the input handler needs to know where one input ends and the next begins ......
I wish you luck but you might have to just find a work-around.
Yes, this is also correct way of explaining the situation. Thanks GS3! 8)

In the end, I have found a solution. Took me to searching and trying and this page: https://wiki.debian.org/I18n/ibus is useful. :D :D :D
Just installed ibus-gtk and ibus-gtk3 from Synaptic in addition. Works like a charm. It was not necessary to install language support in language settings as well as long as one has a font installed....I think.
To be sure, have even tested on an other old PC with a fresh LM Mate installation. Have marked the thread as solved from my part.
Have a pleasant day. :!:

Post Reply

Return to “Newbie Questions”