[Resolved] How do I prevent a program from auto-starting?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
tovian
Level 5
Level 5
Posts: 529
Joined: Sun Nov 22, 2015 1:17 pm
Location: Heart of Dixie

[Resolved] How do I prevent a program from auto-starting?

Post by tovian » Thu May 24, 2018 4:53 pm

Someone recently wrote about "Anydesk" being a good replacement for TeamViewer so I installed it.
That's the kind of program I use ONLY on-demand... I DO NOT want it (Anydesk) running 24x7 in the background.

Anydesk autostarts when Linux or KDE starts, and the icon sits in the tray. I have looked in every location I know to look and cannot find a way to prevent the autostart. The app interface also does not give that option.

Does anyone know other places I can look to defeat this little critter? If not, I will uninstall it and never look back.

Thanks in advance !!
Last edited by tovian on Sat May 26, 2018 9:10 am, edited 2 times in total.
“I think that this situation absolutely requires a really futile and stupid gesture be done on somebody's part!"
"We're just the guys to do it.”

Animal House

User avatar
smgordon1259
Level 2
Level 2
Posts: 68
Joined: Tue Jul 30, 2013 6:12 pm
Location: Wisconsin, USA

Re: How do I prevent a program from auto-starting?

Post by smgordon1259 » Thu May 24, 2018 5:01 pm

maybe check the settings and change the in TEAM VIEWER or uninstall , then re install pay attention to the installation when it asks if you want auto start. or you can just shut it off until you need it.

has nothing to do with linux.
ASUS M5A78L-M/USB3
AMD FX-4350 (4.2gHz)
MSI GeForce GT730 - 2gb Memory
Linux Mint 19 MATE amd64/ Kernel 4.15.0-30
Primary: Seagate 500GB SSHD, Secondary: Seagate 1TB SSHD, Tertiary: Hitachi 750GB HD

Mute Ant
Level 13
Level 13
Posts: 4897
Joined: Tue Sep 03, 2013 7:45 pm

Re: How do I prevent a program from auto-starting?

Post by Mute Ant » Thu May 24, 2018 7:36 pm

"... looked in every location I know to look..." An invitation for a stream of suggestions you have already tried? It sounds like a daemon, I would...

1) Try a ps -e to look for the running-in-the-background command, then look for a systemd service with that name.
...or...
2) Un-zip a copy of the debian package to see what it installs and where.
Data stored in an encrypted volume will only be accessible with the original password. Without this key, all the data will remain scrambled beyond hope of recovery.

User avatar
Flemur
Level 15
Level 15
Posts: 5919
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: How do I prevent a program from auto-starting?

Post by Flemur » Thu May 24, 2018 8:26 pm

tovian wrote:
Thu May 24, 2018 4:53 pm
That's the kind of program I use ONLY on-demand... I DO NOT want it (Anydesk) running 24x7 in the background.
I feel your pain.

There should be a "Startup Applications" in your menu; if you're lucky, it'll be listed there.
Also check
~/.config/autostart
for *.desktop files.

Edit: to see the enabled services (Mint 18.x only):

Code: Select all

systemctl list-unit-files | grep enabled
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

User avatar
tovian
Level 5
Level 5
Posts: 529
Joined: Sun Nov 22, 2015 1:17 pm
Location: Heart of Dixie

Re: How do I prevent a program from auto-starting?

Post by tovian » Fri May 25, 2018 4:17 pm

Flemur wrote:
Thu May 24, 2018 8:26 pm
There should be a "Startup Applications" in your menu; if you're lucky, it'll be listed there.
Also check
~/.config/autostart
for *.desktop files.
I had already checked those and found nothing. Also, I'm having the issue on an earlier version (pre-18). I have a feeling it's a service, I just haven't proved it yet. I know TeamViewer wants to run its service 24x7, but in Windows that's very easy to defeat.

THANKS for your input !!
“I think that this situation absolutely requires a really futile and stupid gesture be done on somebody's part!"
"We're just the guys to do it.”

Animal House

User avatar
Flemur
Level 15
Level 15
Posts: 5919
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: How do I prevent a program from auto-starting?

Post by Flemur » Fri May 25, 2018 10:11 pm

tovian wrote:
Fri May 25, 2018 4:17 pm
I have a feeling it's a service, I just haven't proved it yet.
Didja check for the service?

Code: Select all

systemctl list-unit-files | grep enabled
Look thru the output for something related to "team viewer".
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

User avatar
WharfRat
Level 20
Level 20
Posts: 11428
Joined: Thu Apr 07, 2011 8:15 pm

Re: How do I prevent a program from auto-starting?

Post by WharfRat » Fri May 25, 2018 11:38 pm

Look in /etc/xdg/autostart/ for a file called anydesk.desktop
ImageImage

User avatar
phd21
Level 16
Level 16
Posts: 6544
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: How do I prevent a program from auto-starting?

Post by phd21 » Sat May 26, 2018 12:51 am

Hi tovian,

I just read your post and the good replies to it. Here are my thoughts on this as well.

I have both Anydesk and Teamviewer installed and like you I do not want them automatically starting with my system.

1.) Anydesk: I think WharfRat is on the right track. I disabled the anydesk autostart by moving their anydesk.desktop file to my documents folder from the autostart folder. They should have the option to not start it automatically.

type in the command below to see where the anydesk files are located on your system, then move the anydesk.desktop file from the autostart location to somewhere else or delete it.

Code: Select all

locate anydesk
2.) Teamviewer's default typical Linux installation installs an always running "teamviewerd" service daemon which can be turned off or disabled until you restart it (enable it) from the console terminal. OR, you can use their portable archive file without integrating it into your system which does not install the "teamviewerd" service (this is what I do now). There are slight differences in the two versions, but they both work perfectly.

See post below on Linux services
How to disable bluetooth at startup - Linux Mint Forums
viewtopic.php?f=47&t=268219&hilit=service
For using the TeamViewer archive (portable) version, Install the following QT dependency packages from the "Synaptic Package Manager (SPM)":
qml-module-qtquick-dialogs (5.5.1-1ubuntu1)
qml-module-qtquick-extras (5.5.1-1ubuntu1)
qml-module-qtquick-privatewidgets (5.5.1-1ubuntu1)
qtdeclarative5-dialogs-plugin (5.5.1-1ubuntu1)

Teamviewer 13 download 64-bit Linux archive install
https://download.teamviewer.com/downloa ... d64.tar.xz

Teamviewer 13 download 32-bit Linux archive install
https://download.teamviewer.com/downloa ... 386.tar.xz
If you have the typical Teamviewer installed from their Linux "deb" file and want to control the teamviewer service daemon:
First, find out exactly what your Teamviewer service is called (teamviewerd).

Code: Select all

sudo service --status-all
Then, there are 2 options for controlling the service:

Code: Select all

sudo service teamviewerd stop
*** or this permanently disables a service until you enable it again, even after restarting (rebooting).

Code: Select all

sudo systemctl disable teamviewerd.service


Hope this helps ...
Last edited by phd21 on Tue Jun 19, 2018 6:27 pm, edited 8 times in total.
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

DAMIEN1307
Level 5
Level 5
Posts: 793
Joined: Tue Feb 21, 2017 8:13 pm

Re: How do I prevent a program from auto-starting?

Post by DAMIEN1307 » Sat May 26, 2018 7:24 am

have you tried "bootup-manager" yet?...DAMIEN

User avatar
tovian
Level 5
Level 5
Posts: 529
Joined: Sun Nov 22, 2015 1:17 pm
Location: Heart of Dixie

Re: How do I prevent a program from auto-starting?

Post by tovian » Sat May 26, 2018 9:09 am

WharfRat wrote:
Fri May 25, 2018 11:38 pm
Look in /etc/xdg/autostart/ for a file called anydesk.desktop
Perfect !!! Found it; moved it; no more autostart. 8)

@phd21 - excellent information.

THANK YOU VERY MUCH to all who assisted !!!

:D :D
Last edited by tovian on Sat May 26, 2018 9:39 am, edited 1 time in total.
“I think that this situation absolutely requires a really futile and stupid gesture be done on somebody's part!"
"We're just the guys to do it.”

Animal House

User avatar
phd21
Level 16
Level 16
Posts: 6544
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: How do I prevent a program from auto-starting?

Post by phd21 » Sat May 26, 2018 9:27 am

Hi tovian,

You are welcome from all of us that replied...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

Post Reply

Return to “Newbie Questions”