Cannot Write to USB Drive

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Level 2
Level 2
Posts: 77
Joined: Thu May 17, 2012 9:50 pm
Location: Cincinnati, Ohio

Cannot Write to USB Drive

Post by wmichaelb » Thu May 31, 2018 10:36 pm

I'm running Mint 17/64 bit. My machine has a 1.5 GB HD that I use for general storage. Today, I cannot write from it to any USB drive; I keep getting an error message stating that the destination is read-only. I tried:

sudo chmod 666 /dev/sdh

which ran without feedback, but did not fix the problem. To test the USB drive, I ran:

sda 8:0 0 931.5G 0 disk
├─sda1 8:1 0 195.3G 0 part /
├─sda2 8:2 0 1K 0 part
├─sda3 8:3 0 734.3G 0 part /home
└─sda5 8:5 0 2G 0 part [SWAP]
sdb 8:16 0 931.5G 0 disk
├─sdb1 8:17 0 464.9G 0 part /media/mikeb/Garage
└─sdb2 8:18 0 466.7G 0 part
sdc 8:32 0 1.4T 0 disk
└─sdc1 8:33 0 1.4T 0 part /media/mikeb/Shed
sdh 8:112 1 14.9G 0 disk
└─sdh1 8:113 1 14.9G 0 part /media/mikeb/Lexar
sr0 11:0 1 2K 0 rom
mikeb@Lynxtoid ~ $ X="/dev/sdh"
mikeb@Lynxtoid ~ $ sudo dd if="$X" of="$X" bs=512 count=1
1+0 records in
1+0 records out
512 bytes (512 B) copied, 0.00232726 s, 220 kB/s

But it won't work when I attempt this with the file manager. I've also tried three different USB ports on the machine. Does anyone have a suggestion? Thanks in advance.

User avatar
Level 7
Level 7
Posts: 1868
Joined: Mon Mar 22, 2010 3:21 pm
Location: UK Lake District

Re: Cannot Write to USB Drive

Post by caf4926 » Thu May 31, 2018 11:37 pm

Is there a locking device built in to the USB? It's usually a very small inconspicuous toggle

You could zero the device with dd
But be careful
Linux Mint 19.1 Cinnamon

Post Reply

Return to “Newbie Questions”