Problem with wireless connection

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Bocien
Level 1
Level 1
Posts: 6
Joined: Wed Jun 06, 2018 5:30 pm

Problem with wireless connection

Post by Bocien »

Hi,
After installing Linux Mint everything seemed fine except I can't connect to Wi-Fi. I plugged in the LiveUSB but I can't download any drivers and I can't download it from the internet bcs my laptop dosen't have a spot for the ethernet cable.
Next I typed the inxi -N command in the terminal and I received 'Failed to Detect Network Card!' but yesterday I had Lubuntu installed on that laptop and I had no problems connecting to Wi-Fi
What more can I do to make Wi-Fi work on Linux Mint?

JeremyB
Level 20
Level 20
Posts: 11635
Joined: Fri Feb 21, 2014 8:17 am

Re: Problem with wireless connection

Post by JeremyB »

What Lubuntu version compared to what Mint version? Lubuntu 18.04/Mint 19?

Bocien
Level 1
Level 1
Posts: 6
Joined: Wed Jun 06, 2018 5:30 pm

Re: Problem with wireless connection

Post by Bocien »

I had lubuntu 18.04 and changed it to Linux Mint 18.3. Also I forgot to mention that previously I had Windows 10 installed and also had no problems with Wi-Fi. But I had to change it to something lightweight because it's not a powerful laptop. The model of laptop is Kiano Slimnote 14.2

Hoser Rob
Level 16
Level 16
Posts: 6123
Joined: Sat Dec 15, 2012 8:57 am

Re: Problem with wireless connection

Post by Hoser Rob »

If it'll run with Lubuntu is should work with Mint 18.x, but first you need to post some meaningful system info. Copy/paste this into the terminal and copy/paste the text output here (no screenshots please):

Code: Select all

inxi -Fxz

acerimusdux
Level 4
Level 4
Posts: 337
Joined: Sat Dec 26, 2009 3:36 pm

Re: Problem with wireless connection

Post by acerimusdux »

Likely a driver issue, and if it works in 18.04, it will probably be fixed in 19, which should be ready for release before the end of this month. But you should be able to get it working in 18. Some broadcom models especially need a driver installation, for example. Need the info from the inxi command Rob suggested though, to know the details.

JeremyB
Level 20
Level 20
Posts: 11635
Joined: Fri Feb 21, 2014 8:17 am

Re: Problem with wireless connection

Post by JeremyB »

I would bet it is an SDIO wifi card that needs the 4.15 kernel and possibly firmware to work. These normally fail to be detected by inxi

Bocien
Level 1
Level 1
Posts: 6
Joined: Wed Jun 06, 2018 5:30 pm

Re: Problem with wireless connection

Post by Bocien »

After

Code: Select all

inxi -Fxz

Code: Select all

System:    Host: Kiano-LinuxMint Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)

	Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3) Distro: Linux Mint 18.3 Sylvia

Machine:   System: KIANO product: KIANO SlimNote 14 2

	Mobo: AMI model: Cherry Trail CR Bios: N/A v: WH-BI-14-Y116CR210-C34A-022-B date: 03/28/2017

CPU:       Quad core Intel Atom x5-Z8350 (-MCP-) cache: 1024 KB

	flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 11520

	clock speeds: max: 1920 MHz 1: 1563 MHz 2: 1745 MHz 3: 736 MHz 4: 1540 MHz

Graphics:  Card: Intel Device 22b0 bus-ID: 00:02.0

	Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa) Resolution: 1366x768@60.01hz
	GLX Renderer: Mesa DRI Intel HD Graphics (Cherrytrail)

	GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes

Audio:     Card Failed to Detect Sound Card! Sound: ALSA v: k4.10.0-38-generic

Network:   Card: Failed to Detect Network Card!

Drives:    HDD Total Size: 7.8GB (97.6% used) ID-1: /dev/mmcblk0 model: N/A size: 31.3GB

	ID-2: USB /dev/sda model: USB_Flash_Memory size: 7.8GB
Partition: ID-1: / size: 27G used: 5.3G (22%) fs: ext4 dev: /dev/mmcblk0p2

	ID-2: swap-1 size: 2.07GB used: 0.00GB (0%) fs: swap dev: /dev/mmcblk0p3

RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present

Sensors:   System Temperatures: cpu: 35.0C mobo: N/A

	Fan Speeds (in rpm): cpu: N/A

Info:      Processes: 205 Uptime: 1 min Memory: 471.8/1922.8MB Init: systemd runlevel: 5 Gcc sys: 5.4.0

	Client: Shell (bash 4.3.481) inxi: 2.2.35 

I noticed that it doesn't detect any sound card so here is another problem :)

Bocien
Level 1
Level 1
Posts: 6
Joined: Wed Jun 06, 2018 5:30 pm

Re: Problem with wireless connection

Post by Bocien »

Another thing, I installed Mint 19 and now the problem is almost gone beacuse I now have Wi-Fi but it's still doesnt detect my network card. Dunno what this is about.

JeremyB
Level 20
Level 20
Posts: 11635
Joined: Fri Feb 21, 2014 8:17 am

Re: Problem with wireless connection

Post by JeremyB »

Post results for

Code: Select all

lsmod | grep cfg

Bocien
Level 1
Level 1
Posts: 6
Joined: Wed Jun 06, 2018 5:30 pm

Re: Problem with wireless connection

Post by Bocien »

That's the result

Code: Select all

cfg80211              622592  1 r8723bs

JeremyB
Level 20
Level 20
Posts: 11635
Joined: Fri Feb 21, 2014 8:17 am

Re: Problem with wireless connection

Post by JeremyB »

Your wifi is a Realtek Rtl8723bs on the SDIO bus and inxi doesn't detect them

Bocien
Level 1
Level 1
Posts: 6
Joined: Wed Jun 06, 2018 5:30 pm

Re: Problem with wireless connection

Post by Bocien »

Ooohh ok. Can I change that somehow or that's just the way it is?

JeremyB
Level 20
Level 20
Posts: 11635
Joined: Fri Feb 21, 2014 8:17 am

Re: Problem with wireless connection

Post by JeremyB »

That is just the way it is for now. I am not sure if it will ever change

papa1970
Level 1
Level 1
Posts: 1
Joined: Mon Jul 30, 2018 1:12 pm

Re: Problem with wireless connection

Post by papa1970 »

I am having the same issue. I just installi it on ASUST100HA. Cannot detect the bluetooth and the network adapter.
inxi failed to detect network card
Any suggestions?

Post Reply

Return to “Newbie Questions”