Update broke hibernation and power button

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Kelvin
Level 1
Level 1
Posts: 4
Joined: Wed May 16, 2018 4:17 pm

Update broke hibernation and power button

Post by Kelvin » Thu Jun 07, 2018 5:07 pm

After looking around and finding out it was the kernel update that broke hibernation, I found how to go back to kernel version 4.8, which is what I had before upgrading to 4.13, which is what I have now and cannot start back up with after hibernating. So I run 4.8 instead, and hibernating works again, but now, when I press the power button, nothing shows up. If I hold it for long enough, it'll still cut the power, but the shutdown menu doesn't appear. It'll still appear if I select it from the app menu, though. So since going back to my older kernel solved one issue but somehow created another, I'm hoping someone can help me either get hibernation working on the latest kernel, or making the power button respond properly in the old kernel.

User avatar
all41
Level 13
Level 13
Posts: 4637
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Update broke hibernation and power button

Post by all41 » Fri Jun 08, 2018 12:09 am

Hi @Kelvin,

Open a terminal from your Menu (or by Ctrl+Alt+T) and enter the following inquiry:

Code: Select all

inxi -Fxz
then press enter.
Copy/paste those results, and post them back to this thread using the 'code' icon at the top of the window </> (fifth from left).
This will give the forum an overview of your system and hardware.
Proud to be a supporter and monthly contributor to Mint.

Hoser Rob
Level 12
Level 12
Posts: 4088
Joined: Sat Dec 15, 2012 8:57 am

Re: Update broke hibernation and power button

Post by Hoser Rob » Fri Jun 08, 2018 8:30 am

As mentioned you need to post more info.

And you shouldn't hold down the power button to shut off, it can lose data that way. Hold down Alt-PrtScr and then slowly type REISUO (or REISUB to reboot) to shut down safely.

Kelvin
Level 1
Level 1
Posts: 4
Joined: Wed May 16, 2018 4:17 pm

Re: Update broke hibernation and power button

Post by Kelvin » Fri Jun 22, 2018 11:18 am

System: Host: Shadewing Kernel: 4.13.0-43-generic x86_64 (64 bit gcc: 5.4.0)
Desktop: Xfce 4.12.3 (Gtk 2.24.28) Distro: Linux Mint 18.2 Sonya
Machine: System: LENOVO (portable) product: 4236F62 v: ThinkPad T420
Mobo: LENOVO model: 4236F62
Bios: LENOVO v: 83ET63WW (1.33 ) date: 07/29/2011
CPU: Quad core Intel Core i7-2760QM (-HT-MCP-) cache: 6144 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 19138
clock speeds: max: 3500 MHz 1: 857 MHz 2: 839 MHz 3: 828 MHz
4: 823 MHz 5: 913 MHz 6: 827 MHz 7: 802 MHz 8: 806 MHz
Graphics: Card: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1600x900@60.00hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile
GLX Version: 3.0 Mesa 17.2.8 Direct Rendering: Yes
Audio: Card Intel 6 Series/C200 Series Family High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.13.0-43-generic
Network: Card-1: Intel 82579LM Gigabit Network Connection
driver: e1000e v: 3.2.6-k port: 5080 bus-ID: 00:19.0
IF: enp0s25 state: down mac: <filter>
Card-2: Intel Centrino Advanced-N 6205 [Taylor Peak]
driver: iwlwifi bus-ID: 03:00.0
IF: wlp3s0 state: up mac: <filter>
Drives: HDD Total Size: 1000.2GB (42.1% used)
ID-1: /dev/mmcblk0 model: N/A size: 63.9GB
ID-2: /dev/sda model: WDC_WDS500G2B0A size: 500.1GB
ID-3: /dev/sdb model: ST9500420ASG size: 500.1GB
Partition: ID-1: / size: 451G used: 385G (90%) fs: ext4 dev: /dev/sda1
ID-2: swap-1 size: 8.47GB used: 0.00GB (0%) fs: swap dev: /dev/sda5
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 44.0C mobo: N/A
Fan Speeds (in rpm): cpu: 3533
Info: Processes: 230 Uptime: 33 min Memory: 835.1/7859.7MB
Init: systemd runlevel: 5 Gcc sys: 5.4.0
Client: Shell (bash 4.3.481) inxi: 2.2.35

Post Reply

Return to “Newbie Questions”