setting the system font in a language other than English

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
jaehochoe
Level 1
Level 1
Posts: 1
Joined: Mon Apr 30, 2018 8:49 pm

setting the system font in a language other than English

Post by jaehochoe » Tue Jun 12, 2018 12:26 pm

Hi
I am sort of a newbie to Linux Mint Xfce and so far pretty much satisfied with all the features and functions available in the new operating system.
But there is one small issue I have with using Linux Mint, which is the inability to change the system font of my native language Korean.
Korean uses completely different sets of letters than English or other languages that utilize alphabets.
But on the 'appearance' window or 'window manager,' there is no way to change the system font of a language aside from English.
I am wondering if there's anyone in the forum who knows how to set the system font for a language other than English here.

Cafinux
Level 1
Level 1
Posts: 3
Joined: Mon Jun 11, 2018 2:36 pm

Re: setting the system font in a language other than English

Post by Cafinux » Thu Jun 14, 2018 5:52 am

Have you clicked on >Settings > Language - Support > and worked through the settings from there?

User avatar
songhuijohn
Level 3
Level 3
Posts: 166
Joined: Thu Apr 28, 2016 5:00 pm
Location: Arlington, Texas USA

Re: setting the system font in a language other than English

Post by songhuijohn » Fri Jun 15, 2018 7:53 pm

Here is how I step up switching language input for English and Korean.

This is based upon a US English installed Linux Mint 18.3 Cinnamon.

- left mouse click on Menu
- place cursor on Preferences and left mouse click on Language
- left mouse click on Input method tab
- left mouse click on Korean to install (your need to do this for the additional language input you want)
- after Korean was installed, left mouse click on input method drop down box, left mouse click on Ibus ( I do not know if IBUS is needed for all languages - I suspect when your language is installed, there will be a note below the word Installed for your language telling you what input method to use)
- close the Language setting screen
- left mouse click on Menu
- place cursor on Preferences and left mouse click on Ibus Preferences
- left mouse click on Input Method tab
- left mouse click on Add button
- from the drop down box left mouse click on language to add and then left mouse click on the add botton
- close the Ibus Preference screen
- restart Linux Mint (VERY IMPORTANT)

In the Panel area for my situation I now see and icon of EN. If I want to be able to enter a mixture of English and Korean, I enter win key + space bar and select Korean - the Korean symbol replaces the EN icon in the panel area. Then when entering key strokes into an application, I use the shift + space bar to switch between English and Korean.

What is the reason you did not install Linux Mint Cinnamon? Coming from a Windows background I found Cinnamon very easy to adjust to - plus I have help several other users make the transition from Windows to Linux Mint Cinnamon and they also were quickly very comfortable with Linux Mint Cinnamon.

WARNING: This worked for me with an US English installation with Korean input added - I have no idea about other languages!!!
Linux Mint 18.3 Cinnamon, Mobo MSI A68HM Grenade, AMD A8-7600, 4GIG DDR3 1600, SSD Patriot Blast 120 GB

Post Reply

Return to “Newbie Questions”