[SOLVED]Yet another no WiFi. Driver etc...

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
ScotchMist
Level 1
Level 1
Posts: 17
Joined: Wed Jun 13, 2018 2:44 am

[SOLVED]Yet another no WiFi. Driver etc...

Post by ScotchMist »

Hey.

My first time with Linux and all is great other than the wifi. Im currently using an ethernet cable so its not the end of the world. Ive searched previous threads but havent found anything specific.


inxi -Fxz results

Code: Select all

System:    Host: mint Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: HP product: HP Laptop 15-bw0xx v: Type1ProductConfigId
           Mobo: HP model: 8330 v: 27.32 Bios: Insyde v: F.21 date: 11/17/2017
CPU:       Dual core AMD A9-9420 RADEON R5 5 COMPUTE CORES 2C+3G (-MCP-) cache: 2048 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 11976
           clock speeds: max: 3000 MHz 1: 1400 MHz 2: 2700 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Device 98e4 bus-ID: 00:01.0
           Display Server: X.Org 1.18.4 drivers: ati,amdgpu (unloaded: fbdev,vesa,radeon)
           Resolution: 1920x1080@60.10hz
           GLX Renderer: Gallium 0.4 on AMD STONEY (DRM 3.9.0 / 4.10.0-38-generic, LLVM 4.0.0)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] Device 157a
           driver: snd_hda_intel bus-ID: 00:09.2
           Card-2 Advanced Micro Devices [AMD/ATI] Device 15b3
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Realtek Device d723 port: 2000 bus-ID: 03:00.0
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
Drives:    HDD Total Size: 1031.0GB (0.2% used)
           ID-1: USB /dev/sda model: Ultra_USB_3.0 size: 30.8GB temp: 0C
           ID-2: /dev/sdb model: WDC_WD10JPVX size: 1000.2GB temp: 32C
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 37.0C mobo: 20.0C gpu: 0.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 183 Uptime: 2:12 Memory: 1413.9/3900.1MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
I am still running off of the USB. i dont really want dual boot but i also dont want to do away with windows if this cant be resolved.

hope you can help :?:
Last edited by ScotchMist on Wed Jun 13, 2018 7:38 pm, edited 2 times in total.

User avatar
jimallyn
Level 18
Level 18
Posts: 8951
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Yet another no WiFi. Driver etc...

Post by jimallyn »

ScotchMist wrote:
Wed Jun 13, 2018 2:51 pm
i dont really want dual boot but i also dont want to do away with windows if this cant be resolved.
Welcome to Linux Mint, ScotchMist, and welcome to the forums. I'm not the guy who can resolve your wifi problem, but there are people here who I am certain will be able to help you resolve it.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan


ScotchMist
Level 1
Level 1
Posts: 17
Joined: Wed Jun 13, 2018 2:44 am

Re: Yet another no WiFi. Driver etc...

Post by ScotchMist »

Thanks for the reply.

Everything goes fine until i get as far as building using the command

Code: Select all

cd rtl8723de
make
sudo make install
and then it throws up this

Code: Select all

mint@mint ~ $ cd rtl8723de
bash: cd: rtl8723de: No such file or directory
mint@mint ~ $ cd rtl8723de
bash: cd: rtl8723de: No such file or directory
mint@mint ~ $ make
make: *** No targets specified and no makefile found.  Stop.
mint@mint ~ $ sudo make install
any ideas. thanks again. both of you

edit - could it be because im running just off the live usb still. sorry, i really am a total noob

JeremyB
Level 20
Level 20
Posts: 11281
Joined: Fri Feb 21, 2014 8:17 am

Re: Yet another no WiFi. Driver etc...

Post by JeremyB »

Lets try a better solution

Code: Select all

sudo apt install git build-essential dkms 
git clone -b extended https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6
sudo cd rtlwifi_new/firmware/rtlwifi/ /lib/firmware/rtlwifi/
Reboot

ScotchMist
Level 1
Level 1
Posts: 17
Joined: Wed Jun 13, 2018 2:44 am

Re: Yet another no WiFi. Driver etc...

Post by ScotchMist »

JeremyB wrote:
Wed Jun 13, 2018 4:58 pm
Lets try a better solution

Code: Select all

sudo apt install git build-essential dkms 
git clone -b extended https://github.com/lwfinger/rtlwifi_new.git
sudo dkms add ./rtlwifi_new
sudo dkms install rtlwifi-new/0.6
sudo cd rtlwifi_new/firmware/rtlwifi/ /lib/firmware/rtlwifi/
Reboot
I just came back here to say that id figured it out eventually from the instructions on that site. I wasnt opening the file directly into terminal which was the problem..

Thanks for your help everyone. Happy to say the ethernet cable is going back to the bottom of the drawer :mrgreen:

Post Reply

Return to “Newbie Questions”