persisting trackball settings

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
gaboalonso
Level 1
Level 1
Posts: 9
Joined: Thu Jan 18, 2018 10:39 am

persisting trackball settings

Post by gaboalonso » Sun Jun 17, 2018 3:39 pm

Hi All, I have a logitech trackball and wanted to slow it down on Mint.

xinput set-prop "Logitech M570" "libinput Accel Speed" -1
does the trick, but I wanted to work everytime I plugged in the device or on restart.

I've follow this tutorial https://jcastellssala.com/2016/10/29/lo ... -in-linux/
and created the file.

When on login screen it works great. Once I have authenticated it seems to dismiss the configuration.

How can I fix this?

Thanks all and regards,
Gabriel.

User avatar
all41
Level 13
Level 13
Posts: 4626
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: persisting trackball settings

Post by all41 » Sun Jun 17, 2018 4:31 pm

I have a wireless Logitech Trackpad that needed some tweaking.
I use a script and point a startup applications entry to it's path.


#!/bin/bash
sleep 5
xinput set-prop "Logitech Rechargeable Trackpad T651" "Device Accel Profile" 2
xinput set-prop "Logitech Rechargeable Trackpad T651" "Device Accel Velocity Scaling" 39.500000
exit

You will recognize the lines that address the attributes to be changed.
I added the sleep time to avoid collisions with other scripts I run at startup.

Works well for me.
Proud to be a supporter and monthly contributor to Mint.

Post Reply

Return to “Newbie Questions”