Page 1 of 1

[SOLVED] No boot to Linux after TimeShift restore

Posted: Mon Jun 18, 2018 7:17 am
by Linux_Lobo

After making some system changes in efforts to get a MS Bluetooth mouse working (a topic for another post) I used TimeShift to restore the PC to a point that was running well. Unfortunately, after the restore the PC booted into Windows 10 instead of the Linux boot loader. I left options in TimeShift to their default settings.

A clean install will not be an ideal solution as I want to understand what went wrong as this issue will happen again if I try to use TimeShift.

I am a total newbie to Linux!

1) I tried to fix the bootloader based on this website's solution: Unfortunately, this action stopped Windows 10 booting.
2) I used a Windows 10 recovery disk and am now able to boot into Windows.
3) Using the Linux Live CD I tried to restore the system again by using TimeShift as it was able to see my previous restore points; however, no luck.
4) I have tried changing the boot order under the BIOS but am reluctant to get more adventurous in case I lose Windows now.

Looking forward to some ideas!

Linux Mint 18.3 and Windows 10 dual boot

Code: Select all

System:    Host: mint Kernel: 4.10.0-38-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: LENOVO (portable) product: 80SW v: Lenovo ideapad 710S-13ISK
           Mobo: LENOVO model: Lenovo ideapad 710S-13ISK v: SDK0J40709 WIN
           Bios: LENOVO v: 0NCN41WW date: 03/15/2018
CPU:       Dual core Intel Core i7-6560U (-HT-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8832
           clock speeds: max: 3200 MHz 1: 3198 MHz 2: 3199 MHz 3: 3195 MHz
           4: 3197 MHz
Graphics:  Card: Intel Sky Lake Integrated Graphics bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1920x1080@60.02hz
           GLX Renderer: Mesa DRI Intel Iris Graphics 540 (Skylake GT3e)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Sunrise Point-LP HD Audio
           driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.10.0-38-generic
Network:   Card: Intel Wireless 8260 driver: iwlwifi bus-ID: 01:00.0
           IF: wlp1s0 state: down mac: <filter>
Drives:    HDD Total Size: NA (-) ID-1: /dev/nvme0n1 model: N/A size: 256.1GB
           ID-2: USB /dev/sda model: Ultra_Fit size: 30.8GB temp: 0C
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 42.5C mobo: 42.0C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 205 Uptime: 0 min Memory: 514.3/2606.5MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35

Re: No boot to Linux after TimeShift restore

Posted: Mon Jun 18, 2018 7:29 am
by Pierre
you can fix the Boot Issue in either Windows or on Linux:

in Windows - use easyBCD:
use the Non-commercial / Free version

in Linux - use Boot Repair: ... wont-boot/
You can also just use a dedicated Boot Repair disc to boot straight to the graphical Boot Repair tool.
which you will have to write to a CD and then boot from that.

Re: No boot to Linux after TimeShift restore

Posted: Mon Jun 18, 2018 11:28 am
by Linux_Lobo
Thank you for the response. I tried the easyBCD option initially however got some errors and so decided to use the live USB to use the terminal as described by the article. | got a message saying that "secure boot" needed to be disabled in the BIOS. I did this and the boot loader/GRUB2 was again displayed on bootup. Glad to report that Mint is working again - but, have probably corrupted the Win 10 MBR and cannot boot into windows now. :cry:

Unfortunately, I don't have the windows recovery USB to fix this issue now as I needed the disk (yes - very bad idea). I do have the files that were on the recovery disk but these won't work simply by copying onto another disk. Any ideas how to either fix the windows boot issue or the Win Recovery USB disk?

Thank you

Re: No boot to Linux after TimeShift restore

Posted: Thu Jun 21, 2018 5:59 am
by Linux_Lobo
Just to close this issue out for anyone that goes down this path. I got hold of another Win 10 PC and made a Recovery disc (no system files) to get me back into windows. Then I was able enter the command prompt and repair the corrupt BCD file by using the command: bcdboot c:\windows.

It broke GRUB again but this time used the grub repair first in linux:

in Linux - use Boot Repair: ... wont-boot/

Dual boot windows and Linux Mint now working although now I am beginning to believe single boot is the way to go.

Thank you Pierre for your help.

Re: [SOLVED] No boot to Linux after TimeShift restore

Posted: Thu Jun 21, 2018 2:29 pm
by AndyMH
Recommend the single boot option, with mint of course. But you don't have to give up windows. Install virtualbox and run windows in a VM. I started my mint life dual boot with win7. Now mint is my main OS with win7 running in a VM (mainly for compatibility with stuf at work). The downside - you need a valid win licence for the installation in virtualbox, which you may have to buy.

Re: [SOLVED] No boot to Linux after TimeShift restore

Posted: Fri Jun 22, 2018 7:47 am
by Linux_Lobo
Hi Andy, thanks for the tip. I just set up a virtual machine as suggested just in case I need it in the future. Fortunately I was able to find the embedded MS key.

Re: [SOLVED] No boot to Linux after TimeShift restore

Posted: Sat Jun 23, 2018 8:01 am
by AndyMH
Quick tips on virtualbox (what most of the forum questions relate to):
  • Install the extension pack, you should have downloaded this along with VB, make sure it is the same version as the VB you've installed. To install either double click or right click and open with virtualbox.
  • Install guest addition - this is installed in windows. With win running In virtualbox you can go devices>optical drives and should see guest additions.
  • Add yourself to the vboxusers group - mint menu admin>users & groups.
Without these you won't get full integration between mint and win and you won't be able to access USB devices in win. Note win7 was not shipped with USB3 and you have to download the drivers from intel (but if you were running win7 before you probably know this). You can have a USB device attached to win or mint but not both at the same time. To get at them in win, in VB devices>USB and click on the one you want.

Re: [SOLVED] No boot to Linux after TimeShift restore

Posted: Sat Jun 23, 2018 12:48 pm
by Linux_Lobo
Thank you Andy,

I'll look into it.