New to Linux Mint - cannot connect speakers via bluetooth <Solved>

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
linux2me
Level 1
Level 1
Posts: 4
Joined: Wed Jun 06, 2018 7:44 pm
Location: @home

New to Linux Mint - cannot connect speakers via bluetooth <Solved>

Post by linux2me » Wed Jun 20, 2018 11:52 am

I have an Acer Aspire R laptop running Windows 10 and Linux Mint 18.3 Mate in Virtualbox as a guest. I am trying to connect via Bluetooth some Anker Bluetooth speakers I got for my birthday :), but I am not having any luck. Can someone please let me know what I need to post from the terminal? I have Blueman installed but it can't see any adapters at all. I have searched for solutions on the web and so far no luck.

Thanks for any help given.
Last edited by linux2me on Tue Jul 03, 2018 8:48 pm, edited 1 time in total.

User avatar
phd21
Level 16
Level 16
Posts: 6331
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: New to Linux Mint - cannot connect speakers via bluetooth

Post by phd21 » Wed Jun 20, 2018 4:32 pm

Hi linux2me,

virtualbox.org • View topic - [HowTo] Bluetooth Working on Ubuntu 16.0.4 (WIN10 Host)
https://forums.virtualbox.org/viewtopic.php?f=6&t=87470

Ubuntu 16.04 Virtual Box Bluetooth - Stack Overflow
https://stackoverflow.com/questions/443 ... -bluetooth

Hope this helps ...
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
linux2me
Level 1
Level 1
Posts: 4
Joined: Wed Jun 06, 2018 7:44 pm
Location: @home

Re: New to Linux Mint - cannot connect speakers via bluetooth

Post by linux2me » Wed Jun 20, 2018 5:04 pm

Thank you phd21, I will read through the links you gave me. Thanks :D

User avatar
linux2me
Level 1
Level 1
Posts: 4
Joined: Wed Jun 06, 2018 7:44 pm
Location: @home

Re: New to Linux Mint - cannot connect speakers via bluetooth

Post by linux2me » Tue Jul 03, 2018 8:45 pm

phd21 wrote:
Wed Jun 20, 2018 4:32 pm
Hi linux2me,

virtualbox.org • View topic - [HowTo] Bluetooth Working on Ubuntu 16.0.4 (WIN10 Host)
https://forums.virtualbox.org/viewtopic.php?f=6&t=87470

Ubuntu 16.04 Virtual Box Bluetooth - Stack Overflow
https://stackoverflow.com/questions/443 ... -bluetooth

Hope this helps ...
Sorry for not replying quickly, family emergency. Disabling Bluetooth in Windows 10 did the trick. Thank you phd21! I will mark post as solved.

User avatar
phd21
Level 16
Level 16
Posts: 6331
Joined: Thu Jan 09, 2014 9:42 pm
Location: Florida

Re: New to Linux Mint - cannot connect speakers via bluetooth

Post by phd21 » Tue Jul 03, 2018 9:50 pm

HI linux2me,

You are welcome...

Glad it worked for you.

When using Virtualbox you normally cannot share some devices between the host operating system and the virtualbox guest operating system, so disabling one in either place allows it to be used in the either the host or guest system. Note that sometimes virtualbox will create a virtual device to represent the host operating system hardware device, and you can use that; for instance on my system I use a WiFi adapter to connect to the internet and virtualbox (vb) automatically creates a virtual wired Ethernet adapter device that works in the VB guest system. I do not know how that would work with Bluetooth and Bluetooth speakers though because I have not experimented with that before. I would think that if you connected the Blutooth speakers in your MS Windows Host system and made that the active default sound output connection before starting the Linux Mint VB Guest, that it would play as if they were regular speakers without disabling the Bluetooth in the MS Windows host system, or perhaps in Linux Mint you can select through the sound settings or pulse audio volume control the sound output device or application playback preference.
Phd21: Mint KDE 17.3 & 18.3, 64-bit Awesome OS, Ancient Dell OptiPlex 780 Core2Duo E8400 3GHz,4gb Ram,256gb SDD, Video: Intel 4 Graphics, DVD Lightscribe. Why I use KDE?:https://opensource.com/life/15/4/9-reasons-to-use-kde

User avatar
linux2me
Level 1
Level 1
Posts: 4
Joined: Wed Jun 06, 2018 7:44 pm
Location: @home

Re: New to Linux Mint - cannot connect speakers via bluetooth

Post by linux2me » Wed Jul 04, 2018 10:24 am

phd21 wrote:
Tue Jul 03, 2018 9:50 pm
HI linux2me,

You are welcome...

Glad it worked for you.

When using Virtualbox you normally cannot share some devices between the host operating system and the virtualbox guest operating system, so disabling one in either place allows it to be used in the either the host or guest system. Note that sometimes virtualbox will create a virtual device to represent the host operating system hardware device, and you can use that; for instance on my system I use a WiFi adapter to connect to the internet and virtualbox (vb) automatically creates a virtual wired Ethernet adapter device that works in the VB guest system. I do not know how that would work with Bluetooth and Bluetooth speakers though because I have not experimented with that before. I would think that if you connected the Blutooth speakers in your MS Windows Host system and made that the active default sound output connection before starting the Linux Mint VB Guest, that it would play as if they were regular speakers without disabling the Bluetooth in the MS Windows host system, or perhaps in Linux Mint you can select through the sound settings or pulse audio volume control the sound output device or application playback preference.
Thanks phd21 for this explanation. I will also have to try connecting my blue-tooth speakers in my windows 10 system and making it the active default before starting mint as a virtual guest and see if that also works. Thanks again for your help.

Post Reply

Return to “Newbie Questions”