Keyboard and system freeze-Sylvia 18.3

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
beeshyams
Level 1
Level 1
Posts: 18
Joined: Sat Mar 19, 2016 12:05 pm

Keyboard and system freeze-Sylvia 18.3

Post by beeshyams » Fri Jun 22, 2018 11:27 am

Hi

Bought ASUS VivoBook Max- F541N with pre-installed Win 10 and dual booted into Mint Linux Sylvia (Cinnamon)

I see that the keyboard cursor pointer suddenly freezes while on FireFox . I thought that was something specific to FireFox but same in Libre office (which I am using right now to type) but maybe takes a little longer to freeze compared to FireFox.
I don't use a mouse

1. It seems erratic- at times, I can use and type in the main menu , doing which I went to drivers and switched to Intel Microcode, rebooted and the behaviour persists

2. All updates (level 3) done

3. It’s a virgin system – nothing installed it

4. Laptop tool confirms that it's running the latest BIOS

5. 6 GB swap , 30 GB root and 400 GB home allocated while installing, so that shouldn't be a problem I guess (Edit: Confirmed. Installed resources desklet and checked multiple times . CPU < 15 % and Memory < 1.5 GB when this happens)

I am a newbie in Linux stuff but dual booted my nearly dead Win XP with 17.3 and I like it so much that I decided to install Mint ASAP

Kindly provide specific steps to trouble shoot and fix this problem given that I know nothing about Linux :)

Thanks in advance

This output seems to be the standard requirement, so here it is - it froze again while posting so using a luckily available nearby laptop to edit

Code: Select all

shyam@shyam-X541NA ~ $ inxi -Fxz
System:    Host: shyam-X541NA Kernel: 4.13.0-45-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.6.6 (Gtk 3.18.9-1ubuntu3.3)
           Distro: Linux Mint 18.3 Sylvia
Machine:   System: ASUSTeK (portable) product: X541NA v: 1.0
           Mobo: ASUSTeK model: X541NA v: 1.0
           Bios: American Megatrends v: X541NA.318 date: 02/27/2018
CPU:       Quad core Intel Pentium N4200 (-MCP-) cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8755
           clock speeds: max: 2500 MHz 1: 852 MHz 2: 798 MHz 3: 842 MHz
           4: 1277 MHz
Graphics:  Card: Intel Device 5a84 bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 drivers: intel (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.02hz
           GLX Renderer: Mesa DRI Intel HD Graphics 505 (Broxton)
           GLX Version: 3.0 Mesa 17.0.7 Direct Rendering: Yes
Audio:     Card Intel Device 5a98 driver: snd_hda_intel bus-ID: 00:0e.0
           Sound: Advanced Linux Sound Architecture v: k4.13.0-45-generic
Network:   Card-1: Realtek RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 01:00.0
           IF: enp1s0 state: down mac: <filter>
           Card-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter
           driver: ath9k bus-ID: 02:00.0
           IF: wlp2s0 state: up mac: <filter>
Drives:    HDD Total Size: 1000.2GB (1.3% used)
           ID-1: /dev/sda model: ST1000LM035 size: 1000.2GB
Partition: ID-1: / size: 29G used: 6.3G (23%) fs: ext4 dev: /dev/sda6
           ID-2: /home size: 446G used: 160M (1%) fs: ext4 dev: /dev/sda8
           ID-3: swap-1 size: 6.37GB used: 0.00GB (0%) fs: swap dev: /dev/sda7
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 35.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 201 Uptime: 13 min Memory: 607.0/3809.0MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Edit 23/06/18 : It's gone worse. I was downloading Chromium to rule out FireFox being the culprit and system froze . Rebooted and just watched without opening any browser and it froze again. This time even the keyboard button with windows logo that would bring the menu didn't respond. Just can't use Mint now and booted back to Windows to edit this post


Reviewing the install process, there was a step which let me choose drivers to be installed and I agreed to it. One of the blogs on net says it is not recommended without any elaboration.

1. Since I have nothing installed in Mint, I am willing to re-install Mint without installing drivers and let the right drivers be updated- Is that a good idea?


2. I haven't installed second time before , so would request help on things to watch out for (is it safe? will the partitions remain -swap, root , home or do I need to recreate? do I need to uninstall and then reinstall or just start fresh etc...confused :(


Thanks

beeshyams
Level 1
Level 1
Posts: 18
Joined: Sat Mar 19, 2016 12:05 pm

[Solved]Re: Keyboard and system freeze-Sylvia 18.3

Post by beeshyams » Tue Jun 26, 2018 8:43 am

It was only the cursor and touchpad freezing as I noticed on subsequent reinstalls
This is not a solution but a workaround that may help those who visit here

Tried installing earlier versions of 18.x as also 17.x . Not all would install but those did exhibited same problem. Since the problem seemed to be with touchpad not working, decided to try Mint Linux 19 (Beta) which has better touchpad support

Release notes of Mint Linux 19 (https://www.linuxmint.com/rel_tara_cinnamon.php) say

> The default touchpad driver in this edition is "libinput" (provided by the xserver-xorg-input-libinput package).

> If you experience problems with it, you can switch to another driver called "synaptics" (provided by the xserver-xorg-input-synaptics package)

The default driver worked and this is the second day under observation

Probably the default driver could be installed on 18.x to resolve this problem. For me, improved features in 19 are helpful so am staying on it

Post Reply

Return to “Newbie Questions”