Change Live/Installer to NOT change clock

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
vansloneker
Level 5
Level 5
Posts: 575
Joined: Sat Mar 17, 2018 6:10 am

Change Live/Installer to NOT change clock

Post by vansloneker »

Is there a way I can change the Live/Installer to NOT change the clock of the host computer? It happens more than once I have to use it on a system running Windows and the last thing on my mind is to change the clock afterwards. It is very annoying when workload gets a bad time-stamp.
Unless stated otherwise Mint 18.3-64 XFCE
User avatar
JoeFootball
Level 9
Level 9
Posts: 2677
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: Change Live/Installer to NOT change clock

Post by JoeFootball »

vansloneker wrote:... on a system running Windows ...
I think what you're saying is that the computer's clock is set to UTC, and Windows is still treating it as local time?

While I can't speak to how the installer works (or why Windows defaults to this behavior), here's an article on how to adjust the Windows registry to default it to use UTC time where its local time is governed by the user session, just like the way the rest of the world's computers work.

Joe
User avatar
Lord Boltar
Level 5
Level 5
Posts: 711
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: Change Live/Installer to NOT change clock

Post by Lord Boltar »

Set Clock Time on Dual-Boot Systems

If you're dual-booting Linux Mint 18 and Windows 10, you may find that changing time in one system affects the other and the two systems can't display the same time.

This happens as Linux Mint 18 interprets the hardware clock or real time clock (RTC) in universal time (UTC) by default while Windows 10 maintains the clock in local time.

You can fix this by keeping RTC in local time in Linux Mint, same as Windows, by running a command in the terminal below.

timedatectl set-local-rtc 1 --adjust-system-clock
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing
User avatar
jimallyn
Level 18
Level 18
Posts: 8955
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Change Live/Installer to NOT change clock

Post by jimallyn »

I always implement the fix on Windows, since Linux is always right and therefore if there is any problem, it must be a Windows problem. :D I download and add the registry fixes linked to in this article:

http://www.webupd8.org/2014/09/dual-boo ... tween.html

Which takes you to here:

https://help.ubuntu.com/community/Ubunt ... FixUTC.reg

Just download the file on to your Windows computer and double click it.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan
User avatar
JoeFootball
Level 9
Level 9
Posts: 2677
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: Change Live/Installer to NOT change clock

Post by JoeFootball »

jimallyn wrote:I always implement the fix on Windows ...
+1. Indeed. I don't know of another OS that governs its RTC on local time.

Joe
User avatar
vansloneker
Level 5
Level 5
Posts: 575
Joined: Sat Mar 17, 2018 6:10 am

Re: Change Live/Installer to NOT change clock

Post by vansloneker »

Thank you all for your replies. Apparently my question wasn't clear. I know how to change the clock behaviour on an existing Linux installation -thanks to the great support.
The problem is, the live CD/DVD/USB/Installer. Regardless of installing or not, whenever I have to run that, it changes the clock. It actually doesn't matter if there's a Windows install on the system or not. It changes the clock two hours down. If there is a Windows installation, it's very annoying to discover work has been timed offset for two hours.
Whenever I have a job to do that does involve using the live CD/DVD/USB/Installer it is not on my mind to go check and change the clock afterwards. So I am looking for a way to modify the live CD/DVD/USB/Installer to not change the clock.

I don't know where the idea comes from offsetting the clock is right, but not in my world. Clocks on my wall, on my wrist, on my phone, on my TV, on my oven, on my microwave, in my car, they all display the time that is accurate for the place where I am.
Unless stated otherwise Mint 18.3-64 XFCE
User avatar
JoeFootball
Level 9
Level 9
Posts: 2677
Joined: Tue Nov 24, 2009 1:52 pm
Location: /home/usa/mn/minneapolis/joe

Re: Change Live/Installer to NOT change clock

Post by JoeFootball »

vansloneker wrote:So I am looking for a way to modify the live CD/DVD/USB/Installer to not change the clock.
Other than changing the way that Windows governs your computer's RTC in order to achieve what you're looking for, I don't know of how to modify a live session to mirror Windows' behavior.

Joe
Post Reply

Return to “Newbie Questions”