[SOLVED] Can't stop Mint 19 mounting unwanted partitions at boot

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
xGuy
Level 2
Level 2
Posts: 64
Joined: Fri Jan 29, 2016 3:56 pm

[SOLVED] Can't stop Mint 19 mounting unwanted partitions at boot

Post by xGuy » Fri Jul 06, 2018 2:52 pm

I've been using Mint 17.3 for a couple of years now. I've just installed Mint 19 into a separate partition while leaving Mint 17.3 as my live system. My long term plan is to gradually reinstall and set up all my applications onto the Mint 19 system as I think this will be better than trying the multiple in-situ upgrade route.

I merged the Mint 17.3 /etc/fstab entires into the Mint 19 /etc/fstab file - obviously leaving root and swap alone in the latter. I also had to change any nobootwait options to x_systemd/device-timeout=1 due to systemd replacing mountall.

However, although all my desired mounts are working at startup as they should, there are a number of other partitions/file systems being automounted at boot despite not having any reference in /etc/fstab. I really don't want this behaviour but despite searching I've not been able to work out why it is happening.

I'd be very grateful for any help on this!
Last edited by xGuy on Sun Jul 08, 2018 11:37 am, edited 1 time in total.

User avatar
Alpha_sh
Level 1
Level 1
Posts: 19
Joined: Tue Jul 03, 2018 4:25 pm

Re: Can't stop Mint 19 mounting unwanted partitions at boot

Post by Alpha_sh » Sun Jul 08, 2018 12:02 am

if you are using cinnamon, you should be able to edit the mount options from the "disks" app

to do this, open disks, type in your root password, go to one of the partitions you want to stop from mounting, and untick the option for it to mount on startup

altair4
Level 19
Level 19
Posts: 9738
Joined: Tue Feb 03, 2009 10:27 am

Re: Can't stop Mint 19 mounting unwanted partitions at boot

Post by altair4 » Sun Jul 08, 2018 6:43 am

A very curious symptom.

Where are they mounting?

If it's under /media/your-user-name it could be some gvfs / udisks thing being invoked. You might want to check your Startup Applications list or maybe /etc/rc.local to see if you have anything being run at boot or login.

Just from the contents of your post you don't sound like someone who uses the Disks utility but that will also mount things under /media/your-user-name because it doesn't know any better but those things would show up in fstab I would think.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

User avatar
Pierre
Level 19
Level 19
Posts: 9173
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Can't stop Mint 19 mounting unwanted partitions at boot

Post by Pierre » Sun Jul 08, 2018 6:54 am

my new install of LM 19 Cinnamon also did that Auto_Mount thing,
of some other partitions that are on this Laptop, and so I'd click on 'unmount'
and enter my password & that Icon disappeared from the desktop, only to never return.
8)
even after subsequent re-boots - as well.
:)
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

Mute Ant
Level 14
Level 14
Posts: 5135
Joined: Tue Sep 03, 2013 7:45 pm
Location: Norfolk UK

Re: Can't stop Mint 19 mounting unwanted partitions at boot

Post by Mute Ant » Sun Jul 08, 2018 6:56 am

If you have your desktop set to automatically mount discovered file systems, it will...
While you're waiting, read the free novel we sent you. It's a Spanish story about a guy named "manual".

xGuy
Level 2
Level 2
Posts: 64
Joined: Fri Jan 29, 2016 3:56 pm

Re: Can't stop Mint 19 mounting unwanted partitions at boot

Post by xGuy » Sun Jul 08, 2018 10:25 am

Thanks to all for the quick responses and suggestions.

I never got on too well with the Disks Utility and it seems to be different in Mint 19 - it talks about "User Session Defaults" rather than "Automatic Mount Options". In Mint 19 Disk Manager when I set a partition to not automount it adds an entry to /etc/fstab with the nouser option. But on reboot it doesn't always work! I have not been able to get to the bottom of this.

I think Mute Ant's suggestion - If you have your desktop set to automatically mount discovered file systems, it will... sounds the way to go.

Except - I can't find out where to switch this off! I can switch off Desktop Icons -> Mounted Volumes but that just affects the display not the underlying mounting.

Also, although I would like to have no automatic mounting of HDD partitions which are not mentioned in /etc/fstab, I would like to have automatic mounting of removable drives (eg USB) with their icon automatically appearing on the (Cinnamon) desktop. This is how my Mint 17.3 works.

Sorry if this seems stupid - my excuse will be that we are in a heatwave - but how do I change my Desktop to not automatically mount discovered file systems?

xGuy
Level 2
Level 2
Posts: 64
Joined: Fri Jan 29, 2016 3:56 pm

Re: Can't stop Mint 19 mounting unwanted partitions at boot

Post by xGuy » Sun Jul 08, 2018 11:35 am

OK - I found it - Home->Edit->Preferences->Behaviour->Media Handling. Clear all four items and reboot - no more unwanted mounts and of course no icons on screen (assuming Preferences->Desktop->Desktop Icons->Mounted Volumes is enabled).

Interestingly I have the first three of those four items checked on Mint 17.3 but didn't get this issue.

There is a slight regression here for me because there is now no distinction between an internal HDD partition and, say a removable USB media device. So when I insert a USB HDD, I now do not get an icon appear on the screen. I have to go into Disk Manager and manually mount the drive's partition and then the icon appears. It's not that bad so I will live with it. And my /etc/fstab file size remains manageable. There are many more partitions I don't want mounted at boot than those that I do!

Many thanks to all who helped and I will mark this as solved and move on to the next issue.

Post Reply

Return to “Newbie Questions”