[SOLVED]After suspend mode wired connecttion does not work

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
djnesic
Level 1
Level 1
Posts: 41
Joined: Fri Dec 16, 2016 2:05 pm
Location: Belgrade, Serbia

[SOLVED]After suspend mode wired connecttion does not work

Post by djnesic »

When I go back from suspend mode my wired connecttion does not work. It says that cable is unpluged, but it is not. Then I have to restart computer to get back wired connecttion. How I can solve this?

Code: Select all

djnesic@djnesic-P31-DS3L:~$ inxi -Fxz
System:    Host: djnesic-P31-DS3L Kernel: 4.15.0-24-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.7 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: desktop Mobo: Gigabyte model: P31-DS3L v: x.x serial: N/A
           BIOS: Award v: F10A date: 07/30/2008
CPU:       Dual core Intel Core2 Duo E6750 (-MCP-) 
           arch: Conroe rev.11 cache: 4096 KB
           flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 10667
           clock speeds: max: 2667 MHz 1: 2000 MHz 2: 2000 MHz
Graphics:  Card: NVIDIA G84 [GeForce 8600 GT] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce 8600 GT/PCIe/SSE2
           version: 3.3.0 NVIDIA 340.106 Direct Render: Yes
Audio:     Card Intel NM10/ICH7 Family High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-24-generic
Network:   Card: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 628.1GB (2.4% used)
           ID-1: /dev/sda model: Patriot_Spark size: 128.0GB
           ID-2: /dev/sdb model: TOSHIBA_DT01ACA0 size: 500.1GB
Partition: ID-1: / size: 114G used: 11G (10%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 4.00GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 46.0C mobo: N/A gpu: 0.0:52C
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 186 Uptime: 1:10 Memory: 2535.3/3944.0MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
Last edited by djnesic on Sun Jul 08, 2018 9:31 am, edited 1 time in total.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1895
Joined: Thu Jan 04, 2018 1:00 pm

Re: After suspend mode wired connecttion does not work

Post by Sir Charles »

Hi djnesic,

You could try to create a service for restarting the Network Manager after suspension.

Follow these steps:

1) Open a terminal and run the following command:

Code: Select all

xed admin:///etc/systemd/system/network-resume.service
Type in your password followed by enter.

2) Copy and paste the following content in the file that opens:

Code: Select all

[Unit]
Description=Local system network resume actions
After=suspend.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
Save and close the file.


3) Make the file executable:

Code: Select all

sudo chmod +x  /etc/systemd/system/network-resume.service
4) Enable the new service:

Code: Select all

sudo systemctl enable --now network-resume.service
5) Check if the new service is active and running:

Code: Select all

systemctl status network-resume.service
Hope this helps to resolve the issue.

Good luck!
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

djnesic
Level 1
Level 1
Posts: 41
Joined: Fri Dec 16, 2016 2:05 pm
Location: Belgrade, Serbia

Re: After suspend mode wired connecttion does not work

Post by djnesic »

Hi Marziano,
thanks for your reply.
After first command, I have got message in Xed that it can not find file admin:///etc/systemd/system/network-resume.service.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1895
Joined: Thu Jan 04, 2018 1:00 pm

Re: After suspend mode wired connecttion does not work

Post by Sir Charles »

Alright, try first:

Code: Select all

sudo touch /etc/systemd/system/network-resume.service
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

djnesic
Level 1
Level 1
Posts: 41
Joined: Fri Dec 16, 2016 2:05 pm
Location: Belgrade, Serbia

Re: After suspend mode wired connecttion does not work

Post by djnesic »

Now it is good. Thanks. I am going to reboot.

djnesic
Level 1
Level 1
Posts: 41
Joined: Fri Dec 16, 2016 2:05 pm
Location: Belgrade, Serbia

Re: After suspend mode wired connecttion does not work

Post by djnesic »

...and now I am going to suspend about 10 minutes and then I`ll report.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1895
Joined: Thu Jan 04, 2018 1:00 pm

Re: After suspend mode wired connecttion does not work

Post by Sir Charles »

Crossing fingers here!
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

djnesic
Level 1
Level 1
Posts: 41
Joined: Fri Dec 16, 2016 2:05 pm
Location: Belgrade, Serbia

Re: After suspend mode wired connecttion does not work

Post by djnesic »

No, it is the same thing. "Cable is unpluged" and I have to reboot.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1895
Joined: Thu Jan 04, 2018 1:00 pm

Re: After suspend mode wired connecttion does not work

Post by Sir Charles »

:( about that!
Try this after suspension:

Code: Select all

sudo systemctl restart network-manager.service
If still no go, then there must be something else going on. I am afraid I have no idea what that can be. You will have to wait for other members to chime in

Good Luck!
Last edited by Sir Charles on Sun Jul 08, 2018 6:06 am, edited 4 times in total.
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

djnesic
Level 1
Level 1
Posts: 41
Joined: Fri Dec 16, 2016 2:05 pm
Location: Belgrade, Serbia

Re: After suspend mode wired connecttion does not work

Post by djnesic »

I`ll try. Thank you, I`ll report.

User avatar
thx-1138
Level 8
Level 8
Posts: 2092
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: After suspend mode wired connecttion does not work

Post by thx-1138 »

...i think there might exist a small typo above
(under Mint 18 at least, it's NetworkManager.service, not network-manager.service - don't know if that's changed in 19...)


Scratch that - it's just a symlink...
Last edited by thx-1138 on Sun Jul 08, 2018 6:05 am, edited 1 time in total.

djnesic
Level 1
Level 1
Posts: 41
Joined: Fri Dec 16, 2016 2:05 pm
Location: Belgrade, Serbia

Re: After suspend mode wired connecttion does not work

Post by djnesic »

It does not work. Thanks anyway, Marziano.

djnesic
Level 1
Level 1
Posts: 41
Joined: Fri Dec 16, 2016 2:05 pm
Location: Belgrade, Serbia

Re: After suspend mode wired connecttion does not work

Post by djnesic »

thx-1138 wrote:
Sun Jul 08, 2018 5:49 am
...i think there might exist a small typo above
(under Mint 18 at least, it's NetworkManager.service, not network-manager.service - don't know if that's changed in 19...)
I do not know. It is higher philosophy to me. I am just an ordinary user.

User avatar
thx-1138
Level 8
Level 8
Posts: 2092
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: After suspend mode wired connecttion does not work

Post by thx-1138 »

Nope, just checked it, no typo - i'll edit the above reply.
I would maybe try replacing network-manager.service with networking.service above, but that's just a guess...

User avatar
Sir Charles
Level 7
Level 7
Posts: 1895
Joined: Thu Jan 04, 2018 1:00 pm

Re: After suspend mode wired connecttion does not work

Post by Sir Charles »

thx-1138 wrote:
Sun Jul 08, 2018 6:04 am
Nope, just checked it, no typo - i'll edit the above reply.
I would maybe try replacing network-manager.service with networking.service above, but that's just a guess...
That would be my guess as well:

Code: Select all

sudo systemctl restart networking.servic
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

djnesic
Level 1
Level 1
Posts: 41
Joined: Fri Dec 16, 2016 2:05 pm
Location: Belgrade, Serbia

Re: After suspend mode wired connecttion does not work

Post by djnesic »

Is it mean that I have to repeat all procedure and replace "network-manager.service" by "networking.service"

User avatar
Sir Charles
Level 7
Level 7
Posts: 1895
Joined: Thu Jan 04, 2018 1:00 pm

Re: After suspend mode wired connecttion does not work

Post by Sir Charles »

djnesic wrote:
Sun Jul 08, 2018 6:32 am
Is it mean that I have to repeat all procedure and replace "network-manager.service" by "networking.service"
Try first:

Code: Select all

sudo systemctl restart networking.service
after suspension. If it works, you would need to do:

Code: Select all

xed admin:///etc/systemd/system/network-resume.service
and changenetwork-manager.servicetonetworking.service. Save and close the file. Next reboot.

If still no go, I am afraid I am out of ideas.

Fingers crossed!
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

djnesic
Level 1
Level 1
Posts: 41
Joined: Fri Dec 16, 2016 2:05 pm
Location: Belgrade, Serbia

Re: After suspend mode wired connecttion does not work

Post by djnesic »

No, it does not work. It is Interesting that if suspend mode short (1 or 2 minutes) everything is OK (it was before today too), but if suspend mode longer than 1 or 2 minutes I have to reboot.

User avatar
Sir Charles
Level 7
Level 7
Posts: 1895
Joined: Thu Jan 04, 2018 1:00 pm

Re: After suspend mode wired connecttion does not work

Post by Sir Charles »

djnesic wrote:
Sun Jul 08, 2018 7:04 am
No, it does not work. It is Interesting that if suspend mode short (1 or 2 minutes) everything is OK (it was before today too), but if suspend mode longer than 1 or 2 minutes I have to reboot.
Just for other people looking in for further troubleshooting, please post the terminal ouput of:

Code: Select all

iwconfig
I suppose that's one of the ironies of life, doing the wrong thing at the right moment -C.C.

djnesic
Level 1
Level 1
Posts: 41
Joined: Fri Dec 16, 2016 2:05 pm
Location: Belgrade, Serbia

Re: After suspend mode wired connecttion does not work

Post by djnesic »

Code: Select all

djnesic@djnesic-P31-DS3L:~$ iwconfig
enp3s0    no wireless extensions.

lo        no wireless extensions.

Post Reply

Return to “Newbie Questions”