font rendering

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
desperados
Level 3
Level 3
Posts: 160
Joined: Wed Apr 13, 2016 1:57 am

font rendering

Post by desperados » Sun Jul 08, 2018 6:05 pm

hi all
i've installed mint 19 tara cinnamon, but fonts are not good as in windows
for example, see this 2 screenshots of twitch from chrome (enlarge, both preview are not clear. can i show them in original dimensions?)
same font, Helvetica, but in Mint it's not clear
how to improve?
thanks
Attachments
Mint
Mint
Windows
Windows

desperados
Level 3
Level 3
Posts: 160
Joined: Wed Apr 13, 2016 1:57 am

Re: font rendering

Post by desperados » Mon Jul 09, 2018 6:02 pm

no solutions?

User avatar
Flemur
Level 17
Level 17
Posts: 7323
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: font rendering

Post by Flemur » Mon Jul 09, 2018 8:04 pm

Check the "hinting" in the font settings.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

User avatar
trytip
Level 11
Level 11
Posts: 3823
Joined: Tue Jul 05, 2016 1:20 pm

Re: font rendering

Post by trytip » Mon Jul 09, 2018 8:10 pm

in cinnamon mint 19 changing hinting in settings/fonts do nothing for me. you can test:
create a folder in home call it .fontconfig inside this folder create a blank text call it fonts.conf and paste this then logOFF/ON:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit name="antialias" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hinting" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hintstyle" mode="assign">
            <const>hintslight</const>
        </edit>
        <edit name="rgba" mode="assign">
            <const>rgb</const>
        </edit>
        <edit name="autohint" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="lcdfilter" mode="assign">
            <const>lcddefault</const>
        </edit>
        <edit name="dpi" mode="assign">
            <double>102</double>
        </edit>
    </match>
    <match target="font">
        <test name="weight" compare="more">
            <const>medium</const>
        </test>
        <edit name="autohint" mode="assign">
            <bool>true</bool>
        </edit>
    </match>
</fontconfig>
Image

desperados
Level 3
Level 3
Posts: 160
Joined: Wed Apr 13, 2016 1:57 am

Re: font rendering

Post by desperados » Tue Jul 10, 2018 11:55 am

i've tried many options from "system settings" > "fonts" but nothing changes

EDIT:

the best choices for me are:
hinting: slight medium or full are the same
antialiasing: rgba
rgba order: rgb
but none of them are "perfect"

User avatar
trytip
Level 11
Level 11
Posts: 3823
Joined: Tue Jul 05, 2016 1:20 pm

Re: font rendering

Post by trytip » Wed Jul 11, 2018 12:58 am

have you tried to use .fontconfig? if no changes you can just delete
Image

Abd121
Level 1
Level 1
Posts: 8
Joined: Fri Dec 07, 2018 11:58 am

Re: font rendering

Post by Abd121 » Fri Dec 21, 2018 1:22 pm

trytip wrote:
Mon Jul 09, 2018 8:10 pm
in cinnamon mint 19 changing hinting in settings/fonts do nothing for me. you can test:
create a folder in home call it .fontconfig inside this folder create a blank text call it fonts.conf and paste this then logOFF/ON:

Code: Select all

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match target="font">
        <edit name="antialias" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hinting" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="hintstyle" mode="assign">
            <const>hintslight</const>
        </edit>
        <edit name="rgba" mode="assign">
            <const>rgb</const>
        </edit>
        <edit name="autohint" mode="assign">
            <bool>true</bool>
        </edit>
        <edit name="lcdfilter" mode="assign">
            <const>lcddefault</const>
        </edit>
        <edit name="dpi" mode="assign">
            <double>102</double>
        </edit>
    </match>
    <match target="font">
        <test name="weight" compare="more">
            <const>medium</const>
        </test>
        <edit name="autohint" mode="assign">
            <bool>true</bool>
        </edit>
    </match>
</fontconfig>


December 2018, I have tried this and it finally makes my text less of a headache to read. totally recommend using this fix. but I kinda wonder why such a bug still exists this long after release!

Post Reply

Return to “Newbie Questions”