[Solved] Looking for the USB Controls to prevent USB sleep mode

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
madricodex
Level 1
Level 1
Posts: 4
Joined: Tue Jul 03, 2018 10:42 pm

[Solved] Looking for the USB Controls to prevent USB sleep mode

Post by madricodex » Mon Jul 16, 2018 7:24 pm

In Linux Mint 18.3 my USB wireless mouse and keyboard fall asleep after a while.
I have found the post of the gentleman who had the same problem and he wrote that he disconnects the wireless dongle and reconnect it.

What I want is to find is where are the USB controls in Linux Mint 18.3 and how to prevent the USB ports from falling asleep.
Is there something in LM 18.3 that permits that?
Does anyone knows an incantation that starts with sudo or bash that could do the trick?
Last edited by madricodex on Wed Jul 18, 2018 5:17 pm, edited 1 time in total.

User avatar
Lord Boltar
Level 4
Level 4
Posts: 344
Joined: Mon Jan 09, 2017 7:24 pm

Re: Looking for the USB Controls to prevent USB sleep mode

Post by Lord Boltar » Mon Jul 16, 2018 8:54 pm

Just copy paste the following command in terminal and it will Disable USB autosuspend

echo on | sudo tee /sys/bus/usb/devices/*/power/level >/dev/null

hope that helps

madricodex
Level 1
Level 1
Posts: 4
Joined: Tue Jul 03, 2018 10:42 pm

Re: Looking for the USB Controls to prevent USB sleep mode

Post by madricodex » Tue Jul 17, 2018 1:31 pm

Thank you very much!
The terminal command line you prescribed works very well.
My mouse and keyboard are no longuer sedated any more.

Thank you Lord Boltar

madricodex
Level 1
Level 1
Posts: 4
Joined: Tue Jul 03, 2018 10:42 pm

Re: Looking for the USB Controls to prevent USB sleep mode

Post by madricodex » Sat Aug 04, 2018 7:27 am

Lord Boltar wrote:
Mon Jul 16, 2018 8:54 pm
Just copy paste the following command in terminal and it will Disable USB autosuspend

echo on | sudo tee /sys/bus/usb/devices/*/power/level >/dev/null

hope that helps
BTW Lord Boltar, is the above terminal command something to be done only once and the fix is permanent, or do I have to execute it in terminal each time I boot?

User avatar
Lord Boltar
Level 4
Level 4
Posts: 344
Joined: Mon Jan 09, 2017 7:24 pm

Re: Looking for the USB Controls to prevent USB sleep mode

Post by Lord Boltar » Sun Aug 05, 2018 8:19 pm

madricodex wrote:
Sat Aug 04, 2018 7:27 am
Lord Boltar wrote:
Mon Jul 16, 2018 8:54 pm
Just copy paste the following command in terminal and it will Disable USB autosuspend

echo on | sudo tee /sys/bus/usb/devices/*/power/level >/dev/null

hope that helps
BTW Lord Boltar, is the above terminal command something to be done only once and the fix is permanent, or do I have to execute it in terminal each time I boot?
should be good only once

madricodex
Level 1
Level 1
Posts: 4
Joined: Tue Jul 03, 2018 10:42 pm

Re: [Solved] Looking for the USB Controls to prevent USB sleep mode

Post by madricodex » Mon Aug 06, 2018 7:46 am

Thank you very much Lord Boltar.
Your help is very appreciated.

Post Reply

Return to “Newbie Questions”