[SOLVED] Mint 19 on shutdown at-spi-bus-launcher not responding

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
Mage of Maple
Level 1
Level 1
Posts: 42
Joined: Tue Jul 10, 2018 10:41 am
Location: Maryland USA
Contact:

[SOLVED] Mint 19 on shutdown at-spi-bus-launcher not responding

Post by Mage of Maple » Wed Jul 18, 2018 8:20 pm

Hello,

After switching to Mint 19, when I try to shut down I always get a "program is still running" dialog box telling me that at-spi-bus-launcher is not responding. I click "shut down anyway" and all is well, but it is annoying. This happens on a clean install of Mint 19 Mate and also on a VM running Mint 19 Cinnamon that was upgraded from 18.3.

Any ideas?

Thanks,
Greg
Last edited by Mage of Maple on Fri Jul 20, 2018 7:13 pm, edited 1 time in total.

User avatar
Nic Deane
Level 1
Level 1
Posts: 18
Joined: Mon May 27, 2013 7:28 am
Location: Nottingham

Re: Mint 19 on shutdown at-spi-bus-launcher not responding

Post by Nic Deane » Thu Jul 19, 2018 5:52 am

Was going to ask the same question! Anyone with any answers?

User avatar
Lord Boltar
Level 4
Level 4
Posts: 382
Joined: Mon Jan 09, 2017 7:24 pm

Re: Mint 19 on shutdown at-spi-bus-launcher not responding

Post by Lord Boltar » Thu Jul 19, 2018 9:39 am

Sounds like it may be a bug

navigate to this location

/usr/lib/at-spi2-core/at-spi2-registryd

you will have to use sudo or open as root and right click it and select properties and uncheck the box that allows it to be executable - reboot and see if that worked
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

User avatar
Mage of Maple
Level 1
Level 1
Posts: 42
Joined: Tue Jul 10, 2018 10:41 am
Location: Maryland USA
Contact:

Re: Mint 19 on shutdown at-spi-bus-launcher not responding

Post by Mage of Maple » Thu Jul 19, 2018 9:27 pm

Lord Boltar wrote:
Thu Jul 19, 2018 9:39 am
Sounds like it may be a bug

navigate to this location

/usr/lib/at-spi2-core/at-spi2-registryd

you will have to use sudo or open as root and right click it and select properties and uncheck the box that allows it to be executable - reboot and see if that worked
Removing execute privileges from at-spi2-registryd did not solve the problem. Did you mean to remove the execute privs from at-spi-bus-launcher? That would indeed remove the error - it wouldn't have a problem with not being able to stop if it was not allowed to start in the first place... but surely this program is running for some purpose.

User avatar
Lord Boltar
Level 4
Level 4
Posts: 382
Joined: Mon Jan 09, 2017 7:24 pm

Re: Mint 19 on shutdown at-spi-bus-launcher not responding

Post by Lord Boltar » Thu Jul 19, 2018 9:48 pm

Removing execute privileges from at-spi2-registryd did not solve the problem. Did you mean to remove the execute privs from at-spi-bus-launcher? That would indeed remove the error - it wouldn't have a problem with not being able to stop if it was not allowed to start in the first place... but surely this program is running for some purpose.


that is whole point to see if error goes away - it is part of GTK3 which Cinnamon uses - it is possible that Cinnamon is corrupted you might have to reinstall it
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

User avatar
Mage of Maple
Level 1
Level 1
Posts: 42
Joined: Tue Jul 10, 2018 10:41 am
Location: Maryland USA
Contact:

Re: Mint 19 on shutdown at-spi-bus-launcher not responding

Post by Mage of Maple » Fri Jul 20, 2018 6:33 pm

Lord Boltar wrote:
Thu Jul 19, 2018 9:48 pm
it is possible that Cinnamon is corrupted you might have to reinstall it
How does one go about doing that?

User avatar
Mage of Maple
Level 1
Level 1
Posts: 42
Joined: Tue Jul 10, 2018 10:41 am
Location: Maryland USA
Contact:

Re: Mint 19 on shutdown at-spi-bus-launcher not responding

Post by Mage of Maple » Fri Jul 20, 2018 7:13 pm

Never mind - this problem is solved. It appears that a just-released update has fixed it on both machines.

Thanks!

User avatar
Lord Boltar
Level 4
Level 4
Posts: 382
Joined: Mon Jan 09, 2017 7:24 pm

Re: [SOLVED] Mint 19 on shutdown at-spi-bus-launcher not responding

Post by Lord Boltar » Fri Jul 20, 2018 8:36 pm

Glad the update fixed your issue
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

ergoroca
Level 1
Level 1
Posts: 1
Joined: Sat Oct 13, 2018 6:36 pm

Re: [SOLVED] Mint 19 on shutdown at-spi-bus-launcher not responding

Post by ergoroca » Sat Oct 20, 2018 9:46 am

OK, so I know you said this is solved, but I still have this problem in my laptop. Just installed mint a couple of weeks ago, so I assume it's up to date.
Any fix for this?

gm10
Level 13
Level 13
Posts: 4629
Joined: Thu Jun 21, 2018 5:11 pm

Re: [SOLVED] Mint 19 on shutdown at-spi-bus-launcher not responding

Post by gm10 » Sat Oct 20, 2018 10:49 am

ergoroca wrote:
Sat Oct 20, 2018 9:46 am
OK, so I know you said this is solved, but I still have this problem in my laptop. Just installed mint a couple of weeks ago, so I assume it's up to date.
Any fix for this?
viewtopic.php?p=1540809#p1540809

Post Reply

Return to “Newbie Questions”