SOLVED - Very long boot time and error messages on LM19

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
ACS1986
Level 1
Level 1
Posts: 15
Joined: Fri May 19, 2017 12:54 pm

SOLVED - Very long boot time and error messages on LM19

Post by ACS1986 » Fri Jul 20, 2018 3:28 pm

Hi,

Since moving from LMDE to LM19 XFCE I'm having very long boot times (Over 4 minutes). The following error messages are shown multiple times during boot

[drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:41:pipe B] flip_done timed out
[drm:drm_atomic_helper_wait_for_dependencies [drm_kms_helper]] *ERROR* [PLANE:35:plane B] flip_done timed out

There is also a significant delay when logging in or unlocking a locked session during which I get a black screen.. None of these issues were present in LMDE 2 but are present in 18.3 and all 3 variants of 19 (i've tried these from live USBs), so it could be a regression in the newer kernels. Once actually logged in everything functions fine.

Booting using Nomodeset does solve the boot problems but leaves the computer in software rendering mode giving significantly poorer resolution. If anybody has any suggestions for a more satisfactory solution I'd be very grateful.

Adam

Code: Select all

System:    Host: adam-Satellite-Pro-L300 Kernel: 4.15.0-29-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Linux Mint 19 Tara
Machine:   Device: other-vm? System: TOSHIBA product: Satellite Pro L300 v: PSLB1E-01S015EN serial: N/A
           Mobo: Intel model: N/A serial: N/A
           BIOS: INSYDE v: 1.50 date: 07/10/2008
CPU:       Dual core Intel Pentium Dual T2390 (-MCP-) 
           arch: Conroe rev.13 cache: 1024 KB
           flags: (lm nx sse sse2 sse3 ssse3) bmips: 7448
           clock speeds: max: 1867 MHz 1: 1596 MHz 2: 1494 MHz
Graphics:  Card: Intel Mobile GM965/GL960 Integrated Graphics Controller (primary)
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1280x800@60.00hz
           OpenGL: renderer: Mesa DRI Intel 965GM
           version: 2.1 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Intel 82801H (ICH8 Family) HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-29-generic
Network:   Card-1: Realtek RTL8101/2/6E PCIE Fast/Gigabit Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 3000 bus-ID: 02:00.0
           IF: enp2s0 state: down mac: <filter>
           Card-2: Realtek RTL8187B Wireless Adapter usb-ID: 002-002
           IF: N/A state: N/A mac: N/A
Drives:    HDD Total Size: 120.0GB (17.2% used)
           ID-1: /dev/sda model: FUJITSU_MHZ2120B size: 120.0GB
Partition: ID-1: / size: 104G used: 14G (14%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 6.50GB used: 0.00GB (0%)
           fs: swap dev: /dev/sda2
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 57.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Repos:     Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com tara main upstream import backport #id:linuxmint_main
           deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ bionic partner
Info:      Processes: 152 Uptime: 9 min Memory: 741.3/1984.2MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 
Last edited by ACS1986 on Sat Jul 21, 2018 4:09 am, edited 1 time in total.

User avatar
Lord Boltar
Level 4
Level 4
Posts: 382
Joined: Mon Jan 09, 2017 7:24 pm

Re: Very long boot time and error messages on LM19

Post by Lord Boltar » Fri Jul 20, 2018 9:01 pm

This is a bug basically a broke driver try to remove the Intel x86 Driver package with

sudo apt-get remove xserver-xorg-video-intel

and reboot see if it goes away

DRM = Direct Rendering Manager

did you recently upgrade the kernel?
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

User avatar
thx-1138
Level 6
Level 6
Posts: 1273
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Very long boot time and error messages on LM19

Post by thx-1138 » Fri Jul 20, 2018 9:47 pm

...try:
xed admin:///etc/default/grub
Modify the line there as:
GRUB_CMDLINE_LINUX_DEFAULT="video=SVIDEO-1:d quiet splash"
Save. Then sudo update-grub & reboot...

ACS1986
Level 1
Level 1
Posts: 15
Joined: Fri May 19, 2017 12:54 pm

Re: Very long boot time and error messages on LM19

Post by ACS1986 » Sat Jul 21, 2018 3:51 am

Okay, brilliant. Thanks to both of you :D

I tried thx-1138's method first and it worked for me. Regarding kernels, yes, I believe there was a minor version update in the 4.15 kernel yesterday, but the problems were already present in earlier 4.15 versions and whichever kernel LM18.3 had by default. My big jump in kernels was in the upgrade from LMDE 2 to LM19 (3.16 to 4.15)

Post Reply

Return to “Newbie Questions”