[Solved] Three Second Hitch

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
hpmc13
Level 3
Level 3
Posts: 148
Joined: Tue Jun 04, 2013 4:26 pm

[Solved] Three Second Hitch

Post by hpmc13 » Sun Jul 29, 2018 8:33 pm

Since upgrading to LM19 Cinnamon, I'm experiencing a graphical hitch roughly every three seconds. It only lasts for a fraction of a second, but it's driving me nuts. It's most noticeable when watching video, but it's everywhere. While moving windows, typing, opening menus ... if the screens are on, it's happening. It does not affect sound. LM 18.3 was fine. I've un/reinstalled the Nvidia drivers a couple times to no avail.

Code: Select all

System:    Host: workpc Kernel: 4.15.0-29-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1) Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: Gigabyte product: N/A serial: N/A
           Mobo: Gigabyte model: 990FXA-UD3 R5 v: x.x serial: N/A
           BIOS: American Megatrends v: F2 date: 04/01/2015
CPU:       8 core AMD FX-8350 Eight-Core (-MCP-) arch: Bulldozer rev.0 cache: 16384 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 70732
           clock speeds: max: 4400 MHz 1: 2953 MHz 2: 1831 MHz 3: 1974 MHz 4: 2202 MHz 5: 1676 MHz 6: 1649 MHz
           7: 1646 MHz 8: 1838 MHz
Graphics:  Card: NVIDIA GM206 [GeForce GTX 960] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1280x1024@60.02hz, 1920x1080@60.00hz
           OpenGL: renderer: GeForce GTX 960/PCIe/SSE2 version: 4.6.0 NVIDIA 390.77 Direct Render: Yes
Audio:     Card-1 NVIDIA Device 0fba driver: snd_hda_intel bus-ID: 01:00.1 Sound: ALSA v: k4.15.0-29-generic
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: c000 bus-ID: 05:00.0
           IF: eth1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 1440.3GB (39.1% used)
           ID-1: /dev/sda model: ZOTAC_ZTSSD size: 120.0GB
           ID-2: /dev/sdb model: WDC_WD10EZEX size: 1000.2GB
           ID-3: /dev/sdc model: WDC_WD3200AAJS size: 320.1GB
Partition: ID-1: / size: 30G used: 15G (52%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 29G used: 6.1G (23%) fs: ext4 dev: /dev/sda2
           ID-3: swap-1 size: 2.14GB used: 0.00GB (0%) fs: swap dev: /dev/sda4
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 42.0C mobo: 30.9C gpu: 0.0:55C
           Fan Speeds (in rpm): cpu: 901 fan-2: 0 fan-3: 0 fan-4: 1473 fan-5: 0
Info:      Processes: 251 Uptime: 10:14 Memory: 2030.0/16006.6MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 

Any thoughts anyone? Please?!
Last edited by hpmc13 on Sun Aug 05, 2018 10:41 am, edited 1 time in total.
Running LM 19 Cinnamon

User avatar
Lord Boltar
Level 5
Level 5
Posts: 682
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: Three Second Hitch

Post by Lord Boltar » Sun Jul 29, 2018 9:12 pm

Try to update your nVidia Drivers

nVidia Drivers

open terminal and copy paste the below

sudo add-apt-repository ppa:graphics-drivers/ppa

then push enter and select yes to add

sudo apt-get update

then push enter wait for it to update then close the terminal

Then go to your Driver Manager and update to the latest drivers
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

User avatar
trytip
Level 10
Level 10
Posts: 3467
Joined: Tue Jul 05, 2016 1:20 pm

Re: Three Second Hitch

Post by trytip » Sun Jul 29, 2018 9:17 pm

uninstall xserver-xorg-video-nouveau and try a different kernel. i use ukuu installed the latest 4.17
Image

hpmc13
Level 3
Level 3
Posts: 148
Joined: Tue Jun 04, 2013 4:26 pm

Re: Three Second Hitch

Post by hpmc13 » Mon Jul 30, 2018 10:51 am

Lord Boltar wrote:
Sun Jul 29, 2018 9:12 pm
Try to update your nVidia Drivers
Thank you for the suggestion. I ran this, they upgraded to 396.45, but, unfortunately, no change.

Trytip: I did not upgrade the kernel; think I'll stay with what LM suggests for now. Thank you, though.

For fun I ran 'killall cinnamon' in the terminal and the hitch (along with a lot of other things) went away. So it would seem to me that cinnamon is causing it ... maybe. I'm not sure what to do with that info, though.
Running LM 19 Cinnamon

User avatar
Lord Boltar
Level 5
Level 5
Posts: 682
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: Three Second Hitch

Post by Lord Boltar » Mon Jul 30, 2018 11:05 am

You could run

sudo apt update

the run

sudo apt upgrade

to see if there is an update for Cinnamon
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing

User avatar
trytip
Level 10
Level 10
Posts: 3467
Joined: Tue Jul 05, 2016 1:20 pm

Re: Three Second Hitch

Post by trytip » Mon Jul 30, 2018 11:07 am

well at least boot the default kernel 4.15.20 to see if it's a kernel issue
Image

hpmc13
Level 3
Level 3
Posts: 148
Joined: Tue Jun 04, 2013 4:26 pm

[Solved] Re: Three Second Hitch

Post by hpmc13 » Sun Aug 05, 2018 10:20 am

Thanks everyone for your suggestions. I tried the following:
Upgraded graphics drivers
Went back to kernel 4.15.20
Went up to Kernel 4.17.11 (ukuu is very handy, trytip, thanks for that!)
Turned off and on various settings in Nvidia settings and in Cinnamon.
None of these things helped.

I sort of gave up, then I looking at applets for the panel. I was running CPU frequency applet that showed a warning regarding potential problems with Cinnamon. I'm pretty sure that that applet carried over from previous upgrades. I removed/uninstalled that applet, rebooted, and the hitch is gone.

Thanks again.
Running LM 19 Cinnamon

Post Reply

Return to “Newbie Questions”