huge log files eating up disc space

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
UnwantedArun
Level 2
Level 2
Posts: 54
Joined: Fri Aug 24, 2018 5:06 am

Re: huge log files eating up disc space

Post by UnwantedArun » Fri Aug 24, 2018 2:12 pm

JayBird707 wrote:
Fri Aug 24, 2018 2:08 pm
Isn't is:
sudo grub-update and not sudo update-grub
no it is "sudo update-grub"

User avatar
JayBird707
Level 3
Level 3
Posts: 112
Joined: Sat Jan 30, 2016 9:56 pm

Re: huge log files eating up disc space

Post by JayBird707 » Fri Aug 24, 2018 2:14 pm

What PCI cards are installed?
Dell Studio 1737 Laptop: HP6300 SFF Desktop: HP8000 USFF Desktop: Intel NUC NUC7CJYH Mini All on Linux Mint!
Image

UnwantedArun
Level 2
Level 2
Posts: 54
Joined: Fri Aug 24, 2018 5:06 am

Re: huge log files eating up disc space

Post by UnwantedArun » Fri Aug 24, 2018 2:17 pm

JayBird707 wrote:
Fri Aug 24, 2018 2:14 pm
What PCI cards are installed?
I don't know about PCI card.
Its laptop. So nothing external.

UnwantedArun
Level 2
Level 2
Posts: 54
Joined: Fri Aug 24, 2018 5:06 am

Re: huge log files eating up disc space

Post by UnwantedArun » Fri Aug 24, 2018 2:31 pm

Guys please help.. :(

UnwantedArun
Level 2
Level 2
Posts: 54
Joined: Fri Aug 24, 2018 5:06 am

Re: huge log files eating up disc space

Post by UnwantedArun » Fri Aug 24, 2018 2:32 pm

gm10 wrote:
Fri Aug 24, 2018 2:06 pm
Try adding the pci=noaer option in addition (same way as above).
This is also not working

Laurent85
Level 16
Level 16
Posts: 6100
Joined: Tue May 26, 2015 10:11 am

Re: huge log files eating up disc space

Post by Laurent85 » Fri Aug 24, 2018 3:28 pm

Create a rsyslog rule to discard pcieport messages:

Code: Select all

sudo nano /etc/rsyslog.d/00-pcieport.conf
Which contains:

Code: Select all

:syslogtag, contains, "pcieport"   stop
Restart rsyslog:

Code: Select all

sudo systemctl restart rsyslog
Image

gm10
Level 19
Level 19
Posts: 9217
Joined: Thu Jun 21, 2018 5:11 pm

Re: huge log files eating up disc space

Post by gm10 » Fri Aug 24, 2018 3:53 pm

^ while this stops the syslog from exploding, the spam will continue to go into kern.log. So we still need to find a solution.

The problematic device is one of your PCIe root hubs. Check for a BIOS update and also check your BIOS for PCI Express settings, if any. In particular PCIe link state power management seems a likely culprit.

If you cannot find anything, let's see what device is connected to it (likely a network device). First run

Code: Select all

lspci
You should see an entry for

Code: Select all

Intel Corporation Sunrise Point-LP PCI Express Root Port #6
Remember the number at the beginning of that line.
Now run

Code: Select all

lspci -tv
find the same numbers again (without the leading 00:) - to the right of it it tells you the device connected to that port. Let us know what it is. If it's not something you need we could just disable it.

Installing a different kernel series is also an option.

DAMIEN1307
Level 8
Level 8
Posts: 2072
Joined: Tue Feb 21, 2017 8:13 pm
Location: Alamogordo, New Mexico, USA

Re: huge log files eating up disc space

Post by DAMIEN1307 » Fri Aug 24, 2018 4:20 pm

hi arun...you didnt seem to quite know what everyone is talking about when they are telling you about pci...ive provided 2 links down below that will explain what pci is so you can have a knowledge of it and just what everyone is looking for so they can be of help...hang in there buddy and dont panic...it will be worked out...DAMIEN

https://www.lifewire.com/what-is-pci-2640242

https://en.wikipedia.org/wiki/Conventional_PCI
ORDO AB CHAO

Laurent85
Level 16
Level 16
Posts: 6100
Joined: Tue May 26, 2015 10:11 am

Re: huge log files eating up disc space

Post by Laurent85 » Fri Aug 24, 2018 7:22 pm

gm10 wrote:
Fri Aug 24, 2018 3:53 pm
^ while this stops the syslog from exploding, the spam will continue to go into kern.log.
Actually pcieport is part of the message, not the log tag itself. The correct rule property to dismiss pcieport messages is ":msg", not ":syslogtag".

To sum it up:

Create this rule file:

Code: Select all

sudo nano /etc/rsyslog.d/00-pcieport.conf
Containing the rule to dismiss pcieport messages:

Code: Select all

:msg, contains, "pcieport"   stop
Restart rsyslog:

Code: Select all

sudo systemctl restart rsyslog
Image

UnwantedArun
Level 2
Level 2
Posts: 54
Joined: Fri Aug 24, 2018 5:06 am

Re: huge log files eating up disc space

Post by UnwantedArun » Fri Aug 24, 2018 11:59 pm

Laurent85 wrote:
Fri Aug 24, 2018 3:28 pm
Create a rsyslog rule to discard pcieport messages:

Code: Select all

sudo nano /etc/rsyslog.d/00-pcieport.conf
Which contains:

Code: Select all

:syslogtag, contains, "pcieport"   stop
Restart rsyslog:

Code: Select all

sudo systemctl restart rsyslog
I've done this exactly as you said
Created that file.
Put

Code: Select all

:syslogtag, contains, "pcieport"   stop
in to it.
Executed the 3rd query to restart.

But it didn't worked. Same thing happens.
As i said, i done it through recovery mode.
Because i only get 1-2 minutes before the log file eats up my entire disc.


gm10 wrote:
Fri Aug 24, 2018 3:53 pm
^ while this stops the syslog from exploding, the spam will continue to go into kern.log. So we still need to find a solution.

The problematic device is one of your PCIe root hubs. Check for a BIOS update and also check your BIOS for PCI Express settings, if any. In particular PCIe link state power management seems a likely culprit.

If you cannot find anything, let's see what device is connected to it (likely a network device). First run

Code: Select all

lspci
You should see an entry for

Code: Select all

Intel Corporation Sunrise Point-LP PCI Express Root Port #6
Remember the number at the beginning of that line.
Now run

Code: Select all

lspci -tv
find the same numbers again (without the leading 00:) - to the right of it it tells you the device connected to that port. Let us know what it is. If it's not something you need we could just disable it.

Installing a different kernel series is also an option.
The output is below.
Please check if there's any problem.

https://bit.ly/2P5FNHc
https://bit.ly/2P5BLys

UnwantedArun
Level 2
Level 2
Posts: 54
Joined: Fri Aug 24, 2018 5:06 am

Re: huge log files eating up disc space

Post by UnwantedArun » Sat Aug 25, 2018 12:23 am

DAMIEN1307 wrote:
Fri Aug 24, 2018 4:20 pm
hi arun...you didnt seem to quite know what everyone is talking about when they are telling you about pci...ive provided 2 links down below that will explain what pci is so you can have a knowledge of it and just what everyone is looking for so they can be of help...hang in there buddy and dont panic...it will be worked out...DAMIEN

https://www.lifewire.com/what-is-pci-2640242

https://en.wikipedia.org/wiki/Conventional_PCI
Thanks for your support.
I've read it. Understood something.

oldgranola
Level 4
Level 4
Posts: 357
Joined: Fri Sep 05, 2014 1:39 am

Re: huge log files eating up disc space

Post by oldgranola » Sat Aug 25, 2018 12:57 am

Its obvious you have a hardware issue, perhaps hardware vs kernel.

To make the hardware and PCI bit simpler I summarize. there are communication systems on the motherboard that allows the cpu+memory to communicate with all the other stuff like graphics, sound, network, usb controllers and the hard drives etc. Much but not all of that is now part of the PCI system. Everything attached to it has io or port numbers and the commands above get info on those. Depending on the system, some of the above is integrated on the motherboard (yet still PCI) and some is plugged into slots on the motherboard most of which also called PCI. The commands you were asked to run are to detail whats in your system so folks can correlate the hardware with the error logs. Sometimes its a bit too detailed to parse easily. I hate to ask, but another simpler look at your system would be to run:

Code: Select all

sudo inxi -F -r
Its case sensitive. This will just give an overall simple picture but I find it helpful myself.
comadore, pcDOS, hpux, solaris, vms-vax ....blah blah blah..
Yet I'm still a fn nooob

User avatar
catweazel
Level 19
Level 19
Posts: 9501
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: huge log files eating up disc space

Post by catweazel » Sat Aug 25, 2018 1:00 am

oldgranola wrote:
Sat Aug 25, 2018 12:57 am
Its obvious you have a hardware issue
No it isn't.

The problem is a known kernel bug and it can be worked around using the pcie_aspm=off kernel boot parameter in GrUB.
oldgranola wrote:sudo inxi -F -r

Crikey!
You're going to make the poster reveal their MAC address. Also, sudo is not required.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

UnwantedArun
Level 2
Level 2
Posts: 54
Joined: Fri Aug 24, 2018 5:06 am

Re: huge log files eating up disc space

Post by UnwantedArun » Sat Aug 25, 2018 1:14 am

oldgranola wrote:
Sat Aug 25, 2018 12:57 am
Its obvious you have a hardware issue, perhaps hardware vs kernel.

To make the hardware and PCI bit simpler I summarize. there are communication systems on the motherboard that allows the cpu+memory to communicate with all the other stuff like graphics, sound, network, usb controllers and the hard drives etc. Much but not all of that is now part of the PCI system. Everything attached to it has io or port numbers and the commands above get info on those. Depending on the system, some of the above is integrated on the motherboard (yet still PCI) and some is plugged into slots on the motherboard most of which also called PCI. The commands you were asked to run are to detail whats in your system so folks can correlate the hardware with the error logs. Sometimes its a bit too detailed to parse easily. I hate to ask, but another simpler look at your system would be to run:

Code: Select all

sudo inxi -F -r
Its case sensitive. This will just give an overall simple picture but I find it helpful myself.
I've been using Kali linux for almost 2 years. I didn't experienced any issues.
Also there's a windows 10 in the other end. He too don't have any issues.
So i hope it is not hardware related.

Here's the ss for your query
https://bit.ly/2P4XAhn

gm10
Level 19
Level 19
Posts: 9217
Joined: Thu Jun 21, 2018 5:11 pm

Re: huge log files eating up disc space

Post by gm10 » Sat Aug 25, 2018 1:24 am

UnwantedArun wrote:
Fri Aug 24, 2018 11:59 pm
The output is below.
Please check if there's any problem.

https://bit.ly/2P5FNHc
https://bit.ly/2P5BLys
Those image files are not acccessible (error 403 - authorization required). You can just upload them as an attachment here.

More importantly, try what catweazel suggested, same way that you added the boot parameters I gave you previously. I wasn't aware of this particular parameter but it sounds like it would do exactly what I asked you do to try and disable it in the BIOS (PCIe link state power management), so try this as a priority (thanks catweazel!):
catweazel wrote:
Sat Aug 25, 2018 1:00 am
The problem is a known kernel bug and it can be worked around using the pcie_aspm=off kernel boot parameter in GrUB.

UnwantedArun
Level 2
Level 2
Posts: 54
Joined: Fri Aug 24, 2018 5:06 am

Re: huge log files eating up disc space

Post by UnwantedArun » Sat Aug 25, 2018 1:32 am

gm10 wrote:
Sat Aug 25, 2018 1:24 am
UnwantedArun wrote:
Fri Aug 24, 2018 11:59 pm
The output is below.
Please check if there's any problem.

https://bit.ly/2P5FNHc
https://bit.ly/2P5BLys
Those image files are not acccessible (error 403 - authorization required). You can just upload them as an attachment here.
While attaching, it says file size too large.
I hope the the image is working fine. It'll be some redirection issues. I too did got that error. Try once more.
Here's the direct link

https://jerking.empornium.ph/images/201 ... 085828.jpg
https://jerking.empornium.ph/images/201 ... 085626.jpg

gm10
Level 19
Level 19
Posts: 9217
Joined: Thu Jun 21, 2018 5:11 pm

Re: huge log files eating up disc space

Post by gm10 » Sat Aug 25, 2018 1:36 am

Nope. Try imgur.com. Also really do catweazel's boot option first, I'm fairly confident it will work.

UnwantedArun
Level 2
Level 2
Posts: 54
Joined: Fri Aug 24, 2018 5:06 am

Re: huge log files eating up disc space

Post by UnwantedArun » Sat Aug 25, 2018 1:43 am


User avatar
catweazel
Level 19
Level 19
Posts: 9501
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: huge log files eating up disc space

Post by catweazel » Sat Aug 25, 2018 1:44 am

gm10 wrote:
Sat Aug 25, 2018 1:24 am
(thanks catweazel!):
You're most welcome. We all learn from one another :)

Also, I have this very same problem.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

UnwantedArun
Level 2
Level 2
Posts: 54
Joined: Fri Aug 24, 2018 5:06 am

Re: huge log files eating up disc space

Post by UnwantedArun » Sat Aug 25, 2018 1:47 am

catweazel wrote:
Sat Aug 25, 2018 1:00 am
The problem is a known kernel bug and it can be worked around using the pcie_aspm=off kernel boot parameter in GrUB.
This has disabled the grub. But the problem still continues

Post Reply

Return to “Newbie Questions”