can't lock on repository

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Level 3
Level 3
Posts: 148
Joined: Tue Jan 06, 2009 12:09 am
Location: crossville tn

can't lock on repository

Postby kaykav » Mon Jun 15, 2009 8:12 am

Good morning,..........Jun15.9 7:15am

For the longest time I can,t download some apps. I get a message : " Could not get lock /var/cache/apt/archives/lock - open (11 Resource temporarily unavailable)
E: Unable to lock the download directory". Why is this? What do I need to do to eliminate this problem? Where can I find some tutorial on this subject? Thanks ......Rich

Level 8
Level 8
Posts: 2158
Joined: Thu Feb 26, 2009 8:58 pm

Re: can't lock on repository

Postby emorrp1 » Mon Jun 15, 2009 8:42 am

That's the standard error report for trying to use more than one package manager at once, e.g. apt variants, mintInstall, mintUpdate (only when actually updating/upgrading), synaptic. Try closing them all, or setting mintUpdate's refresh time to a longer period (no need to update every 5 mins).
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term

Return to “Newbie Questions”