Need help with networking

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
jerson
Level 3
Level 3
Posts: 168
Joined: Thu Dec 08, 2016 1:19 pm
Location: Bombay, India

Need help with networking

Post by jerson »

Greetings

I used to have Nemo - Connect to Server working till recently. I was trying to get Samba to work with virtualbox and did not succeed. In the process, I think I broke something. Now, Nemo shows an alert when I try to connect to server "Can't load the supported server method list. Please check your gvfs installation"

I have the following installed at the moment Gadmin-samba and Samba under the applications tree. When I launch Samba, it gives 3 errors and says these are possible configuration errors. One is for password level=6, another for enable spoolss=Yes and the third for update encrypted = Yes

I have absolutely no experience in this area and am requesting a helping hand. At the moment, I have VBox with its shared folders working fine.

1 - I need to be able to get Nemo to connect to server.
2 - Help with making accessible host files to a KVM machine running WinXP

Code: Select all

System:    Host: jerson-G31M-ES2L Kernel: 4.4.0-116-generic x86_64 (64 bit gcc: 5.4.0)
           Desktop: Cinnamon 3.0.7 (Gtk 2.24.30) Distro: Linux Mint 18 Sarah
Machine:   System: Gigabyte product: G31M-ES2L
           Mobo: Gigabyte model: G31M-S2L Bios: Award v: F10 date: 09/29/2009
CPU:       Quad core Intel Core2 Quad Q6600 (-MCP-) cache: 4096 KB
           flags: (lm nx sse sse2 sse3 ssse3 vmx) bmips: 19199
           clock speeds: max: 2400 MHz 1: 1600 MHz 2: 1600 MHz 3: 1600 MHz
           4: 1600 MHz
Graphics:  Card: Intel 82G33/G31 Express Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.Org 1.18.4 driver: intel
           Resolution: 1360x768@60.02hz
           GLX Renderer: Mesa DRI Intel G33
           GLX Version: 1.4 Mesa 11.2.0 Direct Rendering: Yes
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.4.0-116-generic
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: be00 bus-ID: 02:00.0
           IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
           WAN IP: <filter> IF: enp2s0 ip-v4: <filter> ip-v6: <filter>
           IF: virbr0-nic ip-v4: N/A ip-v6: N/A
           IF: virbr0 ip-v4: <filter> ip-v6: N/A
Drives:    HDD Total Size: 1500.3GB (2.8% used)
           ID-1: /dev/sda model: ST3500413AS size: 500.1GB
           ID-2: /dev/sdb model: WDC_WD10EZEX size: 1000.2GB
Partition: ID-1: / size: 92G used: 22G (26%) fs: ext4 dev: /dev/sdb5
           ID-2: /home size: 92G used: 8.2G (10%) fs: ext4 dev: /dev/sdb6
           ID-3: swap-1 size: 10.00GB used: 0.00GB (0%) fs: swap dev: /dev/sdb1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 66.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 183 Uptime: 13 min Memory: 690.4/3941.3MB
           Init: systemd runlevel: 5 Gcc sys: 5.4.0
           Client: Shell (bash 4.3.481) inxi: 2.2.35 
Regards
Jerson

altair4
Level 19
Level 19
Posts: 9857
Joined: Tue Feb 03, 2009 10:27 am

Re: Need help with networking

Post by altair4 »

Gadmin-samba was designed for Version 2 of Samba. We are at Samba Version 4 which is why you got all those error messages. It made a mess of your smb.conf which has some impact on the samba client.

"Samba" is system-config-samba and that was built for Version 3 of Samba. Luckily it won't run unless you know how to fix it.

My advice is to start over and reset your smb.conf file - it only takes 3 steps:

Rename your current smb.conf:

Code: Select all

sudo mv /etc/samba/smb.conf /etc/samba/smb.confORIG
Copy the backup to the working location:

Code: Select all

sudo cp -a /usr/share/samba/smb.conf /etc/samba/
Then restart smbd:

Code: Select all

sudo service smbd restart
"Can't load the supported server method list. Please check your gvfs installation"
I have never seen that error message. If I had to guess it would be a missing package:

Code: Select all

sudo apt install gvfs-backends
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

jerson
Level 3
Level 3
Posts: 168
Joined: Thu Dec 08, 2016 1:19 pm
Location: Bombay, India

Re: Need help with networking

Post by jerson »

I did as you suggested and got my "Connect to server" working again after logout/login

I got a snapshot of the error before applying the suggestions so you know what I got before.
Nemo error on &quot;Connect to Server&quot;
Nemo error on "Connect to Server"
Nemo Error.jpg (9.62 KiB) Viewed 263 times
Could you give me any pointers on how to get my machine to share folders over the local network ?

Appreciate your help
Regards
Jerson

altair4
Level 19
Level 19
Posts: 9857
Joined: Tue Feb 03, 2009 10:27 am

Re: Need help with networking

Post by altair4 »

Since you are using Mint Cinnamon you could create a samba usershare:

Open Nemo and right click a folder you own like your Public folder. Then select Sharing Options > Slide the switch to Share this folder and check all the boxes. You will create a writeable share of your Public folder.

You have a lot of "stuff" going on there with Vitrualbox and KVM so I don't know how much further help I can offer. On VBox itself just make sure that your Network Adapter is set to Bridge Adapter and not NAT. With NAT you will only be able to access other shares. No one will be able to access yours.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

jerson
Level 3
Level 3
Posts: 168
Joined: Thu Dec 08, 2016 1:19 pm
Location: Bombay, India

Re: Need help with networking

Post by jerson »

Thanks again.

This time, I got the VM talking to the LM host and vice versa. The KVM guest cannot connect to some of the displayed LM shares (on different media) and alerts me of a permissions problem.

Shares from the LM host machine user folder are working.

Currently smbguest has membership of kvm, sambamachines, sambashares and users. The shares which do not work are on /media/user/drivex/folder.
Regards
Jerson

altair4
Level 19
Level 19
Posts: 9857
Joined: Tue Feb 03, 2009 10:27 am

Re: Need help with networking

Post by altair4 »

The shares which do not work are on /media/user/drivex/folder.
Edit /etc/samba/smb.conf and right under the workgroup = WORKGROUP line add this one:

Code: Select all

force user = user
Replace "user" with the same name as in /media/user/drivex/folder

Save the file then restart smbd:

Code: Select all

sudo service smbd restart
This isn't a samba problem it's a linux permissions problem. The "force user" should fix it.
Please add a [SOLVED] at the end of your original subject header if your question has been answered and solved.

jerson
Level 3
Level 3
Posts: 168
Joined: Thu Dec 08, 2016 1:19 pm
Location: Bombay, India

Re: Need help with networking

Post by jerson »

I'm sorry, I did not respond earlier. I have some part of the networking working - including with the Virtual Machines. However, trying to reach the host network shares seems to be an issue. Just to make things clear, I can launch 2 virtual machines and they communicate between each other (WinXP and LMDE19). The host machine shares show up, but when I try to access them, I get an error regarding permissions. The same host machine sharing a folder from my user home is accessible.

I am doing a lot of reading as I do not have a background in networking and some of these concepts with samba are not for the novice in me. I thank you for your support and will come back once I am in a better position to ask questions.

Thanks and good day
Regards
Jerson

Post Reply

Return to “Newbie Questions”