Help! Can't update software with update manager

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
aletave
Level 1
Level 1
Posts: 37
Joined: Thu Sep 13, 2018 12:12 pm

Re: Help! Can't update software with update manager

Post by aletave » Tue Sep 18, 2018 6:04 pm

linux-image-extra-3.16.0-38-generic
linux-image-extra-3.19.0-32-generic
linux-image-extra-4.4.0-109-generic
linux-image-extra-4.4.0-111-generic
linux-image-extra-4.4.0-112-generic
linux-image-extra-4.4.0-116-generic
linux-image-extra-4.4.0-119-generic
linux-image-extra-4.4.0-121-generic
linux-image-extra-4.4.0-124-generic
linux-image-extra-4.4.0-127-generic

gm10
Level 13
Level 13
Posts: 4553
Joined: Thu Jun 21, 2018 5:11 pm

Re: Help! Can't update software with update manager

Post by gm10 » Tue Sep 18, 2018 6:10 pm

Really now? Invincible packages. Or do these get re-installed by the sudo apt-get install -f -y? Probably. Sorry, it's late here, I'm tired, not thinking straight. But the important question is whether you still get the error messages?

DAMIEN1307
Level 6
Level 6
Posts: 1211
Joined: Tue Feb 21, 2017 8:13 pm
Location: Alamogordo, New Mexico, USA

Re: Help! Can't update software with update manager

Post by DAMIEN1307 » Tue Sep 18, 2018 6:17 pm

hey there gm10...do you thing that these codes will help get rid of the "Invincible packages" for the OP?...after he uninstalls the kernels again from the update manager?...DAMIEN

Code: Select all

sudo apt autoremove

Code: Select all

dpkg -l | grep '^rc' | awk '{print $2}' | sudo xargs dpkg --purge

Code: Select all

dpkg -l | grep '^rc' | awk '{print $2}' | xargs sudo apt-get purge
ORDO AB CHAO

gm10
Level 13
Level 13
Posts: 4553
Joined: Thu Jun 21, 2018 5:11 pm

Re: Help! Can't update software with update manager

Post by gm10 » Tue Sep 18, 2018 6:29 pm

DAMIEN1307 wrote:
Tue Sep 18, 2018 6:17 pm
hey there gm10...do you thing that these codes will help get rid of the "Invincible packages" for the OP?...after he uninstalls the kernels again from the update manager?...DAMIEN
Those just remove residual configuration, not packages, and removing kernels via Update Manager does not leave any behind.

aletave
Level 1
Level 1
Posts: 37
Joined: Thu Sep 13, 2018 12:12 pm

Re: Help! Can't update software with update manager

Post by aletave » Wed Sep 19, 2018 8:39 am

Hey GM10 yes I still can't update software and now my wifi adapter has disappeared. Nevermind these things are sent to try us lol

gm10
Level 13
Level 13
Posts: 4553
Joined: Thu Jun 21, 2018 5:11 pm

Re: Help! Can't update software with update manager

Post by gm10 » Wed Sep 19, 2018 8:46 am

Heh, true that. I think I definitely made a mistake continuing to give you that install -f command though, I was dead tired yesterday. Please confirm by running doing that last bit from yesterday without that part.

First (I don't need the output):

Code: Select all

sudo rm -fv /var/lib/dpkg/info/linux-image-extra-4.4.0-112-generic.* /var/lib/dpkg/info/linux-image-extra-4.4.0-116-generic.* /var/lib/dpkg/info/linux-image-extra-4.4.0-119-generic.* /var/lib/dpkg/info/linux-image-extra-4.4.0-121-generic.*
and then (I'd like the output):

Code: Select all

sudo dpkg --remove --force-remove-reinstreq --force-depends linux-image-extra-4.4.0-112-generic linux-image-extra-4.4.0-116-generic linux-image-extra-4.4.0-119-generic linux-image-extra-4.4.0-121-generic
and finally this (yes please to the output):

Code: Select all

dpkg-query -W -f '${Package}\n' | grep "^linux-image-extra"
Fingers crossed.

aletave
Level 1
Level 1
Posts: 37
Joined: Thu Sep 13, 2018 12:12 pm

Re: Help! Can't update software with update manager

Post by aletave » Wed Sep 19, 2018 9:14 am

ok thanks

came back with this

inux-image-extra-3.16.0-38-generic
linux-image-extra-3.19.0-32-generic
linux-image-extra-4.4.0-109-generic
linux-image-extra-4.4.0-111-generic
linux-image-extra-4.4.0-112-generic
linux-image-extra-4.4.0-116-generic
linux-image-extra-4.4.0-119-generic
linux-image-extra-4.4.0-121-generic
linux-image-extra-4.4.0-124-generic
linux-image-extra-4.4.0-127-generic

gm10
Level 13
Level 13
Posts: 4553
Joined: Thu Jun 21, 2018 5:11 pm

Re: Help! Can't update software with update manager

Post by gm10 » Wed Sep 19, 2018 9:18 am

I'd really like to see the output of the second set of commands please though. Do just a single one to make it shorter:

Code: Select all

sudo dpkg --remove --force-all linux-image-extra-4.4.0-112-generic

aletave
Level 1
Level 1
Posts: 37
Joined: Thu Sep 13, 2018 12:12 pm

Re: Help! Can't update software with update manager

Post by aletave » Wed Sep 19, 2018 9:20 am

dpkg: warning: ignoring request to remove linux-image-extra-4.4.0-112-generic, only the config
files of which are on the system; use --purge to remove them too

gm10
Level 13
Level 13
Posts: 4553
Joined: Thu Jun 21, 2018 5:11 pm

Re: Help! Can't update software with update manager

Post by gm10 » Wed Sep 19, 2018 10:05 am

aletave wrote:
Wed Sep 19, 2018 9:20 am
dpkg: warning: ignoring request to remove linux-image-extra-4.4.0-112-generic, only the config
files of which are on the system; use --purge to remove them too
Oh weird. That would work on my system, must be another Mint 17 thing. Let's comply, what happens if we --purge instead:

Code: Select all

sudo dpkg --purge --force-all linux-image-extra-4.4.0-112-generic

aletave
Level 1
Level 1
Posts: 37
Joined: Thu Sep 13, 2018 12:12 pm

Re: Help! Can't update software with update manager

Post by aletave » Wed Sep 19, 2018 10:14 am

my wifi is not working at all. is not even an option in the network manager. it has stopped since yesterday when i check the driver manager there is nothing there. Should I consider upgrading to Mint 18 or 19?

(Reading database ... 395752 files and directories currently installed.)
Removing linux-image-extra-4.4.0-112-generic (4.4.0-112.135~14.04.1) ...

gm10
Level 13
Level 13
Posts: 4553
Joined: Thu Jun 21, 2018 5:11 pm

Re: Help! Can't update software with update manager

Post by gm10 » Wed Sep 19, 2018 10:21 am

aletave wrote:
Wed Sep 19, 2018 10:14 am
my wifi is not working at all. is not even an option in the network manager. it has stopped since yesterday when i check the driver manager there is nothing there. Should I consider upgrading to Mint 18 or 19?
We can fix the wifi after we cleared up this mess with the broken kernel packages. We'll just update to the latest kernel 4.4 then and I have a feeling your wifi will start working again. An upgrade to Mint 18 or 19 is something to consider separately, but don't rush that, test it out in a live environment first to make sure it's actually compatible.
aletave wrote:
Wed Sep 19, 2018 10:14 am
(Reading database ... 395752 files and directories currently installed.)
Removing linux-image-extra-4.4.0-112-generic (4.4.0-112.135~14.04.1) ...
So all it wanted was purge, not remove? Cute. Let's do the other three as well then:

Code: Select all

sudo dpkg --purge --force-all linux-image-extra-4.4.0-116-generic linux-image-extra-4.4.0-119-generic linux-image-extra-4.4.0-121-generic
After that you can hopefully remove the rest with the command I originally gave:

Code: Select all

sudo apt-get purge --autoremove -y linux-image-3.16.0-38-generic linux-image-3.19.0-32-generic linux-image-4.4.0-109-generic linux-image-4.4.0-112-generic linux-image-4.4.0-116-generic linux-image-4.4.0-119-generic linux-image-4.4.0-121-generic linux-image-4.4.0-124-generic linux-image-4.4.0-127-generic linux-image-extra-3.16.0-38-generic linux-image-extra-3.19.0-32-generic linux-image-extra-4.4.0-109-generic 

aletave
Level 1
Level 1
Posts: 37
Joined: Thu Sep 13, 2018 12:12 pm

Re: Help! Can't update software with update manager

Post by aletave » Wed Sep 19, 2018 10:24 am

sudo apt-get purge --autoremove -y linux-image-3.16.0-38-generic linux-image-3.19.0-32-generic linux-image-4.4.0-109-generic linux-image-4.4.0-112-generic linux-image-4.4.0-116-generic linux-image-4.4.0-119-generic linux-image-4.4.0-121-generic linux-image-4.4.0-124-generic linux-image-4.4.0-127-generic linux-image-extra-3.16.0-38-generic linux-image-extra-3.19.0-32-generic linux-image-extra-4.4.0-109-generic
E: Command line option --autoremove is not understood

gm10
Level 13
Level 13
Posts: 4553
Joined: Thu Jun 21, 2018 5:11 pm

Re: Help! Can't update software with update manager

Post by gm10 » Wed Sep 19, 2018 10:33 am

Oh, someone shoot me, I need to take a Mint 17 course. First this then:

Code: Select all

sudo apt-get purge -y linux-image-3.16.0-38-generic linux-image-3.19.0-32-generic linux-image-4.4.0-109-generic linux-image-4.4.0-112-generic linux-image-4.4.0-116-generic linux-image-4.4.0-119-generic linux-image-4.4.0-121-generic linux-image-4.4.0-124-generic linux-image-4.4.0-127-generic linux-image-extra-3.16.0-38-generic linux-image-extra-3.19.0-32-generic linux-image-extra-4.4.0-109-generic 
If that works, then:

Code: Select all

sudo apt-get autoremove -y

aletave
Level 1
Level 1
Posts: 37
Joined: Thu Sep 13, 2018 12:12 pm

Re: Help! Can't update software with update manager

Post by aletave » Wed Sep 19, 2018 11:01 am

Dont think it worked

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'linux-image-4.4.0-112-generic' is not installed, so not removed
Package 'linux-image-4.4.0-116-generic' is not installed, so not removed
Package 'linux-image-4.4.0-119-generic' is not installed, so not removed
Package 'linux-image-4.4.0-121-generic' is not installed, so not removed
Package 'linux-image-4.4.0-124-generic' is not installed, so not removed
Package 'linux-image-4.4.0-127-generic' is not installed, so not removed
The following packages were automatically installed and are no longer required:
linux-headers-4.4.0-112 linux-headers-4.4.0-112-generic
linux-headers-4.4.0-116 linux-headers-4.4.0-116-generic
linux-headers-4.4.0-119 linux-headers-4.4.0-119-generic
linux-headers-4.4.0-121 linux-headers-4.4.0-121-generic
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED
linux-image-3.16.0-38-generic* linux-image-3.19.0-32-generic*
linux-image-4.4.0-109-generic* linux-image-extra-3.16.0-38-generic*
linux-image-extra-3.19.0-32-generic* linux-image-extra-4.4.0-109-generic*
linux-image-extra-4.4.0-124-generic linux-image-extra-4.4.0-127-generic
0 to upgrade, 0 to newly install, 8 to remove and 181 not to upgrade.
2 not fully installed or removed.
After this operation, 934 MB disk space will be freed.
(Reading database ... 395752 files and directories currently installed.)
Removing linux-image-extra-4.4.0-124-generic (4.4.0-124.148~14.04.1) ...
depmod: FATAL: could not load /boot/System.map-4.4.0-124-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-124-generic /boot/vmlinuz-4.4.0-124-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.4.0-124-generic /boot/vmlinuz-4.4.0-124-generic
Error! Bad return status for module build on kernel: 4.4.0-124-generic (x86_64)
Consult /var/lib/dkms/ndiswrapper/1.59/build/make.log for more information.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-124-generic /boot/vmlinuz-4.4.0-124-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-124-generic
grep: /boot/config-4.4.0-124-generic: No such file or directory
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-apple.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-apple.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-cherry.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-cherry.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-logitech.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-logitech.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-logitech-dj.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-logitech-dj.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-microsoft.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-microsoft.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-a4tech.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-a4tech.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-belkin.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-belkin.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-chicony.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-chicony.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-cypress.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-cypress.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-ezkey.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-ezkey.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-gyration.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-gyration.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-monterey.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-monterey.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-petalynx.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-petalynx.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-pl.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-pl.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-samsung.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-samsung.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-sony.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-sony.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-sunplus.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-sunplus.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-tmff.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-tmff.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-zpff.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/hid/hid-zpff.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/fs/jfs/jfs.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/fs/jfs/jfs.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/fs/reiserfs/reiserfs.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/fs/reiserfs/reiserfs.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/firewire/firewire-ohci.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/firewire/firewire-ohci.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/firewire/firewire-sbp2.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/firewire/firewire-sbp2.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/firewire/firewire-ohci.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/firewire/firewire-ohci.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/drivers/firewire/firewire-sbp2.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-124-generic/kernel/drivers/firewire/firewire-sbp2.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-124-generic/kernel/fs/nls/nls_utf8.ko’: No such file or directory
E: /usr/share/initramfs-tools/hooks/casper failed with return 1.
update-initramfs: failed for /boot/initrd.img-4.4.0-124-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-extra-4.4.0-124-generic (--remove):
subprocess installed post-removal script returned error exit status 1
Removing linux-image-extra-4.4.0-127-generic (4.4.0-127.153~14.04.1) ...
depmod: FATAL: could not load /boot/System.map-4.4.0-127-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-127-generic /boot/vmlinuz-4.4.0-127-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.4.0-127-generic /boot/vmlinuz-4.4.0-127-generic
Error! echo
Your kernel headers for kernel 4.4.0-127-generic cannot be found at
/lib/modules/4.4.0-127-generic/build or /lib/modules/4.4.0-127-generic/source.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-127-generic /boot/vmlinuz-4.4.0-127-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-127-generic
grep: /boot/config-4.4.0-127-generic: No such file or directory
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-apple.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-apple.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-cherry.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-cherry.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-logitech.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-logitech.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-logitech-dj.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-logitech-dj.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-microsoft.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-microsoft.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-a4tech.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-a4tech.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-belkin.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-belkin.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-chicony.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-chicony.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-cypress.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-cypress.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-ezkey.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-ezkey.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-gyration.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-gyration.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-monterey.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-monterey.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-petalynx.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-petalynx.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-pl.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-pl.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-samsung.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-samsung.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-sony.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-sony.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-sunplus.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-sunplus.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-tmff.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-tmff.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-zpff.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/hid/hid-zpff.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/fs/jfs/jfs.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/fs/jfs/jfs.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/fs/reiserfs/reiserfs.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/fs/reiserfs/reiserfs.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/firewire/firewire-ohci.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/firewire/firewire-ohci.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/firewire/firewire-sbp2.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/firewire/firewire-sbp2.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/firewire/firewire-ohci.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/firewire/firewire-ohci.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/drivers/firewire/firewire-sbp2.ko’: No such file or directory
libkmod: ERROR ../libkmod/libkmod.c:556 kmod_search_moddep: could not open moddep file '/lib/modules/4.4.0-111-generic/modules.dep.bin'
modinfo: ERROR: Module alias /lib/modules/4.4.0-127-generic/kernel/drivers/firewire/firewire-sbp2.ko not found.
cp: cannot stat ‘/lib/modules/4.4.0-127-generic/kernel/fs/nls/nls_utf8.ko’: No such file or directory
E: /usr/share/initramfs-tools/hooks/casper failed with return 1.
update-initramfs: failed for /boot/initrd.img-4.4.0-127-generic with 1.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
dpkg: error processing package linux-image-extra-4.4.0-127-generic (--remove):
subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
linux-image-extra-4.4.0-124-generic
linux-image-extra-4.4.0-127-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

gm10
Level 13
Level 13
Posts: 4553
Joined: Thu Jun 21, 2018 5:11 pm

Re: Help! Can't update software with update manager

Post by gm10 » Wed Sep 19, 2018 11:48 am

Haha, is your stamina still holding? This is certainly the most annoying case of this I've run into so far. By rights this should have started working again already but there's probably something Mint 17-specific that I'm missing. So let's just stick to what we know works. We're nearly there, anyway. Do:

Code: Select all

sudo rm -fv /var/lib/dpkg/info/linux-image-extra-4.4.0-124-generic.* /var/lib/dpkg/info/linux-image-extra-4.4.0-127-generic.*
then

Code: Select all

sudo dpkg --purge --force-all linux-image-extra-4.4.0-124-generic linux-image-extra-4.4.0-127-generic
and:

Code: Select all

sudo apt-get autoremove -y
finally:

Code: Select all

dpkg-query -W -f '${Package}\n' | grep "^linux-"
Give me the output of only the last two. ;)

aletave
Level 1
Level 1
Posts: 37
Joined: Thu Sep 13, 2018 12:12 pm

Re: Help! Can't update software with update manager

Post by aletave » Wed Sep 19, 2018 11:56 am

Thank you so much for helping :D

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED
linux-headers-4.4.0-112 linux-headers-4.4.0-112-generic
linux-headers-4.4.0-116 linux-headers-4.4.0-116-generic
linux-headers-4.4.0-119 linux-headers-4.4.0-119-generic
linux-headers-4.4.0-121 linux-headers-4.4.0-121-generic
0 to upgrade, 0 to newly install, 8 to remove and 181 not to upgrade.
After this operation, 350 MB disk space will be freed.
(Reading database ... 395752 files and directories currently installed.)
Removing linux-headers-4.4.0-112-generic (4.4.0-112.135~14.04.1) ...
dpkg: warning: while removing linux-headers-4.4.0-112-generic, directory '/lib/modules/4.4.0-112-generic' not empty so not removed
Removing linux-headers-4.4.0-112 (4.4.0-112.135~14.04.1) ...
Removing linux-headers-4.4.0-116-generic (4.4.0-116.140~14.04.1) ...
dpkg: warning: while removing linux-headers-4.4.0-116-generic, directory '/lib/modules/4.4.0-116-generic' not empty so not removed
Removing linux-headers-4.4.0-116 (4.4.0-116.140~14.04.1) ...
Removing linux-headers-4.4.0-119-generic (4.4.0-119.143~14.04.1) ...
dpkg: warning: while removing linux-headers-4.4.0-119-generic, directory '/lib/modules/4.4.0-119-generic' not empty so not removed
Removing linux-headers-4.4.0-119 (4.4.0-119.143~14.04.1) ...
Removing linux-headers-4.4.0-121-generic (4.4.0-121.145~14.04.1) ...
dpkg: warning: while removing linux-headers-4.4.0-121-generic, directory '/lib/modules/4.4.0-121-generic' not empty so not removed
Removing linux-headers-4.4.0-121 (4.4.0-121.145~14.04.1) ...

and

linux-firmware
linux-headers-3.16.0-38
linux-headers-3.16.0-38-generic
linux-headers-3.19.0-32
linux-headers-3.19.0-32-generic
linux-headers-4.4.0-109
linux-headers-4.4.0-109-generic
linux-headers-4.4.0-111
linux-headers-4.4.0-111-generic
linux-headers-4.4.0-124
linux-headers-4.4.0-124-generic
linux-image-3.16.0-38-generic
linux-image-3.19.0-32-generic
linux-image-4.4.0-109-generic
linux-image-4.4.0-111-generic
linux-image-extra-3.16.0-38-generic
linux-image-extra-3.19.0-32-generic
linux-image-extra-4.4.0-109-generic
linux-image-extra-4.4.0-111-generic
linux-libc-dev
linux-sound-base

gm10
Level 13
Level 13
Posts: 4553
Joined: Thu Jun 21, 2018 5:11 pm

Re: Help! Can't update software with update manager

Post by gm10 » Wed Sep 19, 2018 12:07 pm

Excellent. So I *think* we can now go back to normal ways of removing these? Please say yes. :lol: Let's try with one of them for now:

Code: Select all

sudo apt-get purge -y linux-image-4.4.0-109-generic
If that works, and only then, do the rest of the list:

Code: Select all

sudo apt-get purge -y linux-headers-3.16.0-38 linux-headers-3.16.0-38-generic linux-headers-3.19.0-32 linux-headers-3.19.0-32-generic linux-headers-4.4.0-109 linux-headers-4.4.0-109-generic linux-headers-4.4.0-111 linux-headers-4.4.0-111-generic linux-headers-4.4.0-124 linux-headers-4.4.0-124-generic linux-image-3.16.0-38-generic linux-image-3.19.0-32-generic linux-image-4.4.0-109-generic linux-image-extra-3.16.0-38-generic linux-image-extra-3.19.0-32-generic linux-image-extra-4.4.0-109-generic
If that also works, do this one again:

Code: Select all

cd /lib/modules
LISTFILE=/tmp/clean_module_dirs.txt
dpkg-query -W -f '${Version}\n' 'linux-image-[^g]*'|sort|uniq -u|sed -e 's/\~[^~]*$//' -e 's/\.[^.]*$/-generic/'> $LISTFILE
comm -2 -3 <(ls) <(sort $LISTFILE) | xargs -r sudo rm -rv
rm -v $LISTFILE
and then I actually think we're done with the clean-up.

After that it's time to install the latest kernel:

Code: Select all

sudo apt-get update
sudo install linux-generic-lts-xenial linux-image-generic-lts-xenial linux-headers-generic-lts-xenial

aletave
Level 1
Level 1
Posts: 37
Joined: Thu Sep 13, 2018 12:12 pm

Re: Help! Can't update software with update manager

Post by aletave » Wed Sep 19, 2018 12:19 pm

did the first bit work?

Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED
linux-image-4.4.0-109-generic* linux-image-extra-4.4.0-109-generic*
0 to upgrade, 0 to newly install, 2 to remove and 181 not to upgrade.
After this operation, 215 MB disk space will be freed.
(Reading database ... 288664 files and directories currently installed.)
Removing linux-image-extra-4.4.0-109-generic (4.4.0-109.132~14.04.1) ...
depmod: FATAL: could not load /boot/System.map-4.4.0-109-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 4.4.0-109-generic /boot/vmlinuz-4.4.0-109-generic
run-parts: executing /etc/kernel/postinst.d/dkms 4.4.0-109-generic /boot/vmlinuz-4.4.0-109-generic
Error! echo
Your kernel headers for kernel 4.4.0-109-generic cannot be found at
/lib/modules/4.4.0-109-generic/build or /lib/modules/4.4.0-109-generic/source.
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 4.4.0-109-generic /boot/vmlinuz-4.4.0-109-generic
update-initramfs: Generating /boot/initrd.img-4.4.0-109-generic
grep: /boot/config-4.4.0-109-generic: No such file or directory
WARNING: missing /lib/modules/4.4.0-109-generic
Device driver support needs thus be built-in linux image!
depmod: ERROR: could not open directory /lib/modules/4.4.0-109-generic: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
/usr/sbin/iucode_tool: cpuid kernel driver unavailable, cannot scan system processor signatures
depmod: WARNING: could not open /tmp/mkinitramfs_lum0s7/lib/modules/4.4.0-109-generic/modules.order: No such file or directory
depmod: WARNING: could not open /tmp/mkinitramfs_lum0s7/lib/modules/4.4.0-109-generic/modules.builtin: No such file or directory
run-parts: executing /etc/kernel/postinst.d/pm-utils 4.4.0-109-generic /boot/vmlinuz-4.4.0-109-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 4.4.0-109-generic /boot/vmlinuz-4.4.0-109-generic
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-4.4.0-111-generic
Found initrd image: /boot/initrd.img-4.4.0-111-generic
Adding boot menu entry for EFI firmware configuration
done
Purging configuration files for linux-image-extra-4.4.0-109-generic (4.4.0-109.132~14.04.1) ...
Removing linux-image-4.4.0-109-generic (4.4.0-109.132~14.04.1) ...
Examining /etc/kernel/prerm.d.
run-parts: executing /etc/kernel/prerm.d/dkms 4.4.0-109-generic /boot/vmlinuz-4.4.0-109-generic
dkms: removing: virtualbox-guest 4.3.36 (4.4.0-109-generic) (x86_64)

-------- Uninstall Beginning --------
Module: virtualbox-guest
Version: 4.3.36
Kernel: 4.4.0-109-generic (x86_64)
-------------------------------------

Status: Before uninstall, this module version was ACTIVE on this kernel.

vboxguest.ko:
- Uninstallation
- Deleting from: /lib/modules/4.4.0-109-generic/
/usr/sbin/dkms: line 1620: cd: /lib/modules/4.4.0-109-generic: No such file or directory
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


vboxsf.ko:
- Uninstallation
- Deleting from: /lib/modules/4.4.0-109-generic/
/usr/sbin/dkms: line 1620: cd: /lib/modules/4.4.0-109-generic: No such file or directory
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.


vboxvideo.ko:
- Uninstallation
- Deleting from: /lib/modules/4.4.0-109-generic/
/usr/sbin/dkms: line 1620: cd: /lib/modules/4.4.0-109-generic: No such file or directory
- Original module
- No original module was found for this module on this kernel.
- Use the dkms install command to reinstall any previous module version.

depmod....(bad exit status: 1)

DKMS: uninstall completed.
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-109-generic /boot/vmlinuz-4.4.0-109-generic
update-initramfs: Deleting /boot/initrd.img-4.4.0-109-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-109-generic /boot/vmlinuz-4.4.0-109-generic
Generating grub configuration file ...
Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
Found linux image: /boot/vmlinuz-4.4.0-111-generic
Found initrd image: /boot/initrd.img-4.4.0-111-generic
Adding boot menu entry for EFI firmware configuration
done
Purging configuration files for linux-image-4.4.0-109-generic (4.4.0-109.132~14.04.1) ...
Examining /etc/kernel/postrm.d .
run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-109-generic /boot/vmlinuz-4.4.0-109-generic
run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-109-generic /boot/vmlinuz-4.4.0-109-generic

gm10
Level 13
Level 13
Posts: 4553
Joined: Thu Jun 21, 2018 5:11 pm

Re: Help! Can't update software with update manager

Post by gm10 » Wed Sep 19, 2018 12:23 pm

aletave wrote:
Wed Sep 19, 2018 12:19 pm
did the first bit work?
Don't make it sound like I have any idea what I'm doing here. :lol:

I think it worked, but the lazy way to confirm is to just run the command again, it should fail saying that the package is not installed. In that case then run all the rest above.

Post Reply

Return to “Newbie Questions”