Power management is worse after instaling linux

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
angelodealwis
Level 1
Level 1
Posts: 10
Joined: Tue Aug 14, 2018 7:38 pm

Power management is worse after instaling linux

Post by angelodealwis » Wed Sep 19, 2018 7:39 am

Hi
I have UX21E (asus) on which i have installed linux mint 19 xfce
When it was running MS Windows I could send the computer into hibernation and the battery would last for a few days at least.
Since installing the linux mint I have noted that the power management if very poor. What can i do do enable hibernation in the computer under linux
Thank you

Hoser Rob
Level 12
Level 12
Posts: 4203
Joined: Sat Dec 15, 2012 8:57 am

Re: Power management is worse after instaling linux

Post by Hoser Rob » Wed Sep 19, 2018 9:26 am

It's not 100% unusual for power management to be worse in Linux but hard to say without meaningful system details. PLease copy/paste this to the terminal and copy/paste the text output here (no screenshots please):

Code: Select all

inxi -Fxz

angelodealwis
Level 1
Level 1
Posts: 10
Joined: Tue Aug 14, 2018 7:38 pm

Re: Power management is worse after instaling linux

Post by angelodealwis » Wed Sep 19, 2018 9:31 am

HI
this is the output

System: Host: angelo-UX21E Kernel: 4.15.0-34-generic x86_64
bits: 64 gcc: 7.3.0
Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Linux Mint 19 Tara
Machine: Device: laptop System: ASUSTeK product: UX21E v: 1.0 serial: N/A
Mobo: ASUSTeK model: UX21E v: 1.0 serial: N/A
BIOS: American Megatrends v: UX21E.207 date: 10/25/2011
Battery BAT0: charge: 16.2 Wh 54.7% condition: 29.6/33.6 Wh (88%)
model: ASUSTek UX21-48 status: Charging
CPU: Dual core Intel Core i3-2367M (-MT-MCP-)
arch: Sandy Bridge rev.7 cache: 3072 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 5587
clock speeds: max: 1400 MHz 1: 876 MHz 2: 842 MHz 3: 808 MHz
4: 798 MHz
Graphics: Card: Intel 2nd Generation Core Integrated Graphics Controller
bus-ID: 00:02.0
Display Server: x11 (X.Org 1.19.6 )
drivers: modesetting (unloaded: fbdev,vesa)
Resolution: 1366x768@60.00hz
OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile
version: 3.3 Mesa 18.0.5 Direct Render: Yes
Audio: Card Intel 6 Series/C200 Series Family High Def. Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Sound: Advanced Linux Sound Architecture v: k4.15.0-34-generic
Network: Card: Qualcomm Atheros AR9485 Wireless Network Adapter
driver: ath9k bus-ID: 02:00.0
IF: wlp2s0 state: up mac: <filter>
Drives: HDD Total Size: 64.0GB (41.5% used)
ID-1: /dev/sda model: SanDisk_SSD_U100 size: 64.0GB
Partition: ID-1: / size: 59G used: 25G (45%) fs: ext4 dev: /dev/sda1
RAID: No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors: System Temperatures: cpu: 63.0C mobo: N/A
Fan Speeds (in rpm): cpu: 0
Info: Processes: 186 Uptime: 35 min Memory: 1630.4/3845.5MB
Init: systemd runlevel: 5 Gcc sys: 7.3.0
Client: Shell (bash 4.4.191) inxi: 2.3.56

Thank you

ud6
Level 2
Level 2
Posts: 95
Joined: Wed May 09, 2018 3:41 am
Location: Malawi

Re: Power management is worse after instaling linux

Post by ud6 » Wed Sep 19, 2018 5:14 pm

This is a link on setting up hibernation: viewtopic.php?t=273202

I'm afraid quite complex... hibernation was deactivated a while ago because of problems relating to restarting system, but can be activated again. However, obviously hibernation doesn't allow you reduce power useage whilst using the computer. You should consider maybe using suspend instead (after period of time), and when not using your computer, simply shutting it down.

Unfortunately windows tends to have better power management than linux. I work in Africa (lots of powercuts) and do 3 things to help with power saving:

1. Install 'TLP' (it is in software manager) this automatically assists reduction in battery useage
2. Reduce brightness of monitor amd adjust power settings (right click on battery icon). This allows you to adjust suspend settings too.
3. Install 'indicator-cpufreq'. Also found in software manager. This allows you to swap between 'performance' and 'powersave' with a small applet that automatically gets added to panel next time you boot in.

To install TLP and indicator-cpufreq at command line instead, you can:

Code: Select all

sudo apt install tlp

Code: Select all

sudo apt install indicator-cpufreq

angelodealwis
Level 1
Level 1
Posts: 10
Joined: Tue Aug 14, 2018 7:38 pm

Re: Power management is worse after instaling linux

Post by angelodealwis » Fri Sep 21, 2018 10:12 am

Thank you for the suggestions.
Is there a front end for TLP?

User avatar
N3wb
Level 2
Level 2
Posts: 65
Joined: Mon Sep 17, 2018 11:33 am

Re: Power management is worse after instaling linux

Post by N3wb » Sat Sep 22, 2018 8:47 am

Just wanted to say thanks for suggesting tlp, I noticed similar battery drain issue on my HP laptop coming from Windows.
I think you just need to use

Code: Select all

sudo tlp start
and it should automatically run for subsequent sessions (correct me if I'm wrong).
Linux Mint 19 Cinnamon
Kernel: 4.15.0-36-generic

Post Reply

Return to “Newbie Questions”