cant see preview of video in icon in list mode - Solved

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
offir
Level 1
Level 1
Posts: 49
Joined: Wed Sep 21, 2016 7:37 am

Re: cant see preview of video in icon in list mode

Post by offir » Sat Sep 22, 2018 8:16 am

This is a bug in Linux or
A malfunction only on my computer ?

gm10
Level 13
Level 13
Posts: 4580
Joined: Thu Jun 21, 2018 5:11 pm

Re: cant see preview of video in icon in list mode

Post by gm10 » Sat Sep 22, 2018 8:50 am

offir wrote:
Sat Sep 22, 2018 8:16 am
This is a bug in Linux or
A malfunction only on my computer ?
Actually I have to apologize, I had not read your OP nor the rest of the thread at all until now, I had only latched onto the issue the smurphos pinged me into the thread for. But what you actually said was:
offir wrote:
Thu Sep 20, 2018 3:09 am
When I view files in icon mode
See a picture of the video content

When I switch to list mode
You can not see a picture
In other words, you do not have any problems with thumbnail generation at all, and you are on MATE, not Cinnamon. In other words, I don't know why anything of the before was even discussed. The correct answer to your problem is the following:

MATE's default file browser caja does never display thumbnails in list view for all I know. It does show them in compact view for zoom levels above 100%, and always in icon view.

If you need thumbails in list view you can use Cinnamon's file browser instead:

Code: Select all

apt install nemo
Make it your preferred file browser in Mint menu > Preferred applications.

Sorry again for jumping on the off-topic train earlier.

offir
Level 1
Level 1
Posts: 49
Joined: Wed Sep 21, 2016 7:37 am

Re: cant see preview of video in icon in list mode

Post by offir » Sat Sep 22, 2018 9:02 am

i install the file manager
What do I have to choose??
I do not see nemo

i try all of them
no change
Attachments
Screenshot at 2018-09-22 16-00-06.png
Screenshot at 2018-09-22 16-00-06.png (23.88 KiB) Viewed 99 times

offir
Level 1
Level 1
Posts: 49
Joined: Wed Sep 21, 2016 7:37 am

Re: cant see preview of video in icon in list mode

Post by offir » Sat Sep 22, 2018 9:13 am

i type nemo i the search bar and "files" open
and it work
I chose "files" (The Green)
In Preferred File Manager

And it does not work
The regular manager works

gm10
Level 13
Level 13
Posts: 4580
Joined: Thu Jun 21, 2018 5:11 pm

Re: cant see preview of video in icon in list mode

Post by gm10 » Sat Sep 22, 2018 9:15 am

Oh wow, you've got more file browsers installed than expected. Do you have multiple desktop environments installed? You can give all those "Files" entries proper names by finding them in the Mint menu and right clicking them to edit their properties and giving a more useful name.

But to test the thumbnail thing you can just launch nemo from a terminal - I'm not quite sure from your post one up whether "works" refers to the thumbail issue.

offir
Level 1
Level 1
Posts: 49
Joined: Wed Sep 21, 2016 7:37 am

Re: cant see preview of video in icon in list mode

Post by offir » Sat Sep 22, 2018 9:19 am

Oh wow, you've got more file browsers installed than expected. Do you have multiple desktop environments installed?
no
Except for the software chirp

This is a standard installation from the installation disk
I did not add anything
But to test the thumbnail thing you can just launch nemo from a terminal.
It works
But I want to access the files via the usual icons on the desktop or on the panel at the bottom of the screen



I'm not quite sure from your post one up whether "works" refers to the thumbnails issue.
it work mean no thumbnails issue all is good

gm10
Level 13
Level 13
Posts: 4580
Joined: Thu Jun 21, 2018 5:11 pm

Re: cant see preview of video in icon in list mode

Post by gm10 » Sat Sep 22, 2018 10:36 am

offir wrote:
Sat Sep 22, 2018 9:19 am
It works
But I want to access the files via the usual icons on the desktop or on the panel at the bottom of the screen
Oh good, so the the only problem is the default associations. The icon on the panel you'll have to edit yourself, right click and change the command to nemo %U.

For the rest, after testing it, I'm surprised I have to say it does not seem easily possible. The entire MATE desktop seems hardcoded to use caja, the configured file browser association is completely ignored unfortunately. One quick trick I tried was to redirect all calls to caja to nemo:

Code: Select all

sudo ln -s /usr/bin/nemo /usr/local/bin/caja
You'd need to load /usr/bin/caja manually as a startup application then to make your desktop work. Problem with this approach was a new nemo window would pop up every couple of seconds, apparently the caja desktop calls itself all the time but with a parameter that nemo does not understand. You'd probably have to use nemo for the desktop view as well. Unfortunately I don't have the time to look into that right now, maybe somebody else feels like tinkering.

It may be easier to just create launchers referencing nemo directly to place on your desktop instead.

PS: sudo rm /usr/local/bin/caja to undo the above command should you have tried it.

offir
Level 1
Level 1
Posts: 49
Joined: Wed Sep 21, 2016 7:37 am

Re: cant see preview of video in icon in list mode

Post by offir » Sat Sep 22, 2018 10:58 am

It may be easier to just create launchers referencing nemo directly to place on your desktop instead
That's what I did now it works
Only through this icon but at least it works


Thanks

User avatar
thx-1138
Level 6
Level 6
Posts: 1273
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: cant see preview of video in icon in list mode

Post by thx-1138 » Sat Oct 13, 2018 8:43 am

smurphos wrote:
Sat Sep 22, 2018 4:54 am
...........................
...looks like it's been fixed...

Post Reply

Return to “Newbie Questions”