Installing Mono Develop

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
NewtSoup
Level 1
Level 1
Posts: 41
Joined: Sat Sep 22, 2018 11:52 pm
Location: United Kingdom

Installing Mono Develop

Post by NewtSoup » Sun Sep 23, 2018 12:09 am

Hi,

I'd like to install Mono Develop but their website has instructions for Ubuntu 18.04 and 16.04
I know Mint 19 ( what I just installed because Ubuntu 18.04 was giving me hassle ) is binary compatible with Ubuntu so which instructions do I need to use?

The ones for 18.04 or the ones for 16.04?

https://www.mono-project.com/download/s ... wnload-lin

User avatar
catweazel
Level 19
Level 19
Posts: 9252
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: Installing Mono Develop

Post by catweazel » Sun Sep 23, 2018 1:54 am

NewtSoup wrote:
Sun Sep 23, 2018 12:09 am
Hi,

I'd like to install Mono Develop but their website has instructions for Ubuntu 18.04 and 16.04
I know Mint 19 ( what I just installed because Ubuntu 18.04 was giving me hassle ) is binary compatible with Ubuntu so which instructions do I need to use?

The ones for 18.04 or the ones for 16.04?
If you have Mint 18.x then use the instructions for Ubuntu 16.04. If you have Mint 19 then use the instructions for Ubuntu 18.04. Alternatively, see if any of the PPAs here support those two versions.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

User avatar
NewtSoup
Level 1
Level 1
Posts: 41
Joined: Sat Sep 22, 2018 11:52 pm
Location: United Kingdom

Re: Installing Mono Develop

Post by NewtSoup » Sun Sep 23, 2018 8:55 am

Thank you, Catweazel, that was exactly what I needed to know. I am using Mint 19 and will do stuff the Ubuntu 18.04 way.

User avatar
emmissaire
Level 1
Level 1
Posts: 1
Joined: Mon Apr 08, 2019 4:58 pm

Re: Installing Mono Develop

Post by emmissaire » Mon Apr 08, 2019 5:06 pm

I also am trying to install Monodevelop with the intention of using it as the C# editor for Unity.

Not sure where I've gone wrong, but when I get to "sudo apt-get install monodevelop" the terminal comes up with a huge list of "Unmet dependencies" and concludes with the helpful message "Unable to correct problems, you have held broken packages."

Having spent a while Googling this, I'm no closer to understanding what went wrong from a terminal installation perspective.

I did stumble on some instructions to install it from "Flatpak" (not idea what that was) which do seem to have installed it, but the way it's installed, Unity doesn't recognise it exists.

I'll take any suggestions I can get on the best way forward!

ufotech
Level 1
Level 1
Posts: 8
Joined: Mon Aug 12, 2019 6:17 pm

Re: Installing Mono Develop

Post by ufotech » Thu Aug 15, 2019 3:35 pm

Install 19,2 which is the current LTS version and follow my instructions exactly as indicated on this link.
viewtopic.php?f=47&t=299692

jglen490
Level 5
Level 5
Posts: 625
Joined: Sat Jul 15, 2017 9:57 pm

Re: Installing Mono Develop

Post by jglen490 » Thu Aug 15, 2019 4:08 pm

And that may work. But, just for added background there is a mono repository problem as noted at the Kubuntu forums that will take user effort to resolve..
I feel more like I do than I did when I got here.
Toshiba A135-S2386, Intel T2080, ATI Radeon® Xpress 200M Chipset, 2GB RAM, 500GB

ufotech
Level 1
Level 1
Posts: 8
Joined: Mon Aug 12, 2019 6:17 pm

Re: Installing Mono Develop

Post by ufotech » Sun Aug 18, 2019 6:18 am

jglen490 wrote:
Thu Aug 15, 2019 4:08 pm
And that may work. But, just for added background there is a mono repository problem as noted at the Kubuntu forums that will take user effort to resolve..
Yes there is a problem IF you followed on the instructions for Ubuntu 18.04 to install mono and monodevelop.

The install for Linux Mint 19.2 is slightly different from other versions.

FOLLOW the how to exactly as indicated on the howto page I wrote.
viewtopic.php?f=47&t=299939

Post Reply

Return to “Newbie Questions”