i think maybe linux mint broke

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
db86694
Level 1
Level 1
Posts: 1
Joined: Sun Sep 23, 2018 6:36 pm

i think maybe linux mint broke

Post by db86694 » Sun Sep 23, 2018 7:22 pm

im brand new to linux but not pcs. i just cleared windows 7 from old laptop and installed brand new linux mint 19 figured id try somthing new to me.

install and day one awesome i was realy liking how responsive and fast it made my old pc! only day 1 problem was ethernet would not connect. Not to big a deal wifi worked and i figured i just go online and grab some drivers and install them.

So day 2 roles around i search online and find the intel drives i need all good so far, i download drivers and linux put the drives in default downloads file, i confirm this by looking in said file yep there it is e1000e***. again everything whent perfect.

Now here is were the trouble begins i pop open cmd and enter apt-get install i read that is one of half dozen or so package managers to us. So apt-get install e1000e***.
And to my suprise becouse everything has worked so well, linux returns with an unable to locate package. If you see a mistake i made in the above procedure please stop now and tell me were.

if your still with me, i then reconfirmed that e1000e*** was indeed in the downlioads file right were LINUX put it. so i tried again several times to no avail.

i then decided to move e1000e*** to new folder and try .NOPE! So thought id try a different package manager say gdebi and you probably know were we are heade4d with this yeah that didnt work either. Nore did dpkg -i, pip install, and last but not least aptitude which i think is same as apt-get but at this point what the heck i would have typed command standing on head if it would work.

every manager said unable to locate or unkown package type.So my quistion is how the heck can a computer put a package in a file and 45 seconds later not be able to find that package!! i have spent couple hours searching online for solution and trying various thing (just short of attaching neon im here sighn) to correc t this still no luck.

Please tell me how somthing as smart as a pc can forget were they put somthing in under a minute i know a few long time potheads that have better memory than that! my 4 year old grandson remembers were it put stuff dayd if not weaks later!!

all jokes aside am realy stumped and i dont want to have such negative thoughts about an O.S. i was starting to like so any advice to fix this blindness my install of linux i would be forever grateful, and god knows its greatly needed

User avatar
catweazel
Level 17
Level 17
Posts: 7767
Joined: Fri Oct 12, 2012 9:44 pm
Location: Australian Antarctic Territory

Re: i think maybe linux mint broke

Post by catweazel » Mon Sep 24, 2018 1:48 am

db86694 wrote:
Sun Sep 23, 2018 7:22 pm
every manager said unable to locate or unkown package type.
That's because there is no package in the repositories with a name anything like e1000e, and especially not e1000e***.

The asterisks are being expanded as wildcards, which is why you can't locate the file using the command line. The better approach to your problem is to describe the problem you're having that caused you to download something called e1000e*** from who knows where in the first place.
¡uʍop ǝpısdn sı buıɥʇʎɹǝʌǝ os ɐıןɐɹʇsnɐ ɯoɹɟ ɯ,ı

User avatar
smurphos
Level 8
Level 8
Posts: 2204
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: i think maybe linux mint broke

Post by smurphos » Mon Sep 24, 2018 2:54 am

Hi to expand on catweazals response I think you are misunderstanding basics of the package management system.

Mint comes with a set of online software repositories, provided by the Mint team and Ubuntu. This populates the software available in Software Manager, Synaptic or installable via apt. It can't locate your package but it's looking online for it

You can download .Deb packages independently and these can be installed via the GUI app gdebi or command line dpkg.

There are other ways to install software but we'll leave that for the time being and much of the time the procedure will be specific to that particular software.

Going on to your ethernet issue, the Linux kernel provides drivers for the vast majority of cards, with the exception of the very new, the very obscure or the very old. It's unusual but not impossible that you would need to manually install drivers for your ethernet card.

Please post back the output of inxi -Fxz run in a terminal and also a link to the site you downloaded your driver download from to provide a starting point for folks to help troubleshoot your issue.

Post Reply

Return to “Newbie Questions”