[SOLVED] Mint 19 Xfce typing delay

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
FerociousLinux
Level 1
Level 1
Posts: 2
Joined: Mon Sep 24, 2018 11:12 am

[SOLVED] Mint 19 Xfce typing delay

Post by FerociousLinux » Mon Sep 24, 2018 11:43 am

When I start "Xfce Terminal" there is a few seconds delay after typing a character from appearing. Seems like anything related with typing has this delay (eg: Firefox, text editor, etc) but "Xfce Terminal" is the worst..

This was fresh install of Mint 19 Xfce. For testing purposes I wipe everything and installed Mint 19 Cinnamon and do not have this issue. Wiped again and installed Mint 19 Xfce, issue is back... I have also done all the updates but issue persists. Any help with be greatly appreciated.

Thanks in advance... :)

Code: Select all

user@Stream14:~$ inxi -Fxz
System:    Host: Stream14-Linux Kernel: 4.15.0-20-generic x86_64 bits: 64 gcc: 7.3.0
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: HP product: HP Stream Laptop 14-ax0XX v: Type1ProductConfigId serial: N/A
           Mobo: HP model: 82BD v: 11.20 serial: N/A UEFI: Insyde v: F.46 date: 01/18/2018
Battery    BAT0: charge: 41.6 Wh 100.0% condition: 41.6/41.6 Wh (100%)
           model: Hewlett-Packard Primary status: Charging
           hidpp__0: charge: N/A condition: NA/NA Wh
           model: Logitech Wireless Mouse M215 2nd Gen status: Discharging
CPU:       Dual core Intel Celeron N3060 (-MCP-) arch: Airmont rev.4 cache: 1024 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 6400
           clock speeds: max: 2480 MHz 1: 1158 MHz 2: 553 MHz
Graphics:  Card: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting (unloaded: fbdev,vesa)
           Resolution: 1366x768@60.01hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 400 (Braswell)
           version: 4.5 Mesa 18.0.5 Direct Render: Yes
Audio:     Card Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card: Intel Wireless 7265 driver: iwlwifi bus-ID: 02:00.0
           IF: wlo1 state: down mac: <filter>
Drives:    HDD Total Size: NA (-)
           ID-1: /dev/mmcblk0 model: N/A size: 31.3GB
Partition: ID-1: / size: 24G used: 6.2G (28%) fs: ext4 dev: /dev/dm-1
           ID-2: /boot size: 705M used: 152M (24%) fs: ext4 dev: /dev/mmcblk0p2
           ID-3: swap-1 size: 4.20GB used: 0.00GB (0%) fs: swap dev: /dev/dm-3
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 42.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 200 Uptime: 3:59 Memory: 1007.1/3850.9MB Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56
Last edited by FerociousLinux on Tue Sep 25, 2018 12:01 pm, edited 1 time in total.

User avatar
Pjotr
Level 21
Level 21
Posts: 13473
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: Mint 19 Xfce typing delay

Post by Pjotr » Mon Sep 24, 2018 11:47 am

Strange.... Try this:

1. Disable all visual effects in Xfce:
https://sites.google.com/site/easylinux ... ts-in-Xfce
(item 5.3, right column)

2. Update your kernel to the latest one of the 4.15 series (-34). Then reboot.
Tip: 10 things to do after installing Linux Mint 19.2 Tina
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

User avatar
trytip
Level 11
Level 11
Posts: 3687
Joined: Tue Jul 05, 2016 1:20 pm

Re: Mint 19 Xfce typing delay

Post by trytip » Mon Sep 24, 2018 11:54 am

could be the initial startup notify try this which removed the notification of apps starting:

Code: Select all

sudo sed -i 's/StartupNotify=true/StartupNotify=false/g' /usr/share/applications/*.desktop

Code: Select all

sudo sed -i 's/Notify=true/Notify=false/g' /etc/xdg/autostart/*.desktop
and once more for the home directory but this is not run as sudo

Code: Select all

sed -i 's/StartupNotify=true/StartupNotify=false/g' $HOME/.local/share/applications/*.desktop
do you also have this folder? /usr/share/applications/kde4/
Image

FerociousLinux
Level 1
Level 1
Posts: 2
Joined: Mon Sep 24, 2018 11:12 am

Re: Mint 19 Xfce typing delay

Post by FerociousLinux » Mon Sep 24, 2018 2:26 pm

Pjotr & trytip, thanks for the help. Tried the kernel update using Ukuu and switched to 4.15.0-34.37 then rebooted, no improvement. Used the above link to disable "Turn off visual effects in Xfce". Didn't find that exact option but found "Windows Manager Tweeks" and unchecked the "Enable display compositing, WORKED! =)

Windows Manager Tweeks
Windows Manager Tweeks

bcc4foss
Level 1
Level 1
Posts: 2
Joined: Sat Mar 12, 2011 11:41 pm

Re: [SOLVED] Mint 19 Xfce typing delay

Post by bcc4foss » Fri Feb 01, 2019 6:39 pm

Thank you FerociousLinux, I have been having Keyboard and mouse delays, missed clicks, etc ever since I installed mint 19 XFCE of a brand new Acer Aspire AMD A10 with intergrated Radeon R7 graphics. I have been putting up with it and was thinking of trying a different distro but stumbled upon this post and thought I'd give your solution a try. Disabling display compositing has fixed the problem for me as well.

rjmoses
Level 1
Level 1
Posts: 6
Joined: Thu Feb 21, 2019 12:50 pm

Re: [SOLVED] Mint 19 Xfce typing delay

Post by rjmoses » Thu Feb 21, 2019 1:06 pm

Interesting! I was having the same kind of problem after upgrading from 18.3 to 19.1 when logging from an remote X-Windows system (running on Windows 10 using Xming) until I "Enabled display compositing".

Before: Holding down a key would type a little over one character/second.
After: Holding a key down types about 3 cps.

Now, onto the next problems--Slow program startup time and slow boot.

User avatar
kevin987
Level 4
Level 4
Posts: 346
Joined: Fri Dec 11, 2015 12:35 pm

Re: [SOLVED] Mint 19 Xfce typing delay

Post by kevin987 » Thu Feb 21, 2019 6:40 pm

rjmoses wrote:
Thu Feb 21, 2019 1:06 pm
Now, onto the next problems--Slow program startup time and slow boot.
Hi rjmoses,

If you'd like, start a new thread concerning your slow startup/boot times.

Include your system information from the Terminal command:

Code: Select all

inxi -Fxzd
Use the code button feature (5th button from left at the top of the message box).

Welcome to the Linux Mint forums 8)
Linux Mint 19.1 (Cinnamon)
LMDE 3 (Cinnamon)
GeckoLinux 150 (Cinnamon)

rjmoses
Level 1
Level 1
Posts: 6
Joined: Thu Feb 21, 2019 12:50 pm

Re: [SOLVED] Mint 19 Xfce typing delay

Post by rjmoses » Fri Feb 22, 2019 7:02 am

Thanks. I will as soon as I have enough info to describe the situation completely and I'm reasonably sure I haven't screwed something up.

HaveaMint
Level 5
Level 5
Posts: 692
Joined: Fri Feb 02, 2018 9:56 pm
Location: Somewhere in the USA
Contact:

Re: [SOLVED] Mint 19 Xfce typing delay

Post by HaveaMint » Fri Feb 22, 2019 7:51 am

This was the main issue with 19.1 XFCE for me also on two different pc's. Unfortunately I went back to 18.3 so unable to try it on mine.
"Tune for maximum Smoke and then read the Instructions".

simon2019khh
Level 1
Level 1
Posts: 1
Joined: Sat Mar 16, 2019 7:09 am

Re: Mint 19 Xfce typing delay

Post by simon2019khh » Sat Mar 16, 2019 7:16 am

FerociousLinux wrote:
Mon Sep 24, 2018 2:26 pm
Pjotr & trytip, thanks for the help. Tried the kernel update using Ukuu and switched to 4.15.0-34.37 then rebooted, no improvement. Used the above link to disable "Turn off visual effects in Xfce". Didn't find that exact option but found "Windows Manager Tweeks" and unchecked the "Enable display compositing, WORKED! =)


Screenshot_2018-09-24_13-00-38.png
Thank you, this works for me with Acer ES1-132 too.

Post Reply

Return to “Newbie Questions”