Locked out - help!!!

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
magicchance
Level 3
Level 3
Posts: 126
Joined: Sat Jul 18, 2015 4:58 am
Location: Las Vegas, NV, USA

Locked out - help!!!

Post by magicchance »

Today for no reason I got this message as I was starting my PC just like I do every day:

As a result, I am locked out of my computer.

Edit: no matter what I do, the pic loads upside down. Sorry.

Image
Last edited by karlchen on Fri Sep 28, 2018 6:38 am, edited 3 times in total.
Reason: added correctly rotated image
User avatar
richyrich
Level 19
Level 19
Posts: 9059
Joined: Mon May 04, 2009 8:31 pm

Re: Locked out - help!!!

Post by richyrich »

magicchance
Level 3
Level 3
Posts: 126
Joined: Sat Jul 18, 2015 4:58 am
Location: Las Vegas, NV, USA

Re: Locked out - help!!!

Post by magicchance »

How do you do that exactly?

What is iommu, and why does it lock me out of my PC?
magicchance
Level 3
Level 3
Posts: 126
Joined: Sat Jul 18, 2015 4:58 am
Location: Las Vegas, NV, USA

Re: Locked out - help!!!

Post by magicchance »

I'm also getting this message as I try to reboot:

Image
Last edited by karlchen on Fri Sep 28, 2018 6:38 am, edited 2 times in total.
Reason: added correctly rotated image
User avatar
thx-1138
Level 8
Level 8
Posts: 2112
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Locked out - help!!!

Post by thx-1138 »

1) ...iommu explained... (look in your bios for either Intel VT-d/x or IOMMU, and enable such...)
2) ...it's asking you to run a manual filesystem check / repair... type sudo fsck -yvf /dev/sda1, press enter...
magicchance
Level 3
Level 3
Posts: 126
Joined: Sat Jul 18, 2015 4:58 am
Location: Las Vegas, NV, USA

Re: Locked out - help!!!

Post by magicchance »

thx-1138 wrote:
Fri Sep 28, 2018 6:27 am
1) ...iommu explained... (look in your bios for either Intel VT-d/x or IOMMU, and enable such...)
2) ...it's asking you to run a manual filesystem check / repair... type sudo fsck -yvf /dev/sda1, press enter...
1. I don't see anything like this in the bios.
2. I am locked out. I can't get to my desktop. I can't get past the screen shown in the first pic above. So I have no access to the Terminal.
AscLinux
Level 4
Level 4
Posts: 342
Joined: Sat Oct 29, 2016 3:32 pm

Re: Locked out - help!!!

Post by AscLinux »

IOMMU has nothing to do with your problems.
Your root filesytem is corrupted. Whether it is due to failing hard drive or improper shutdown is up to you to diagnose. To boot again you need to repair your root filesystem and hope nothing is permanently lost. You can do it from busybox or you can boot an external media and run the fsck from there.
User avatar
thx-1138
Level 8
Level 8
Posts: 2112
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Locked out - help!!!

Post by thx-1138 »

...magicchance - i don't know if iommu is the actual culprit or if it is a red herring as AscLinux suggests:
never stumbled upon that kfd warning before myself.

Run fsck, and pay note to whatever messages returned back in regards to which files got corrupted and/or repaired.
Why such happened, without knowing what you were doing before & without checking the logs,
it's more or less impossible for someone around to say.
AscLinux
Level 4
Level 4
Posts: 342
Joined: Sat Oct 29, 2016 3:32 pm

Re: Locked out - help!!!

Post by AscLinux »

For sake of clarity. IOMMU is required only to give exclusive access for virtual machines to a certain piece of hardware. Lacking IOMMU support will not affect the main operating system in any way.
User avatar
thx-1138
Level 8
Level 8
Posts: 2112
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Locked out - help!!!

Post by thx-1138 »

...for the sake of extra clarity, depending on kernel version bugs & the vendors' iommu implementation,
it might affect just fine the main operating system...
I assume there's a reason for a number of iommu= parameters to be passed to in case such is needed...

If only i had to mention just how many cases i've encountered where iommu=soft should be passed, else, the system crashed...
AscLinux
Level 4
Level 4
Posts: 342
Joined: Sat Oct 29, 2016 3:32 pm

Re: Locked out - help!!!

Post by AscLinux »

I build all my Gentoo kernels without IOMMU support and never had an issue. However, if the stock kernel has IOMMU enabled [just in case] then it would make sense to pass iommu=off to the kernel. Unless you really need it, that is. Enabling IOMMU only may add undesirable DMA mapping overhead to setups where it is not really used.
If only i had to mention just how many cases i've encountered where iommu=soft should be passed, else, the system crashed...
^^ This is probably the case with systems that do not support IOMMU in hardware. Again, just turn the damn thing off.
magicchance
Level 3
Level 3
Posts: 126
Joined: Sat Jul 18, 2015 4:58 am
Location: Las Vegas, NV, USA

Re: Locked out - help!!!

Post by magicchance »

thx-1138 wrote:
Fri Sep 28, 2018 12:32 pm
...magicchance - i don't know if iommu is the actual culprit or if it is a red herring as AscLinux suggests:
never stumbled upon that kfd warning before myself.

Run fsck, and pay note to whatever messages returned back in regards to which files got corrupted and/or repaired.
Why such happened, without knowing what you were doing before & without checking the logs,
it's more or less impossible for someone around to say.
Exactly how do I run fsck? I have no Terminal access, remember. Also, I'm a total noob, so I need someone understanding to walk me through this step by step.
magicchance
Level 3
Level 3
Posts: 126
Joined: Sat Jul 18, 2015 4:58 am
Location: Las Vegas, NV, USA

Re: Locked out - help!!!

Post by magicchance »

FYI to everyone here, this is what I mean by BIOS:
20180928_102116.jpg
(Apologies if its not right side up. My compression app doesn't know Up from Down.)
User avatar
thx-1138
Level 8
Level 8
Posts: 2112
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Locked out - help!!!

Post by thx-1138 »

...magicchance, don't you get an (initramfs) _ prompt above? You just run fsck from there...
Else, reboot, press Esc or Shift for Grub to show up, select Recovery mode, 'drop to root shell"...*

AscLinux - correct, but:
1) it is enabled in Canonical kernels that we use here (and not only)...
2) completely disabling it isn't that much of an option,
just how many people around use (and need it) for VMs (especially here)?

*Edit: Or just boot from a live stick / cd as AscLinux suggested...
ajgreeny
Level 5
Level 5
Posts: 606
Joined: Mon Nov 19, 2007 3:27 pm

Re: Locked out - help!!!

Post by ajgreeny »

We seem to be going round and round here with no simple answer for magicchance, so here is my attempt.

Boot to a live system, eg the DVD/USB you used to install Mint originally.
From that live system open a terminal and run

Code: Select all

sudo e2fsck /dev/sda1
which will report if there are any filesystem errors.

Depending on what is reported you may need to now run

Code: Select all

sudo efsck -y /dev/sda1
User avatar
Lord Boltar
Level 5
Level 5
Posts: 710
Joined: Mon Jan 09, 2017 7:24 pm
Location: Sunny Florida

Re: Locked out - help!!!

Post by Lord Boltar »

IOMMU = Input-output memory management unit

Your bios should have the function in it - when you startup tap the F2 (in most cases, but not all) key to access BIOS usually it will be under the Advanced tab it may say one of the following “IOMMU,” “I/O Memory Management Unit,” or “Intel ® VT-d”setting (usually located under the “Advanced” or “Chipset/Northbridge/Tylersburg IOH/Intel VT for Directed I/O Configuration”settings menu - you just have to find it and select off, once found and changed to off press the F10 Key to save and exit BIOS and see if your machine starts normally - you can always change it back to on in the BIOS
IF your problem has been solved, please edit your original post and add [SOLVED] to the beginning of the Subject Line. It helps other members

The only way for evil to prosper is for good men to do nothing
Post Reply

Return to “Newbie Questions”