Page 1 of 1

Intel a370 / AC 9560 no wifi [Solved]

Posted: Sun Oct 14, 2018 9:23 am
by weirdybeardyman
Could you fine Linux wizards of Mint land lend me a brief ear and come to my aid, I am in a dire pickle.
I am a proper noob and I installed Mint on my laptop.
I struggled with getting the Nvidia drivers working but after consulting a few forum posts that issue is all resolved (I think).
Now comes the WIFI issue, the Intel network card is not being used, there is only the option for wired connection.
Here are the relevant logs;

Code: Select all

Network:   Card-1: Intel Device a370
           IF: N/A state: N/A speed: N/A duplex: N/A mac: N/A
           Card-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller
           driver: alx
           IF: enp59s0 state: up speed: 100 Mbps duplex: full
           mac: 54:bf:64:17:4c:7c

System:    Host: The-Machine Kernel: 4.15.0-20-generic x86_64 bits: 64
           Desktop: Cinnamon 3.8.8  Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: Dell product: Vostro 7580 serial: N/A
           Mobo: Dell model: 07HXGJ v: A00 serial: N/A
           UEFI: Dell v: 1.5.0 date: 09/27/2018
Battery    BAT0: charge: 32.9 Wh 58.7% condition: 56.0/56.0 Wh (100%)
CPU:       Quad core Intel Core i5-8300H (-MT-MCP-) speed/max: 900/4000 MHz
Graphics:  Card-1: Intel Device 3e9b
           Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile]
           Display Server: x11 (X.Org 1.19.6 )
           drivers: modesetting,nvidia (unloaded: fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.02hz
           OpenGL: renderer: GeForce GTX 1050/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.77
Network:   Card-1: Intel Device a370
           Card-2: Qualcomm Atheros Killer E2400 Gigabit Ethernet Controller
           driver: alx
Drives:    HDD Total Size: 1311.8GB (3.5% used)
Info:      Processes: 233 Uptime: 5 min Memory: 1238.7/7679.0MB
           Client: Shell (bash) inxi: 2.3.56 

What I have tried thusfar-
I have disabled secure boot, found the relevant firmware file on the intel site;
https://www.intel.co.uk/content/www/uk/ ... rking.html
The first one, for the 9560, and I copy and pasted the ucode iwlwifi file into the /lib/firmware folder.
There was already a file with the same name in the folder and it had been edited more recently but I replaced it anyways.
After rebooting there is no change.
Please help, I am not sure what to try next, is it the firmware, drivers, kernel?
If I go into the drivers manager there is only the option for the GPU.
Thanks for any help, it's much appreciated.

Re: Intel a370 / AC 9560 no wifi

Posted: Sun Oct 14, 2018 10:01 pm
by AscLinux
First, you should check dmesg to see if there are any clues regarding wireless.
Also, you could check what kernel version is needed for your card. For instance, device a370 with subsystem 42a4 requires kernel 4.17 or newer.
There is kernel database at cateee.net. IWLWIFI

Re: Intel a370 / AC 9560 no wifi

Posted: Mon Oct 15, 2018 1:54 pm
by weirdybeardyman
Thanks for the info, that might be the issue then, I'll try updating the kernel. I tried dmesg | grep iwl and it produced nothing.

Re: Intel a370 / AC 9560 no wifi

Posted: Mon Oct 15, 2018 4:09 pm
by weirdybeardyman
I am not sure how to id which iwlwifi driver I need, does this info help?
I think it is one of the ones at the bottom of the list with the identification lkddb pci 8086 a370 but I am not sure which one of those I need.

Code: Select all

sudo lshw -c network
*-network UNCLAIMED       
       description: Network controller
       product: Intel Corporation
       vendor: Intel Corporation
       physical id: 14.3
       bus info: pci@0000:00:14.3
       version: 10
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: memory:ed3a4000-ed3a7fff
*-network
       description: Ethernet interface
       product: Killer E2400 Gigabit Ethernet Controller
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:3b:00.0
       logical name: enp59s0
       version: 10
       serial: 54:bf:64:17:4c:7c
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=alx latency=0 link=no multicast=yes port=twisted pair
       resources: irq:17 memory:ed200000-ed23ffff ioport:3000(size=128)
       

Re: Intel a370 / AC 9560 no wifi

Posted: Mon Oct 15, 2018 4:31 pm
by weirdybeardyman
Network controller [0280]: Intel Corporation Device [8086:a370] (rev 10)

There does not appear to be an 8086 - a370 - 0280

Re: Intel a370 / AC 9560 no wifi

Posted: Mon Oct 15, 2018 4:51 pm
by JeremyB
In terminal, do one line at a time

Code: Select all

sudo apt install git build-essential
git clone https://git.kernel.org/pub/scm/linux/kernel/git/iwlwifi/backport-iwlwifi.git
cd backport-iwlwifi
make defconfig-iwlwifi-public
sed -i 's/CPTCFG_IWLMVM_VENDOR_CMDS=y/# CPTCFG_IWLMVM_VENDOR_CMDS is not set/' .config
make -j4
sudo make install
Reboot and go into BIOS/UEFI settings and make sure secure boot is disabled

Re: Intel a370 / AC 9560 no wifi

Posted: Mon Oct 15, 2018 5:17 pm
by weirdybeardyman
Yay I updated (Not sure what the lingo is, shucked?) to 4.17 Kernel and it works like a charm. Only problem is it borked my Nvidia driver again, need to remember how I fixed that before.

Re: Intel a370 / AC 9560 no wifi

Posted: Mon Oct 15, 2018 5:18 pm
by weirdybeardyman
Thanks for the response Jeremy but updating the Kernel fixed it. It's weird that it shows secure boot as being Enabled because I disabled it in UEFI and I even checked it again.

Re: Intel a370 / AC 9560 no wifi

Posted: Mon Oct 15, 2018 5:30 pm
by JeremyB
Go back to the 4.15 kernels as I doubt any Nvidia drivers in the repo will work with the 4.17 kernel or with Secure Boot enabled

Re: Intel a370 / AC 9560 no wifi

Posted: Mon Oct 15, 2018 5:42 pm
by weirdybeardyman
Ok, yeah I will go back to 4.15. I have disabled secure boot though, is there anything I am missing other than unticking the secure boot option in UEFI?

Re: Intel a370 / AC 9560 no wifi

Posted: Mon Oct 15, 2018 5:54 pm
by JeremyB
That should be all

Re: Intel a370 / AC 9560 no wifi

Posted: Mon Oct 15, 2018 6:00 pm
by weirdybeardyman
I rolled back (reshucked) to 4.15 and followed your steps and it's working now. You are a life saver thank you so much!

Re: Intel a370 / AC 9560 no wifi [Solved]

Posted: Mon Oct 15, 2018 6:08 pm
by JeremyB
If you install a newer 4.15 kernel, you will need to

Code: Select all

cd backport-iwlwifi
make clean
make defconfig-iwlwifi-public
sed -i 's/CPTCFG_IWLMVM_VENDOR_CMDS=y/# CPTCFG_IWLMVM_VENDOR_CMDS is not set/' .config
make -j4
sudo make install
Reboot

Re: Intel a370 / AC 9560 no wifi [Solved]

Posted: Mon Oct 15, 2018 6:23 pm
by weirdybeardyman
Thank you!