Page 1 of 1

vpnbook setup error

Posted: Sun Oct 14, 2018 7:14 pm
by Seadreamer
I am trying to get a vpn set up and decided to try vpnbook. In following their instructions for Ubuntu I got this error.

Code: Select all

WARNING: No server certificate verification method has been enabled
Is there a simple answer to this? Everything I can find on google might as well be in Chinese. No offence meant to anyone who is really Chinese. :D

Code: Select all

System:    Host: greybeard-All-Series Kernel: 4.15.0-36-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: MATE 1.20.1 (Gtk 2.24.32) Distro: Linux Mint 19 Tara
Machine:   Device: desktop System: ASUS product: All Series serial: N/A
           Mobo: ASUSTeK model: MAXIMUS VII HERO v: Rev 1.xx serial: N/A
           UEFI [Legacy]: American Megatrends v: 3503 date: 04/18/2018
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
           model: Logitech Wireless Mouse M510 status: Discharging
CPU:       Quad core Intel Core i7-4790K (-MT-MCP-) 
           arch: Haswell rev.3 cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 31984
           clock speeds: max: 4400 MHz 1: 1750 MHz 2: 1781 MHz 3: 1414 MHz
           4: 1766 MHz 5: 1793 MHz 6: 1675 MHz 7: 1788 MHz 8: 1790 MHz
Graphics:  Card: NVIDIA GP104 [GeForce GTX 1080] bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: nvidia (unloaded: modesetting,fbdev,vesa,nouveau)
           Resolution: 1920x1080@60.00hz
           OpenGL: renderer: GeForce GTX 1080/PCIe/SSE2
           version: 4.6.0 NVIDIA 390.77 Direct Render: Yes
Audio:     Card-1 Intel 9 Series Family HD Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 NVIDIA GP104 High Def. Audio Controller
           driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.15.0-36-generic
Network:   Card-1: Intel Ethernet Connection (2) I218-V
           driver: e1000e v: 3.2.6-k port: f040 bus-ID: 00:19.0
           IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter>
           Card-2: Qualcomm Atheros AR93xx Wireless Network Adapter
           driver: ath9k bus-ID: 04:00.0
           IF: wlp4s0 state: down mac: <filter>
Drives:    HDD Total Size: 5265.1GB (53.6% used)
           ID-1: /dev/sda model: MKNSSDCR240GB size: 240.1GB
           ID-2: /dev/sdb model: WDC_SSC size: 256.1GB
           ID-3: /dev/sdc model: WDC_WD7501AALS size: 750.2GB
           ID-4: /dev/sdd model: Samsung_SSD_840 size: 250.1GB
           ID-5: /dev/sde model: SanDisk_SDSSDP25 size: 256.1GB
           ID-6: /dev/sdf model: MKNSSDRE512GB size: 512.1GB
           ID-7: USB /dev/sdg model: My_Passport_0741 size: 2000.4GB
           ID-8: USB /dev/sdh model: Expansion size: 1000.2GB
Partition: ID-1: / size: 21G used: 8.4G (43%) fs: ext4 dev: /dev/sda2
           ID-2: /home size: 347G used: 158G (48%) fs: ext4 dev: /dev/sdc1
           ID-3: swap-1 size: 4.42GB used: 0.00GB (0%)
           fs: swap dev: /dev/sdc5
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 0.0:46C
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 230 Uptime: 3:15 Memory: 2476.1/15983.6MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56 

Re: vpnbook setup error

Posted: Sun Oct 14, 2018 8:17 pm
by Seadreamer
OK, I got it to work. It still gives me the same error but my IP address went from Oregon to Thailand. So I guess it works, it is slow. My email client, Thunderbird, doesn't work is that normal? This is my first attempt at a vpn so I know nothing. Is being from Thailand normal?

Thanks,

Re: vpnbook setup error

Posted: Sun Oct 14, 2018 8:26 pm
by phd21
Hi Seadreamer,

Run this command or install "resolvconf", "easy-rsa", "openvpn", and "network-manager-openvpn" from the "Synaptic Package Manager (SPM)". The openvpn packages are normally pre-installed already in all Linux Mint editions and versions.

Code: Select all

sudo apt install resolvconf easy-rsa openvpn network-manager-openvpn
Then, See these posts:

Video link - Linux Mint 18.x How to add a VPN connection and change DNS Server IP addresses - YouTube
https://www.youtube.com/watch?v=o8ajoFkdeuE

There are 2 really good links in these posts, look for:
How to Establish An OpenVPN Connection in Ubuntu
How to Establish An OpenVPN Connection in Ubuntu 14.04 (Linux Mint 17.x)

Network Manager not using VPN - Linux Mint Forums
viewtopic.php?f=53&t=266820&hilit=vpnbook

vpn [SOLVED] - Linux Mint Forums
viewtopic.php?f=90&t=265922&hilit=vpnbook

Hope this helps ...