Linux Mint Upgrade Error.

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
MateoEstradaR
Level 1
Level 1
Posts: 11
Joined: Mon Oct 15, 2018 6:03 pm

Linux Mint Upgrade Error.

Post by MateoEstradaR » Mon Oct 15, 2018 6:10 pm

Well, this is my first question... I want to upgrade my system but i get this error. Sorry if is in spanish
El objetivo Packages (main/binary-amd64/Packages) está configurado varias veces en /etc/apt/sources.list.d/additional-repositories.list:1 y /etc/apt/sources.list.d/additional-repositories.list:2El objetivo Packages (main/binary-i386/Packages) está configurado varias veces en /etc/apt/sources.list.d/additional-repositories.list:1 y /etc/apt/sources.list.d/additional-repositories.list:2El objetivo Packages (main/binary-all/Packages) está configurado varias veces en /etc/apt/sources.list.d/additional-repositories.list:1 y /etc/apt/sources.list.d/additional-repositories.list:2El objetivo Translations (main/i18n/Translation-es_CO) está configurado varias veces en /etc/apt/sources.list.d/additional-repositories.list:1 y /etc/apt/sources.list.d/additional-repositories.list:2El objetivo Translations (main/i18n/Translation-es) está configurado varias veces en /etc/apt/sources.list.d/additional-repositories.list:1 y /etc/apt/sources.list.d/additional-repositories.list:2El objetivo Translations (main/i18n/Translation-en) está configurado varias veces en /etc/apt/sources.list.d/additional-repositories.list:1 y /etc/apt/sources.list.d/additional-repositories.list:2El objetivo DEP-11 (main/dep11/Components-amd64.yml) está configurado varias veces en /etc/apt/sources.list.d/additional-repositories.list:1 y /etc/apt/sources.list.d/additional-repositories.list:2El objetivo DEP-11 (main/dep11/Components-all.yml) está configurado varias veces en /etc/apt/sources.list.d/additional-repositories.list:1 y /etc/apt/sources.list.d/additional-repositories.list:2El objetivo CNF (main/cnf/Commands-amd64) está configurado varias veces en /etc/apt/sources.list.d/additional-repositories.list:1 y /etc/apt/sources.list.d/additional-repositories.list:2El objetivo CNF (main/cnf/Commands-all) está configurado varias veces en /etc/apt/sources.list.d/additional-repositories.list:1 y /etc/apt/sources.list.d/additional-repositories.list:2Error de GPG: http://download.opensuse.org/repositori ... Debian_9.0 ./ Release: Las firmas siguientes no se pudieron verificar porque su clave pública no está disponible: NO_PUBKEY 2F7F0DA5FD5B64B9El repositorio «http://download.opensuse.org/repositori ... Debian_9.0 ./ Release» no está firmado.

Thanks for any help.

JeremyB
Level 19
Level 19
Posts: 9305
Joined: Fri Feb 21, 2014 8:17 am

Re: Linux Mint Upgrade Error.

Post by JeremyB » Mon Oct 15, 2018 6:33 pm

Post results from terminal for

Code: Select all

inxi -r

MateoEstradaR
Level 1
Level 1
Posts: 11
Joined: Mon Oct 15, 2018 6:03 pm

Re: Linux Mint Upgrade Error.

Post by MateoEstradaR » Mon Oct 15, 2018 7:13 pm

This is what i get from

Code: Select all

 Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
           deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main
           deb https://dl.winehq.org/wine-builds/ubuntu/ bionic main
           Active apt sources in file: /etc/apt/sources.list.d/google-chrome.list
           deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
           Active apt sources in file: /etc/apt/sources.list.d/lutris.list
           deb http://download.opensuse.org/repositories/home:/strycore/Debian_9.0/ ./
           Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
           deb http://packages.linuxmint.com tara main upstream import backport
           deb http://archive.ubuntu.com/ubuntu bionic main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe multiverse
           deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
           deb http://security.ubuntu.com/ubuntu/ bionic-security main restricted universe multiverse
           deb http://archive.canonical.com/ubuntu/ bionic partner
           Active apt sources in file: /etc/apt/sources.list.d/webupd8team-java-bionic.list
           deb http://ppa.launchpad.net/webupd8team/java/ubuntu bionic main
           deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu bionic main

gm10
Level 12
Level 12
Posts: 4145
Joined: Thu Jun 21, 2018 5:11 pm

Re: Linux Mint Upgrade Error.

Post by gm10 » Mon Oct 15, 2018 7:31 pm

Do we even need to ask anymore? Of course it's winehq. It's always wineq. Somebody tell them to fix their stupid installation instructions...

Run:

Code: Select all

sudo sed -i '2d' /etc/apt/sources.list.d/additional-repositories.list

User avatar
xenopeek
Level 24
Level 24
Posts: 23117
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Linux Mint Upgrade Error.

Post by xenopeek » Tue Oct 16, 2018 2:23 am

In addition to above to delete the duplicate line you have in your repositories, to solve the NO_PUBKEY for your Lutris repository you need to redo the instructions for adding their repository because you botched that. From https://lutris.net/downloads/. You used the Debian instructions while you're using Linux Mint 19 that is based on Ubuntu.

First, run this command to overwrite the Lutris repository configuration file with the correct information:
echo "deb http://download.opensuse.org/repositories/home:/strycore/xUbuntu_18.04/ ./" | sudo tee /etc/apt/sources.list.d/lutris.list
Next, get the public key for the Lutris repository:
wget -q https://download.opensuse.org/repositories/home:/strycore/xUbuntu_18.04/Release.key -O- | sudo apt-key add -

That should fix the NO_PUBKEY and after doing apt update you should be able to install Lutris with apt install lutris
Image

gm10
Level 12
Level 12
Posts: 4145
Joined: Thu Jun 21, 2018 5:11 pm

Re: Linux Mint Upgrade Error.

Post by gm10 » Tue Oct 16, 2018 2:26 am

Hah, good catch xeno. I didn't even look at that wall of text. No line breaks makes me look away. ;)

MateoEstradaR
Level 1
Level 1
Posts: 11
Joined: Mon Oct 15, 2018 6:03 pm

Re: Linux Mint Upgrade Error.

Post by MateoEstradaR » Tue Oct 16, 2018 8:03 pm

Thanks, that worked for me, sorry but. What does that happen? And. What is lutris or whatever it is called like for?

User avatar
xenopeek
Level 24
Level 24
Posts: 23117
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Linux Mint Upgrade Error.

Post by xenopeek » Wed Oct 17, 2018 3:01 am

I haven't the foggiest; something for managing games? https://lutris.net/ You added it to your system yourself.
Image

Post Reply

Return to “Newbie Questions”