limit thumbnails cache does not work

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
vansloneker
Level 5
Level 5
Posts: 575
Joined: Sat Mar 17, 2018 6:10 am

limit thumbnails cache does not work

Post by vansloneker »

I have limited the thumbnails cache by dconf editor [org - gnome - desktop - thumbnail-cache] however the limits I've set are not applied by the system. After setting it still thumbnails are saved that exceed the limits I've set.

I've found a way of completely disabling them
xenopeek wrote:
Thu Nov 05, 2015 12:32 pm
In the most basic way:

Code: Select all

rm -rf ~/.cache/thumbnails/*
chmod 555 ~/.cache/thumbnails
sudo chown root:root ~/.cache/thumbnails
Empties it, makes it read only, and locks ownership to root. No more thumbnails can be created.

I didn't look into dconf settings but probably there is an option to disable thumbnail creation from Nemo there.
but maybe there is something I have overlooked with the dconf editor?
Unless stated otherwise Mint 18.3-64 XFCE
AscLinux
Level 4
Level 4
Posts: 342
Joined: Sat Oct 29, 2016 3:32 pm

Re: limit thumbnails cache does not work

Post by AscLinux »

Don't know about dconf and Co. But you could create a cronjob which cleans the thumbnails directory of all files older than x days (or hours).
User avatar
smurphos
Level 17
Level 17
Posts: 7332
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: limit thumbnails cache does not work

Post by smurphos »

vansloneker wrote:
Tue Oct 16, 2018 11:47 am
I have limited the thumbnails cache by dconf editor [org - gnome - desktop - thumbnail-cache] however the limits I've set are not applied by the system. After setting
Are you still on Cinnamon?

If so i think that's the wrong schema - you want org.cinnamon.desktop.thumbnail-cache
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.
User avatar
vansloneker
Level 5
Level 5
Posts: 575
Joined: Sat Mar 17, 2018 6:10 am

Re: limit thumbnails cache does not work

Post by vansloneker »

Read the signature.
Unless stated otherwise Mint 18.3-64 XFCE
User avatar
xenopeek
Level 24
Level 24
Posts: 24855
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: limit thumbnails cache does not work

Post by xenopeek »

Small light green letters on light yellow or white background isn't the easiest to read :)
Image
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: limit thumbnails cache does not work

Post by gm10 »

vansloneker wrote:
Tue Oct 16, 2018 2:37 pm
Read the signature.
Why assume we even see your signature:
sig.png
;)
vansloneker wrote:
Tue Oct 16, 2018 11:47 am
I've found a way of completely disabling them
That's a terrible way. You can just disable them in nemo (or whatever your file manager is) options.
User avatar
vansloneker
Level 5
Level 5
Posts: 575
Joined: Sat Mar 17, 2018 6:10 am

Re: limit thumbnails cache does not work

Post by vansloneker »

gm10 wrote:
Wed Oct 17, 2018 2:06 pm
vansloneker wrote:
Tue Oct 16, 2018 2:37 pm
...
vansloneker wrote:
Tue Oct 16, 2018 11:47 am
I've found a way of completely disabling them
That's a terrible way. You can just disable them in nemo (or whatever your file manager is) options.
Well XFCE comes with Thunar. I don't want disable them, I don't want to lug around thousands of saved thumbs for months that have only been of usage once or twice while viewing a folder.

-

Please save me those petty jokes. It's a good sig and in all harmony with the Linux Mint forum lay out.
Unless stated otherwise Mint 18.3-64 XFCE
gm10
Level 20
Level 20
Posts: 10999
Joined: Thu Jun 21, 2018 5:11 pm

Re: limit thumbnails cache does not work

Post by gm10 »

Oh Thunar doesn't allow you to disable it? Weird.
vansloneker wrote:
Wed Oct 17, 2018 2:58 pm
Please save me those petty jokes. It's a good sig and in all harmony with the Linux Mint forum lay out.
Wasn't a joke, although you might just have made it one, because all my screenshot showed was that I have signatures disabled, that's why I cannot see yours and why it's generally not reliable to assume people read your sig. ;)
Post Reply

Return to “Newbie Questions”