on shutdown a number of apps are not responding

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
ineuw
Level 4
Level 4
Posts: 258
Joined: Sun Nov 13, 2016 12:27 am
Location: Canada

on shutdown a number of apps are not responding

Post by ineuw » Wed Oct 17, 2018 8:46 pm

In the attached image, this app never responds to a shutdown, and there are times that are as many as 7 apps don't respond. What can I do to correct this?
Screenshot from 2018-10-17 20-26-18.png
Windows 10 and Linux Mint 19v2 Cinnamon 16gb RAM and a Macbook 3.1 laptop, 64bit 4gb RAM.

User avatar
xenopeek
Level 24
Level 24
Posts: 23117
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: on shutdown a number of apps are not responding

Post by xenopeek » Thu Oct 18, 2018 5:24 am

No idea why so many applications could be stuck. AT-SPI is for accessibility. Are you using anything like desktop zoom, on screen keyboard, screen reader or such?

You might try disabling AT-SPI though I'm hard pressed to explain how AT-SPI could cause all those other applications you refer to get stuck. Seems like something else must be the root cause. But you could try. It seems to me at best this would remove AT-SPI from the stuck applications list at shutdown, not fix the actual problem or solve the issue for those other applications.

You need to both disable the autostarter AND mask the user bus service, or it will get started anyway. First, make sure your autostart override directory exists with this command:
mkdir -v ~/.config/autostart
Then you can run this command to disable the autostarter:
cat /etc/xdg/autostart/at-spi-dbus-bus.desktop <(echo "X-GNOME-Autostart-enabled=false") > ~/.config/autostart/at-spi-dbus-bus.desktop
Finally also mask the user bus service:
systemctl --user mask at-spi-dbus-bus.service
Image

User avatar
ineuw
Level 4
Level 4
Posts: 258
Joined: Sun Nov 13, 2016 12:27 am
Location: Canada

Re: on shutdown a number of apps are not responding

Post by ineuw » Fri Oct 19, 2018 11:48 am

xenopeek, I am sure that these issues directly relate to the video problem, about which I last posted, I use none of the software mentioned and my take on the issue is old hardware attempting to incorporate new software and a lack of video memory. I will keep you posted and thanks for the help. A very interesting solution.
Windows 10 and Linux Mint 19v2 Cinnamon 16gb RAM and a Macbook 3.1 laptop, 64bit 4gb RAM.

milomak
Level 1
Level 1
Posts: 7
Joined: Wed May 09, 2012 4:40 pm

Re: on shutdown a number of apps are not responding

Post by milomak » Fri Nov 02, 2018 10:08 am

thanks this seems to have helped me disable at-spi on my debian install as well

Post Reply

Return to “Newbie Questions”