[SOLVED] Wifi adapter not detected on Thinkpad

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
trinine
Level 1
Level 1
Posts: 2
Joined: Fri Oct 19, 2018 8:15 pm

[SOLVED] Wifi adapter not detected on Thinkpad

Post by trinine » Fri Oct 19, 2018 8:21 pm

Hello!

My laptop had Windows 8 on it, but then decided to install Linux Mint 19 Tara. But, after the install, Linux Mint says there is no Wi-Fi adapters in this system.
If any one needs it, here is

Code: Select all

inxi -Fxz
System:    Host: jackie-ThinkPad-11e Kernel: 4.15.0-20-generic x86_64
           bits: 64 gcc: 7.3.0
           Desktop: Cinnamon 3.8.8 (Gtk 3.22.30-1ubuntu1)
           Distro: Linux Mint 19 Tara
Machine:   Device: laptop System: LENOVO product: 20ED001HUS v: ThinkPad 11e serial: N/A
           Mobo: LENOVO model: 20ED001HUS v: SDK0J40697 WIN serial: N/A
           UEFI [Legacy]: LENOVO v: JIET28WW (1.13 ) date: 01/21/2016
Battery    BAT1: charge: 22.1 Wh 65.5% condition: 33.8/34.0 Wh (99%)
           model: SMP LNV-45N1751 status: Discharging
CPU:       Quad core AMD A4-6210 APU with AMD Radeon R3 Graphics (-MCP-) 
           arch: Puma rev.1 cache: 2048 KB
           
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 14372
           clock speeds: max: 1800 MHz 1: 1260 MHz 2: 1123 MHz 3: 1207 MHz
           4: 1272 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Mullins [Radeon R3 Graphics]
           bus-ID: 00:01.0
           Display Server: x11 (X.Org 1.19.6 )
           drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1366x768@60.00hz
           OpenGL: renderer: AMD MULLINS (DRM 2.50.0 / 4.15.0-20-generic, LLVM 6.0.0)
           version: 4.5 Mesa 18.0.0-rc5 Direct Render: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller
           driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Kabini HDMI/DP Audio
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.15.0-20-generic
Network:   Card-1: Broadcom Limited BCM4352 802.11ac Wireless Network Adapter
           driver: bcma-pci-bridge bus-ID: 01:00.0
           IF: N/A state: N/A mac: N/A
           Card-2: Realtek RTL8111/8168/8411 PCIE Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: 1000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 135.7GB (7.4% used)
           ID-1: /dev/sda model: SAMSUNG_MZ7LF120 size: 120.0GB
           ID-2: USB /dev/sdb model: Cruzer_Glide size: 15.7GB
Partition: ID-1: / size: 110G used: 7.6G (8%) fs: ext4 dev: /dev/sda1
RAID:      No RAID devices: /proc/mdstat, md_mod kernel module present
Sensors:   System Temperatures: cpu: 60.0C mobo: 0.0C gpu: 62.0
           Fan Speeds (in rpm): cpu: 0
Info:      Processes: 193 Uptime: 7 min Memory: 1145.1/3368.4MB
           Init: systemd runlevel: 5 Gcc sys: 7.3.0
           Client: Shell (bash 4.4.191) inxi: 2.3.56
Last edited by trinine on Sat Oct 20, 2018 9:18 am, edited 2 times in total.

User avatar
thx-1138
Level 6
Level 6
Posts: 1247
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Wifi adapter not detected on Thinkpad

Post by thx-1138 » Sat Oct 20, 2018 3:51 am

...open Control Center - Driver Manager, see if it lists bcmwl-kernel-source, enable it.
If not, try: sudo apt-get install bcmwl-kernel-source

trinine
Level 1
Level 1
Posts: 2
Joined: Fri Oct 19, 2018 8:15 pm

Re: Wifi adapter not detected on Thinkpad

Post by trinine » Sat Oct 20, 2018 9:17 am

Thank you! This worked on my laptop. :wink:

Post Reply

Return to “Newbie Questions”