[Solved] Mint 19 Leafpad word wrap setting not remembered

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
User avatar
vansloneker
Level 4
Level 4
Posts: 279
Joined: Sat Mar 17, 2018 6:10 am

[Solved] Mint 19 Leafpad word wrap setting not remembered

Post by vansloneker » Sat Oct 20, 2018 2:41 pm

I installed Mint 19 for someone else. In this setup I installed Leafpad. It does not remember word wrap.
Last edited by vansloneker on Mon Oct 22, 2018 8:29 am, edited 1 time in total.
Unless stated otherwise Mint 18.3-64 XFCE

User avatar
xenopeek
Level 24
Level 24
Posts: 23128
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Mint 19 Leafpad word wrap setting not remembered

Post by xenopeek » Sun Oct 21, 2018 2:35 pm

Can't reproduce. Just installed leafpad on Linux Mint 19 and toggling word wrap, closing and restart leafpad, it's still what I set it to.

It stores its configuration in ~/.config/leafpad/leafpadrc. Perhaps that directory isn't writable for some reason (can happen when you run GUI programs as root with sudo, makes stuff in your home directory be owned by root). Check that first.

It's a weird format but here is the file for me with word wrap disabled:

Code: Select all

0.8.18.1
600
400
Monospace 12
0
0
0
And with word wrap enabled (3rd line from bottom changed from 0 to 1):

Code: Select all

0.8.18.1
600
400
Monospace 12
1
0
0
Image

User avatar
vansloneker
Level 4
Level 4
Posts: 279
Joined: Sat Mar 17, 2018 6:10 am

Re: Mint 19 Leafpad word wrap setting not remembered

Post by vansloneker » Mon Oct 22, 2018 8:28 am

Thanks very much for taking the trouble of investigating this.
Your guess is perfect: the folder was owned by root and no rights for the user.
I've set rights for the user and now it works as it should be.

I remember when I installed this, the Software Manager hung and I had to close and start it over again. Maybe that has something to do with it.
Unless stated otherwise Mint 18.3-64 XFCE

Post Reply

Return to “Newbie Questions”