[SOLVED] Software updater has disappeared from the system

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Elysium
Level 2
Level 2
Posts: 60
Joined: Sat Nov 24, 2012 5:01 pm

[SOLVED] Software updater has disappeared from the system

Post by Elysium » Mon Oct 22, 2018 8:02 pm

Hi there,

I am using LM 18.3 Cinnamon and my update manager has disappeared completely.

Has anyone had the same issue? What is the solution? Google only gives me matches that deal with the disappearance of the update icon (which is not the case...it is totally gone). I have tried updating from the command like using "sudo apt-get update", but the updater finishes really quickly. I would expect more updates, but I might be wrong on this one.

Cheers
Last edited by Moem on Thu Oct 25, 2018 3:14 am, edited 1 time in total.
Reason: Marked this as [SOLVED] for you; please note that you can and should do this for your own topics. Thanks!

User avatar
all41
Level 13
Level 13
Posts: 4875
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Software updater has disappeared from the system

Post by all41 » Mon Oct 22, 2018 8:16 pm

Try opening the Update Manager via the terminal:

Code: Select all

mintupdate
If you are referring to the Software Manager te terminal command is:

Code: Select all

mintinstall
If the terminal windows report errors copy and paste those back to this thread.
Proud to be a supporter and monthly contributor to Mint.

Elysium
Level 2
Level 2
Posts: 60
Joined: Sat Nov 24, 2012 5:01 pm

Re: Software updater has disappeared from the system

Post by Elysium » Mon Oct 22, 2018 11:50 pm

all41 wrote:
Mon Oct 22, 2018 8:16 pm
Try opening the Update Manager via the terminal:

Code: Select all

mintupdate
If you are referring to the Software Manager te terminal command is:

Code: Select all

mintinstall
If the terminal windows report errors copy and paste those back to this thread.
Hi, Thanks a lot!

Mintupdate gives me this:
"I have just typed that in the terminal.......

~ $ mintupdate
mintupdate: command not found

So, that is a bit surprising.

Mintinstall gives this:

Code: Select all

 ~ $ mintinstall
Detected system architecture: 'x86_64' (using 'x86_64')
load_cache took 2766.365 ms
add_categories took 91.759 ms
build_matched_packages took 0.867 ms
add_packages took 8523.564 ms
process_matching_packages took 19.548 ms
add_reviews took 1047.665 ms
Downloading new reviews
__init__ took 13414.569 ms
update_reviews took 2911.998 ms
add_flatpaks took 19964.776 ms
Overwriting reviews file in /home/gabe/.cache/mintinstall/reviews.list
update_reviews took 2921.480 ms
Synced flathub
sync_flatpaks_into_appstream took 96792.979 ms
^CTraceback (most recent call last):
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 2035, in <module>
    app.run()
  File "/usr/lib/linuxmint/mintinstall/mintinstall.py", line 563, in run
    self.loop.run()
  File "/usr/lib/python2.7/dist-packages/gi/overrides/GLib.py", line 576, in run
    raise KeyboardInterrupt
KeyboardInterrupt
Last edited by WharfRat on Tue Oct 23, 2018 10:48 pm, edited 1 time in total.
Reason: Added code tag

User avatar
smurphos
Level 8
Level 8
Posts: 2050
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Software updater has disappeared from the system

Post by smurphos » Tue Oct 23, 2018 12:38 am

What's the output of apt policy mint*. If that throws an error of any description please post back the error and try apt-cache policy mint* instead. Please paste the output back in [code][/code] tags. Makes for easier reading.

Elysium
Level 2
Level 2
Posts: 60
Joined: Sat Nov 24, 2012 5:01 pm

Re: Software updater has disappeared from the system

Post by Elysium » Tue Oct 23, 2018 1:38 am

smurphos wrote:
Tue Oct 23, 2018 12:38 am
What's the output of apt policy mint*. If that throws an error of any description please post back the error and try apt-cache policy mint* instead. Please paste the output back in [code][/code] tags. Makes for easier reading.
Hi,

Ok. Sure. I am posting what the apt policy mint* gives at the line that says "mintupdate"

Code: Select all

mintupdate:
  Installed: (none)
  Candidate: 5.3.2.5
  Version table:
     5.3.2.5 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status

It doesnt give any error messages, but it looks like the mintupdate is all gone.

Here is the whole list I was given:

Code: Select all

apt policy mint*
mint-meta-kde64:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-mirrors:
  Installed: 1.1.7
  Candidate: 1.1.8
  Version table:
     1.1.8 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
 *** 1.1.7 100
        100 /var/lib/dpkg/status
mintwelcome:
  Installed: (none)
  Candidate: 2.2.6
  Version table:
     2.2.6 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-user-guide-kde:
  Installed: (none)
  Candidate: 18
  Version table:
     18 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-translations:
  Installed: 2018.01.06
  Candidate: 2018.01.06
  Version table:
 *** 2018.01.06 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-z-theme:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-mate-default-settings:
  Installed: (none)
  Candidate: (none)
  Version table:
mintdesktop:
  Installed: (none)
  Candidate: 3.5.7
  Version table:
     3.5.7 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-mdm-themes-gdm:
  Installed: (none)
  Candidate: 1.8.1
  Version table:
     1.8.1 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-artwork-gnome:
  Installed: 2.6.49
  Candidate: 2.6.49
  Version table:
 *** 2.6.49 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-wallpaper-katya:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-backgrounds-serena:
  Installed: 1.1
  Candidate: 1.1
  Version table:
 *** 1.1 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-y-icons:
  Installed: 1.1.3
  Candidate: 1.1.3
  Version table:
 *** 1.1.3 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-mdm-themes-kde:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-backgrounds-rebecca:
  Installed: (none)
  Candidate: 1.5
  Version table:
     1.5 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-themes-gtk3:
  Installed: 3.18+17
  Candidate: 3.18+17
  Version table:
 *** 3.18+17 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mintinstall:
  Installed: 7.8.9
  Candidate: 7.8.9
  Version table:
 *** 7.8.9 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-themes:
  Installed: 1.5.0
  Candidate: 1.5.0
  Version table:
 *** 1.5.0 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mintupdate-gnome:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-user-guide-cinnamon:
  Installed: 18
  Candidate: 18
  Version table:
 *** 18 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-backgrounds-sonya:
  Installed: 1.1
  Candidate: 1.1
  Version table:
 *** 1.1 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-info:
  Installed: (none)
  Candidate: (none)
  Version table:
mintsources:
  Installed: 1.7.2
  Candidate: 1.7.2
  Version table:
 *** 1.7.2 700
        700 http://packages.linuxmint.com sylvia/upstream amd64 Packages
        700 http://packages.linuxmint.com sylvia/upstream i386 Packages
        100 /var/lib/dpkg/status
mint-mdm-themes:
  Installed: (none)
  Candidate: 2014.10.29
  Version table:
     2014.10.29 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mintsystem:
  Installed: 8.3.4
  Candidate: 8.3.4
  Version table:
 *** 8.3.4 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mintlocale:
  Installed: 1.4.4
  Candidate: 1.4.4
  Version table:
 *** 1.4.4 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-meta-codecs-kde:
  Installed: (none)
  Candidate: 2017.06.25
  Version table:
     2017.06.25 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-meta-xfce:
  Installed: (none)
  Candidate: 2017.09.19
  Version table:
     2017.09.19 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-meta-codecs-core:
  Installed: 2017.06.25
  Candidate: 2017.06.25
  Version table:
 *** 2017.06.25 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-backgrounds-sarah:
  Installed: 1.1
  Candidate: 1.1
  Version table:
 *** 1.1 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mintupdate-xfce:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-meta-main:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-meta-mate:
  Installed: (none)
  Candidate: 2017.09.19
  Version table:
     2017.09.19 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mintassistant-kde:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-meta-cinnamon:
  Installed: (none)
  Candidate: 2017.09.19
  Version table:
     2017.09.19 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-meta-gnome:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-artwork-common:
  Installed: 2.1.8.1
  Candidate: 2.1.8.1
  Version table:
 *** 2.1.8.1 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-user-guide:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-meta-codecs:
  Installed: 2017.06.25
  Candidate: 2017.06.25
  Version table:
 *** 2017.06.25 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-user-guide-xfce:
  Installed: (none)
  Candidate: 18
  Version table:
     18 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mintreport:
  Installed: 1.0.5
  Candidate: 1.0.5
  Version table:
 *** 1.0.5 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mintupdate-debian:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-backgrounds-katya:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-common:
  Installed: 1.2.9
  Candidate: 1.2.9
  Version table:
 *** 1.2.9 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-artwork-cinnamon:
  Installed: 5.7
  Candidate: 5.7
  Version table:
 *** 5.7 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-meta-core:
  Installed: (none)
  Candidate: 2017.09.19
  Version table:
     2017.09.19 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-meta-cinnamon-dvd:
  Installed: (none)
  Candidate: (none)
  Version table:
mintassistant:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-user-guide-mate:
  Installed: (none)
  Candidate: 18
  Version table:
     18 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mintdrivers:
  Installed: 1.3.7
  Candidate: 1.3.7
  Version table:
 *** 1.3.7 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-backgrounds-nadia:
  Installed: (none)
  Candidate: 1.4
  Version table:
     1.4 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-artwork-debian:
  Installed: (none)
  Candidate: (none)
  Version table:
mintupgrade:
  Installed: (none)
  Candidate: 18.3.11
  Version table:
     18.3.11 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-info-kde:
  Installed: (none)
  Candidate: 2017.10.27
  Version table:
     2017.10.27 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
mint-meta-kde:
  Installed: (none)
  Candidate: 2017.09.19
  Version table:
     2017.09.19 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-x-theme:
  Installed: (none)
  Candidate: (none)
  Version table:
mintbackup:
  Installed: 2.3.2
  Candidate: 2.3.2
  Version table:
 *** 2.3.2 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-backgrounds-rafaela:
  Installed: (none)
  Candidate: 1.2
  Version table:
     1.2 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mintmenu:
  Installed: 5.8.4
  Candidate: 5.8.4
  Version table:
 *** 5.8.4 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mintstick:
  Installed: 1.3.5
  Candidate: 1.3.5
  Version table:
 *** 1.3.5 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-backgrounds-qiana:
  Installed: (none)
  Candidate: 1.5
  Version table:
     1.5 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mintupload:
  Installed: (none)
  Candidate: 4.1.1
  Version table:
     4.1.1 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-mdm-themes-html:
  Installed: (none)
  Candidate: 2.0.15
  Version table:
     2.0.15 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mintupdate:
  Installed: (none)
  Candidate: 5.3.2.5
  Version table:
     5.3.2.5 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-dev-tools:
  Installed: (none)
  Candidate: 1.1.7
  Version table:
     1.1.7 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-info-cinnamon:
  Installed: 2017.10.27
  Candidate: 2017.10.27
  Version table:
 *** 2017.10.27 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        100 /var/lib/dpkg/status
mint-backgrounds-retro:
  Installed: (none)
  Candidate: 1.3
  Version table:
     1.3 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-y-theme:
  Installed: 1.2.3
  Candidate: 1.2.3
  Version table:
 *** 1.2.3 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-artwork-xfce:
  Installed: (none)
  Candidate: 2017.12.13
  Version table:
     2017.12.13 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-backgrounds-rosa:
  Installed: (none)
  Candidate: 1.2
  Version table:
     1.2 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-backgrounds-petra:
  Installed: (none)
  Candidate: 1.7
  Version table:
     1.7 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-backgrounds-olivia:
  Installed: (none)
  Candidate: 1.7
  Version table:
     1.7 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-upgrade-info:
  Installed: 1.1.1
  Candidate: 1.1.1
  Version table:
 *** 1.1.1 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-backgrounds-xfce:
  Installed: (none)
  Candidate: 2017.10.27
  Version table:
     2017.10.27 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-artwork-mate:
  Installed: 1.3.4
  Candidate: 1.3.4
  Version table:
 *** 1.3.4 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
mint-backgrounds-sylvia:
  Installed: 1.1
  Candidate: 1.2
  Version table:
     1.2 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
 *** 1.1 100
        100 /var/lib/dpkg/status
mintassistant-gnome:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-info-xfce:
  Installed: (none)
  Candidate: 2017.10.27
  Version table:
     2017.10.27 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
mint-clearloox-theme:
  Installed: (none)
  Candidate: (none)
  Version table:
mintnanny:
  Installed: (none)
  Candidate: 1.5.4
  Version table:
     1.5.4 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-configuration-kde:
  Installed: (none)
  Candidate: (none)
  Version table:
mintupdate-kde:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-meta-x64:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-backgrounds-maya:
  Installed: (none)
  Candidate: 1.5
  Version table:
     1.5 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mint-info-mate:
  Installed: (none)
  Candidate: 2017.10.27
  Version table:
     2017.10.27 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
mint-artwork-kde:
  Installed: (none)
  Candidate: 2.0.31
  Version table:
     2.0.31 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
mintnanny-kde:
  Installed: (none)
  Candidate: (none)
  Version table:
mintnanny-gnome:
  Installed: (none)
  Candidate: (none)
  Version table:
mint-x-icons:
  Installed: 1.4.6
  Candidate: 1.4.6
  Version table:
 *** 1.4.6 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
Last edited by WharfRat on Tue Oct 23, 2018 10:44 pm, edited 1 time in total.
Reason: Fixed the code tags.

User avatar
smurphos
Level 8
Level 8
Posts: 2050
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Software updater has disappeared from the system

Post by smurphos » Tue Oct 23, 2018 2:06 am

You are missing a few things that should be there.

apt install mint-meta-cinnamon should bring them back.

Do you recall uninstalling something else just prior to update manager's disappearance? If so what was it?

Elysium
Level 2
Level 2
Posts: 60
Joined: Sat Nov 24, 2012 5:01 pm

Re: Software updater has disappeared from the system

Post by Elysium » Tue Oct 23, 2018 8:38 pm

smurphos wrote:
Tue Oct 23, 2018 2:06 am
You are missing a few things that should be there.

apt install mint-meta-cinnamon should bring them back.

Do you recall uninstalling something else just prior to update manager's disappearance? If so what was it?
That did fix it. Thanks.

Can you do me a favour and explain to me why this has happened and how that command fixed it?

Cheers

User avatar
all41
Level 13
Level 13
Posts: 4875
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Software updater has disappeared from the system

Post by all41 » Tue Oct 23, 2018 9:11 pm

That did fix it. Thanks.
Can you do me a favour and explain to me why this has happened and how that command fixed it?
@smurphos
Yes,
Obviously a grand slam--will you offer up your diagnosis thoughts here.

@Elysium Good that your system is back in order
Proud to be a supporter and monthly contributor to Mint.

User avatar
smurphos
Level 8
Level 8
Posts: 2050
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Software updater has disappeared from the system

Post by smurphos » Wed Oct 24, 2018 12:09 am

Give that mintupdate had mysteriously disappeared my hunch was that Elysium had inadvertently uninstalled a package that mintupdate depends on so triggering mintupdate removal. That it turn would trigger other removals hence asking for the output of the apt policy mint* to double check what else what missing from the main mint packages that should be there.

mint-meta-cinnamon doesn't do anything as a package itself other than list a whole bunch of dependencies for packages that should be present on any Mint Cinnamon install. It was missing along with another meta package mint-meta-core and mintwelcome so a quick fix rather than trawling through each and every package was to install it - triggering the installation of any other essential missing package including mintupdate

This shows the dependency chain (On a Mint 19 Cinnamon machine)

Code: Select all

steve@steve-HP-Pavilion-g6-Notebook-PC:~$ apt depends mint-meta-cinnamon
mint-meta-cinnamon
  Depends: mint-meta-core
  Depends: cinnamon
  Depends: gir1.2-gnomedesktop-3.0
  Depends: gir1.2-nemo-3.0
  Depends: nemo
  Depends: nemo-fileroller
  Depends: folder-color-switcher
  Depends: cinnamon-control-center
  Depends: cinnamon-screensaver
  Depends: cinnamon-screensaver-x-plugin
  Conflicts: <mint-meta-cinnamon-dvd>
  Conflicts: <mint-meta-gnome>
  Conflicts: <mint-meta-main>
  Conflicts: <mint-meta-x64>
  Replaces: <mint-meta-cinnamon-dvd>
  Replaces: <mint-meta-gnome>
  Replaces: <mint-meta-main>
  Replaces: <mint-meta-x64>
steve@steve-HP-Pavilion-g6-Notebook-PC:~$ apt depends mint-meta-core
mint-meta-core
  Depends: linuxmint-keyring
  Depends: <mint-info>
    mint-info-cinnamon
    mint-info-mate
    mint-info-xfce
  Depends: mint-artwork
  Depends: mintsystem
  Depends: ubuntu-system-adjustments
  Depends: plymouth-theme-ubuntu-text
  Depends: mintbackup
  Depends: mintinstall
  Depends: mintupdate
  Depends: mintwelcome
  Depends: mintsources
  Depends: mintdrivers
  Depends: mintstick
steve@steve-HP-Pavilion-g6-Notebook-PC:~$ apt depends mintupdate
mintupdate
 |Depends: dconf-gsettings-backend
  Depends: <gsettings-backend>
    dconf-gsettings-backend
  Depends: lsb-release
  Depends: inxi
  Depends: python3-apt
  Depends: python3-pycurl
  Depends: python3-setproctitle
  Depends: synaptic
  Depends: mint-mirrors
  Depends: mint-upgrade-info
  Depends: python3-xapp
  Depends: gir1.2-appindicator3-0.1
  Conflicts: <mintupdate-gnome>
  Conflicts: <mintupdate-kde>
  Conflicts: <mintupdate-xfce>
  Replaces: <mintupdate-gnome>
  Replaces: <mintupdate-kde>
  Replaces: <mintupdate-xfce>
To know what triggered the problem the first place Elysium would need to trawl through the apt logs (or post them back for us to have a look at) - cat /var/log/apt/history.log & cat /var/log/apt/term.log to try and identify what happened immediately prior to mintupdate being removed.

User avatar
all41
Level 13
Level 13
Posts: 4875
Joined: Tue Dec 31, 2013 9:12 am
Location: Computer, Car, Cage

Re: Software updater has disappeared from the system

Post by all41 » Wed Oct 24, 2018 12:15 am

smurphos--you d man
thanks for thought train
Proud to be a supporter and monthly contributor to Mint.

Elysium
Level 2
Level 2
Posts: 60
Joined: Sat Nov 24, 2012 5:01 pm

Re: Software updater has disappeared from the system

Post by Elysium » Wed Oct 24, 2018 11:24 pm

smurphos wrote:
Wed Oct 24, 2018 12:09 am
Give that mintupdate had mysteriously disappeared my hunch was that Elysium had inadvertently uninstalled a package that mintupdate depends on so triggering mintupdate removal. That it turn would trigger other removals hence asking for the output of the apt policy mint* to double check what else what missing from the main mint packages that should be there.

mint-meta-cinnamon doesn't do anything as a package itself other than list a whole bunch of dependencies for packages that should be present on any Mint Cinnamon install. It was missing along with another meta package mint-meta-core and mintwelcome so a quick fix rather than trawling through each and every package was to install it - triggering the installation of any other essential missing package including mintupdate

This shows the dependency chain (On a Mint 19 Cinnamon machine)
Thanks a lot for your patience and given me that information. I did type the command: cat /var/log/apt/history.log

I was given this information, which I dont fully understand and it also seems to be only a 3 day range of changes on my computer.

Code: Select all

Start-Date: 2018-10-22  09:29:27
Commandline: apt-get install telepad
Requested-By: gabe (1000)
Install: ca-certificates-java:amd64 (20160321ubuntu1, automatic), libpthread-stubs0-dev:amd64 (0.3-4, automatic), x11proto-kb-dev:amd64 (1.0.7-0ubuntu1, automatic), openjdk-8-jdk:amd64 (8u181-b13-0ubuntu0.16.04.1, automatic), libxtst-dev:amd64 (2:1.2.2-1, automatic), openjdk-8-jre:amd64 (8u181-b13-0ubuntu0.16.04.1, automatic), libc6-dev:amd64 (2.23-0ubuntu10, automatic), libxext-dev:amd64 (2:1.3.3-1, automatic), x11proto-record-dev:amd64 (1.14.2-1, automatic), xtrans-dev:amd64 (1.3.5-1, automatic), x11proto-xext-dev:amd64 (7.3.0-1, automatic), libxcb1-dev:amd64 (1.11.1-1ubuntu1, automatic), openjdk-8-jdk-headless:amd64 (8u181-b13-0ubuntu0.16.04.1, automatic), x11proto-core-dev:amd64 (7.0.31-1~ubuntu16.04.2, automatic), libxau-dev:amd64 (1:1.0.8-1, automatic), libxdmcp-dev:amd64 (1:1.1.2-1.1, automatic), telepad:amd64 (1.0.7-1), libxfixes-dev:amd64 (1:5.0.1-2, automatic), x11proto-input-dev:amd64 (2.3.1-1, automatic), libx11-dev:amd64 (2:1.6.3-1ubuntu2.1, automatic), openjdk-8-jre-headless:amd64 (8u181-b13-0ubuntu0.16.04.1, automatic), libbluetooth-dev:amd64 (5.37-0ubuntu5.1, automatic), libc-dev-bin:amd64 (2.23-0ubuntu10, automatic), xorg-sgml-doctools:amd64 (1:1.11-1, automatic), libxi-dev:amd64 (2:1.7.6-1, automatic), x11proto-fixes-dev:amd64 (1:5.0-2ubuntu2, automatic)
End-Date: 2018-10-22  09:30:20

Start-Date: 2018-10-24  07:50:52
Commandline: /usr/bin/apt install mint-meta-cinnamon
Requested-By: gabe (1000)
Install: mintwelcome:amd64 (2.2.6, automatic), apturl-common:amd64 (0.5.2+linuxmint5, automatic), mint-meta-cinnamon:amd64 (2017.09.19), apturl:amd64 (0.5.2+linuxmint5, automatic), mint-meta-core:amd64 (2017.09.19, automatic), mintupdate:amd64 (5.3.2.5, automatic)
Remove: virtualbox-guest-utils:amd64 (5.1.38-dfsg-0ubuntu1.16.04.1), virtualbox-guest-dkms:amd64 (5.1.38-dfsg-0ubuntu1.16.04.1), virtualbox-guest-x11:amd64 (5.1.38-dfsg-0ubuntu1.16.04.1)
End-Date: 2018-10-24  07:52:01

Start-Date: 2018-10-24  10:52:39
Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 83886109 -o Synaptic::closeZvt=true --set-selections-file /tmp/tmplnt60lxo
Requested-By: gabe (1000)
Install: linux-headers-4.15.0-38-generic:amd64 (4.15.0-38.41~16.04.1), linux-modules-extra-4.15.0-38-generic:amd64 (4.15.0-38.41~16.04.1), linux-modules-4.15.0-38-generic:amd64 (4.15.0-38.41~16.04.1, automatic), linux-headers-4.15.0-38:amd64 (4.15.0-38.41~16.04.1), linux-image-4.15.0-38-generic:amd64 (4.15.0-38.41~16.04.1)
Upgrade: mint-mirrors:amd64 (1.1.7, 1.1.8), libdns-export162:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), libservlet3.1-java:amd64 (8.0.32-1ubuntu1.7, 8.0.32-1ubuntu1.8), libisccfg140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), python-samba:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.16, 2:4.3.11+dfsg-0ubuntu0.16.04.17), linux-libc-dev:amd64 (4.4.0-134.160, 4.4.0-138.164), libcurl3:amd64 (7.47.0-1ubuntu2.8, 7.47.0-1ubuntu2.9), thunderbird-locale-es-es:amd64 (1:52.9.1+build3-0ubuntu0.16.04.1, 1:60.2.1+build1-0ubuntu0.16.04.4), liblcms2-2:amd64 (2.6-3ubuntu2, 2.6-3ubuntu2.1), imagemagick:amd64 (8:6.8.9.9-7ubuntu5.12, 8:6.8.9.9-7ubuntu5.13), libopencv-imgproc2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), libopencv-objdetect2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), libwbclient0:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.16, 2:4.3.11+dfsg-0ubuntu0.16.04.17), liblouis9:amd64 (2.6.4-2ubuntu0.3, 2.6.4-2ubuntu0.4), libgs9:amd64 (9.18~dfsg~0-0ubuntu2.8, 9.25~dfsg+1-0ubuntu0.16.04.1), flatpak:amd64 (0.10.0-0alexlarsson1~xenial, 1.0.3-flatpak1~xenial), binutils:amd64 (2.26.1-1ubuntu1~16.04.6, 2.26.1-1ubuntu1~16.04.7), libmagickwand-6.q16-2:amd64 (8:6.8.9.9-7ubuntu5.12, 8:6.8.9.9-7ubuntu5.13), libopencv-video2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), libsnmp-base:amd64 (5.7.3+dfsg-1ubuntu4.1, 5.7.3+dfsg-1ubuntu4.2), bind9-host:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), ssh-askpass-gnome:amd64 (1:7.2p2-4ubuntu2.4, 1:7.2p2-4ubuntu2.5), libflatpak0:amd64 (0.10.0-0alexlarsson1~xenial, 1.0.3-flatpak1~xenial), dnsutils:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), python3-louis:amd64 (2.6.4-2ubuntu0.3, 2.6.4-2ubuntu0.4), libisc160:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), skypeforlinux:amd64 (8.29.0.50, 8.32.0.44), libglib2.0-0-dbg:amd64 (2.48.2-0ubuntu4, 2.48.2-0ubuntu4.1), initramfs-tools-bin:amd64 (0.122ubuntu8.11, 0.122ubuntu8.13), python3-requests:amd64 (2.9.1-3, 2.9.1-3ubuntu0.1), libopencv-flann2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), libapparmor1:amd64 (2.10.95-0ubuntu2.9, 2.10.95-0ubuntu2.10), libopencv-contrib2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), adobe-flashplugin:amd64 (1:20180814.1-0ubuntu0.16.04.2, 1:20181009.1-0ubuntu0.16.04.1), libopencv-highgui2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), gir1.2-flatpak-1.0:amd64 (0.10.0-0alexlarsson1~xenial, 1.0.3-flatpak1~xenial), libxkbcommon-x11-0:amd64 (0.5.0-1ubuntu2, 0.5.0-1ubuntu2.1), thunderbird-gnome-support:amd64 (1:52.9.1+build3-0ubuntu0.16.04.1, 1:60.2.1+build1-0ubuntu0.16.04.4), samba-libs:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.16, 2:4.3.11+dfsg-0ubuntu0.16.04.17), imagemagick-6.q16:amd64 (8:6.8.9.9-7ubuntu5.12, 8:6.8.9.9-7ubuntu5.13), libsnmp30:amd64 (5.7.3+dfsg-1ubuntu4.1, 5.7.3+dfsg-1ubuntu4.2), xdg-desktop-portal-gtk:amd64 (0.7-0alexlarsson2~xenial, 1.0.2-flatpak1~xenial), libapparmor-perl:amd64 (2.10.95-0ubuntu2.9, 2.10.95-0ubuntu2.10), libisc-export160:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), chromium-browser:amd64 (68.0.3440.106-0ubuntu0.16.04.1, 69.0.3497.81-0ubuntu0.16.04.1), python-paramiko:amd64 (1.16.0-1ubuntu0.1, 1.16.0-1ubuntu0.2), thunderbird-locale-en-us:amd64 (1:52.9.1+build3-0ubuntu0.16.04.1, 1:60.2.1+build1-0ubuntu0.16.04.4), samba-common:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.16, 2:4.3.11+dfsg-0ubuntu0.16.04.17), firefox-locale-en:amd64 (61.0.1+linuxmint1+sylvia, 62.0.3+linuxmint1+sylvia), firefox-locale-es:amd64 (61.0.1+linuxmint1+sylvia, 62.0.3+linuxmint1+sylvia), chromium-codecs-ffmpeg-extra:amd64 (68.0.3440.106-0ubuntu0.16.04.1, 69.0.3497.81-0ubuntu0.16.04.1), liblwres141:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), libglib2.0-bin:amd64 (2.48.2-0ubuntu4, 2.48.2-0ubuntu4.1), ghostscript:amd64 (9.18~dfsg~0-0ubuntu2.8, 9.25~dfsg+1-0ubuntu0.16.04.1), libopencv-calib3d2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), libopencv-legacy2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), libssh-gcrypt-4:amd64 (0.6.3-4.3, 0.6.3-4.3ubuntu0.1), ghostscript-x:amd64 (9.18~dfsg~0-0ubuntu2.8, 9.25~dfsg+1-0ubuntu0.16.04.1), libsmbclient:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.16, 2:4.3.11+dfsg-0ubuntu0.16.04.17), smbclient:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.16, 2:4.3.11+dfsg-0ubuntu0.16.04.17), openssh-client:amd64 (1:7.2p2-4ubuntu2.4, 1:7.2p2-4ubuntu2.5), samba-common-bin:amd64 (2:4.3.11+dfsg-0ubuntu0.16.04.16, 2:4.3.11+dfsg-0ubuntu0.16.04.17), libmagickcore-6.q16-2:amd64 (8:6.8.9.9-7ubuntu5.12, 8:6.8.9.9-7ubuntu5.13), libgs9-common:amd64 (9.18~dfsg~0-0ubuntu2.8, 9.25~dfsg+1-0ubuntu0.16.04.1), thunderbird:amd64 (1:52.9.1+build3-0ubuntu0.16.04.1, 1:60.2.1+build1-0ubuntu0.16.04.4), libdns162:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), libostree-1-1:amd64 (2017.12-0alexlarsson1~xenial, 2018.7-flatpak2~xenial), libglib2.0-data:amd64 (2.48.2-0ubuntu4, 2.48.2-0ubuntu4.1), libopencv-core2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), liblouis-data:amd64 (2.6.4-2ubuntu0.3, 2.6.4-2ubuntu0.4), firefox:amd64 (61.0.1+linuxmint1+sylvia, 62.0.3+linuxmint1+sylvia), apparmor:amd64 (2.10.95-0ubuntu2.9, 2.10.95-0ubuntu2.10), imagemagick-common:amd64 (8:6.8.9.9-7ubuntu5.12, 8:6.8.9.9-7ubuntu5.13), libisccc140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), libopencv-ml2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), mint-backgrounds-sylvia:amd64 (1.1, 1.2), libbind9-140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), opera-stable:amd64 (55.0.2994.56, 56.0.3051.52), libopencv-features2d2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), virtualbox-5.2:amd64 (5.2.18-124319~Ubuntu~xenial, 5.2.20-125813~Ubuntu~xenial), curl:amd64 (7.47.0-1ubuntu2.8, 7.47.0-1ubuntu2.9), libxkbcommon0:amd64 (0.5.0-1ubuntu2, 0.5.0-1ubuntu2.1), liblcms2-utils:amd64 (2.6-3ubuntu2, 2.6-3ubuntu2.1), thunderbird-locale-en:amd64 (1:52.9.1+build3-0ubuntu0.16.04.1, 1:60.2.1+build1-0ubuntu0.16.04.4), thunderbird-locale-es:amd64 (1:52.9.1+build3-0ubuntu0.16.04.1, 1:60.2.1+build1-0ubuntu0.16.04.4), xdg-desktop-portal:amd64 (0.8-0alexlarsson2~xenial, 1.0.2-flatpak1~xenial), libglib2.0-0:amd64 (2.48.2-0ubuntu4, 2.48.2-0ubuntu4.1), spotify-client:amd64 (1:1.0.64.407.g9bd02c2d-26, 1:1.0.80.480.g51b03ac3-13), initramfs-tools-core:amd64 (0.122ubuntu8.11, 0.122ubuntu8.13), libcurl3-gnutls:amd64 (7.47.0-1ubuntu2.8, 7.47.0-1ubuntu2.9), initramfs-tools:amd64 (0.122ubuntu8.11, 0.122ubuntu8.13), tzdata:amd64 (2017c-0ubuntu0.16.04, 2018e-0ubuntu0.16.04), libkpathsea6:amd64 (2015.20160222.37495-1, 2015.20160222.37495-1ubuntu0.1)
Error: Sub-process /usr/bin/dpkg returned an error code (1)
End-Date: 2018-10-24  10:58:11

Start-Date: 2018-10-24  11:00:04
Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 83886109 -o Synaptic::closeZvt=true --set-selections-file /tmp/tmp7c1smeom
Requested-By: gabe (1000)
Upgrade: mint-mirrors:amd64 (1.1.7, 1.1.8), libdns-export162:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), libservlet3.1-java:amd64 (8.0.32-1ubuntu1.7, 8.0.32-1ubuntu1.8), libisccfg140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), linux-libc-dev:amd64 (4.4.0-134.160, 4.4.0-138.164), thunderbird-locale-es-es:amd64 (1:52.9.1+build3-0ubuntu0.16.04.1, 1:60.2.1+build1-0ubuntu0.16.04.4), imagemagick:amd64 (8:6.8.9.9-7ubuntu5.12, 8:6.8.9.9-7ubuntu5.13), libopencv-imgproc2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), libopencv-objdetect2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), liblouis9:amd64 (2.6.4-2ubuntu0.3, 2.6.4-2ubuntu0.4), libgs9:amd64 (9.18~dfsg~0-0ubuntu2.8, 9.25~dfsg+1-0ubuntu0.16.04.1), flatpak:amd64 (0.10.0-0alexlarsson1~xenial, 1.0.3-flatpak1~xenial), binutils:amd64 (2.26.1-1ubuntu1~16.04.6, 2.26.1-1ubuntu1~16.04.7), libopencv-video2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), libsnmp-base:amd64 (5.7.3+dfsg-1ubuntu4.1, 5.7.3+dfsg-1ubuntu4.2), bind9-host:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), ssh-askpass-gnome:amd64 (1:7.2p2-4ubuntu2.4, 1:7.2p2-4ubuntu2.5), libflatpak0:amd64 (0.10.0-0alexlarsson1~xenial, 1.0.3-flatpak1~xenial), dnsutils:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), python3-louis:amd64 (2.6.4-2ubuntu0.3, 2.6.4-2ubuntu0.4), libisc160:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), initramfs-tools-bin:amd64 (0.122ubuntu8.11, 0.122ubuntu8.13), python3-requests:amd64 (2.9.1-3, 2.9.1-3ubuntu0.1), libopencv-flann2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), libopencv-contrib2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), adobe-flashplugin:amd64 (1:20180814.1-0ubuntu0.16.04.2, 1:20181009.1-0ubuntu0.16.04.1), libopencv-highgui2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), gir1.2-flatpak-1.0:amd64 (0.10.0-0alexlarsson1~xenial, 1.0.3-flatpak1~xenial), libxkbcommon-x11-0:amd64 (0.5.0-1ubuntu2, 0.5.0-1ubuntu2.1), thunderbird-gnome-support:amd64 (1:52.9.1+build3-0ubuntu0.16.04.1, 1:60.2.1+build1-0ubuntu0.16.04.4), imagemagick-6.q16:amd64 (8:6.8.9.9-7ubuntu5.12, 8:6.8.9.9-7ubuntu5.13), libsnmp30:amd64 (5.7.3+dfsg-1ubuntu4.1, 5.7.3+dfsg-1ubuntu4.2), xdg-desktop-portal-gtk:amd64 (0.7-0alexlarsson2~xenial, 1.0.2-flatpak1~xenial), libapparmor-perl:amd64 (2.10.95-0ubuntu2.9, 2.10.95-0ubuntu2.10), libisc-export160:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), python-paramiko:amd64 (1.16.0-1ubuntu0.1, 1.16.0-1ubuntu0.2), thunderbird-locale-en-us:amd64 (1:52.9.1+build3-0ubuntu0.16.04.1, 1:60.2.1+build1-0ubuntu0.16.04.4), liblwres141:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), ghostscript:amd64 (9.18~dfsg~0-0ubuntu2.8, 9.25~dfsg+1-0ubuntu0.16.04.1), libopencv-calib3d2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), libopencv-legacy2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), libssh-gcrypt-4:amd64 (0.6.3-4.3, 0.6.3-4.3ubuntu0.1), ghostscript-x:amd64 (9.18~dfsg~0-0ubuntu2.8, 9.25~dfsg+1-0ubuntu0.16.04.1), openssh-client:amd64 (1:7.2p2-4ubuntu2.4, 1:7.2p2-4ubuntu2.5), libgs9-common:amd64 (9.18~dfsg~0-0ubuntu2.8, 9.25~dfsg+1-0ubuntu0.16.04.1), thunderbird:amd64 (1:52.9.1+build3-0ubuntu0.16.04.1, 1:60.2.1+build1-0ubuntu0.16.04.4), libdns162:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), libostree-1-1:amd64 (2017.12-0alexlarsson1~xenial, 2018.7-flatpak2~xenial), libopencv-core2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), liblouis-data:amd64 (2.6.4-2ubuntu0.3, 2.6.4-2ubuntu0.4), apparmor:amd64 (2.10.95-0ubuntu2.9, 2.10.95-0ubuntu2.10), libisccc140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), libopencv-ml2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), mint-backgrounds-sylvia:amd64 (1.1, 1.2), libbind9-140:amd64 (1:9.10.3.dfsg.P4-8ubuntu1.10, 1:9.10.3.dfsg.P4-8ubuntu1.11), libopencv-features2d2.4v5:amd64 (2.4.9.1+dfsg-1.5ubuntu1, 2.4.9.1+dfsg-1.5ubuntu1.1), virtualbox-5.2:amd64 (5.2.18-124319~Ubuntu~xenial, 5.2.20-125813~Ubuntu~xenial), curl:amd64 (7.47.0-1ubuntu2.8, 7.47.0-1ubuntu2.9), libxkbcommon0:amd64 (0.5.0-1ubuntu2, 0.5.0-1ubuntu2.1), liblcms2-utils:amd64 (2.6-3ubuntu2, 2.6-3ubuntu2.1), thunderbird-locale-en:amd64 (1:52.9.1+build3-0ubuntu0.16.04.1, 1:60.2.1+build1-0ubuntu0.16.04.4), thunderbird-locale-es:amd64 (1:52.9.1+build3-0ubuntu0.16.04.1, 1:60.2.1+build1-0ubuntu0.16.04.4), xdg-desktop-portal:amd64 (0.8-0alexlarsson2~xenial, 1.0.2-flatpak1~xenial), initramfs-tools-core:amd64 (0.122ubuntu8.11, 0.122ubuntu8.13), libcurl3-gnutls:amd64 (7.47.0-1ubuntu2.8, 7.47.0-1ubuntu2.9), initramfs-tools:amd64 (0.122ubuntu8.11, 0.122ubuntu8.13), tzdata:amd64 (2017c-0ubuntu0.16.04, 2018e-0ubuntu0.16.04), libkpathsea6:amd64 (2015.20160222.37495-1, 2015.20160222.37495-1ubuntu0.1)
End-Date: 2018-10-24  11:03:59

Start-Date: 2018-10-24  11:06:36
Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 83886109 -o Synaptic::closeZvt=true --set-selections-file /tmp/tmpakg_sw_d
Requested-By: gabe (1000)
Install: linux-headers-4.15.0-38-generic:amd64 (4.15.0-38.41~16.04.1), linux-modules-extra-4.15.0-38-generic:amd64 (4.15.0-38.41~16.04.1), linux-modules-4.15.0-38-generic:amd64 (4.15.0-38.41~16.04.1, automatic), linux-headers-4.15.0-38:amd64 (4.15.0-38.41~16.04.1), linux-image-4.15.0-38-generic:amd64 (4.15.0-38.41~16.04.1)
End-Date: 2018-10-24  11:07:57

Start-Date: 2018-10-25  07:45:47
Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 88080407 -o Synaptic::closeZvt=true --set-selections-file /tmp/tmp33mvie9m
Requested-By: gabe (1000)
Upgrade: skypeforlinux:amd64 (8.29.0.50, 8.32.0.44), firefox-locale-en:amd64 (61.0.1+linuxmint1+sylvia, 62.0.3+linuxmint1+sylvia), firefox-locale-es:amd64 (61.0.1+linuxmint1+sylvia, 62.0.3+linuxmint1+sylvia), firefox:amd64 (61.0.1+linuxmint1+sylvia, 62.0.3+linuxmint1+sylvia)
End-Date: 2018-10-25  07:46:24

Start-Date: 2018-10-25  08:11:33
Commandline: aptdaemon role='role-install-packages' sender=':1.70'
Install: autotools-dev:amd64 (20150820.1, automatic), librpmsign3:amd64 (4.12.0.1+dfsg1-3build3, automatic), s-nail:amd64 (14.8.6-1, automatic), rpm2cpio:amd64 (4.12.0.1+dfsg1-3build3, automatic), at:amd64 (3.1.18-2ubuntu1, automatic), librpmbuild3:amd64 (4.12.0.1+dfsg1-3build3, automatic), lsb-security:amd64 (9.20160110ubuntu0.2, automatic), zlib1g:i386 (1:1.2.8.dfsg-2ubuntu4.1, automatic), dh-autoreconf:amd64 (12~ubuntu16.04.1, automatic), google-earth-pro-stable:amd64 (7.3.0.3832-r0), alien:amd64 (8.95, automatic), debugedit:amd64 (4.12.0.1+dfsg1-3build3, automatic), libc6:i386 (2.23-0ubuntu10, automatic), automake:amd64 (1:1.15-4ubuntu1, automatic), gcc-6-base:i386 (6.0.1-0ubuntu1, automatic), lsb-invalid-mta:amd64 (9.20160110ubuntu0.2, automatic), dh-strip-nondeterminism:amd64 (0.015-1, automatic), libfile-stripnondeterminism-perl:amd64 (0.015-1, automatic), librpmio3:amd64 (4.12.0.1+dfsg1-3build3, automatic), libgcc1:i386 (1:6.0.1-0ubuntu1, automatic), po-debconf:amd64 (1.0.19, automatic), autoconf:amd64 (2.69-9, automatic), pax:amd64 (1:20151013-1, automatic), rpm-common:amd64 (4.12.0.1+dfsg1-3build3, automatic), rpm:amd64 (4.12.0.1+dfsg1-3build3, automatic), librpm3:amd64 (4.12.0.1+dfsg1-3build3, automatic), ncurses-term:amd64 (6.0+20160213-1ubuntu1, automatic), debhelper:amd64 (10.2.2ubuntu1~ubuntu16.04.1, automatic), lsb-core:amd64 (9.20160110ubuntu0.2, automatic), autopoint:amd64 (0.19.7-2ubuntu3, automatic), libtool:amd64 (2.4.6-0.1, automatic)
End-Date: 2018-10-25  08:12:28

Start-Date: 2018-10-25  08:27:13
Commandline: /usr/sbin/synaptic --hide-main-window --non-interactive --parent-window-id 88080407 -o Synaptic::closeZvt=true --set-selections-file /tmp/tmp9x5vd5ue
Requested-By: gabe (1000)
Upgrade: tzdata:amd64 (2018e-0ubuntu0.16.04, 2018f-0ubuntu0.16.04)
End-Date: 2018-10-25  08:27:17

User avatar
smurphos
Level 8
Level 8
Posts: 2050
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Software updater has disappeared from the system

Post by smurphos » Thu Oct 25, 2018 12:35 am

Elysium wrote:
Wed Oct 24, 2018 11:24 pm
Thanks a lot for your patience and given me that information. I did type the command: cat /var/log/apt/history.log
I was given this information, which I dont fully understand and it also seems to be only a 3 day range of changes on my computer.
That is a bit weird unless you hadn't installed or removed anything in the rest of October - the current log goes back to the 1st of the month by default. Older logs are in compressed .gz format in /var/log/apt. Judging by the number of updates applied when you got mintupdate up and running it looks like it's been quite a while since you last applied updates - presumably because mintupdatehas been missing for quite a while?

Still the 3 packages that were removed when you installed mint-meta-cinnamon are interesting. In Mint 18.x mintupdate has been set to block the installation of the virtualbox-guest* packages since this debacle back in March 18 - viewtopic.php?f=47&t=266431&start=40

Did you try and install virtualbox-guest* packages at any point? Installing them would trigger the removal of mintupdate. However whatever installation method you used you would have had a message to warn you that packages including mintupdate would being removed and asking you to confirm the operation. If it was via apt-get the warning would have been in the terminal output - if via Synaptic or Software Manager in a little pop-up.

Message of the day is always read these warnings when installing or removing software and if there is anything unexpected (particularly unexpected package removals) abort the operation and seek advice. :wink:

I can see from the other updates applied that you've got the Oracle Virtualbox repo and the Oracle version of Virtualbox installed so maybe you thought you needed the virtualbox-guest* packages or installed virtualbox with a wildcard like apt-get install virtualbox* after adding the Oracle repo? Running back through the compressed logs may help you work that out if you can't recall.

No one needs the virtualbox-guest* packages anyway. They are intended for use for a Mint/Ubuntu install inside Virtualbox and even then it's always better to install them via the guest-additions-iso that you can run from within Virtualbox.

Code: Select all

Start-Date: 2018-10-24  07:50:52
Commandline: /usr/bin/apt install mint-meta-cinnamon
Requested-By: gabe (1000)build3, automatic), s-nail:amd64 (14.8.6-1, automatic), rpm2cpio:amd64 (4.12.0.1+dfsg1-3build3, automatic), at:amd64 (3.1.18-2
Install: mintwelcome:amd64 (2.2.6, automatic), apturl-common:amd64 (0.5.2+linuxmint5, automatic), mint-meta-cinnamon:amd64 (2017.09.19), apturl:amd64 (0.5.2+linuxmint5, automatic), mint-meta-core:amd64 (2017.09.19, automatic), mintupdate:amd64 (5.3.2.5, automatic)
Remove: virtualbox-guest-utils:amd64 (5.1.38-dfsg-0ubuntu1.16.04.1), virtualbox-guest-dkms:amd64 (5.1.38-dfsg-0ubuntu1.16.04.1), virtualbox-guest-x11:amd64 (5.1.38-dfsg-0ubuntu1.16.04.1)
End-Date: 2018-10-24  07:52:01

Elysium
Level 2
Level 2
Posts: 60
Joined: Sat Nov 24, 2012 5:01 pm

Re: Software updater has disappeared from the system

Post by Elysium » Thu Oct 25, 2018 12:54 am

smurphos wrote:
Thu Oct 25, 2018 12:35 am


That is a bit weird unless you hadn't installed or removed anything in the rest of October - the current log goes back to the 1st of the month by default. Older logs are in compressed .gz format in /var/log/apt. Judging by the number of updates applied when you got mintupdate up and running it looks like it's been quite a while since you last applied updates - presumably because mintupdatehas been missing for quite a while?
I did install Oracle VB and could have ticked "yes" to everything. Thanks for pointing that out.

I havent really installed anything recently. I have been too busy studying my postgrad degree and working at a new job.

I have just checked the terminal apt policy mint* (because there was an update that belonged to the VB last night) to make sure that the update hasnt triggered any unwanted changes.

The update manager seem to be running well too. I can rest assured that everything is back to normal, right?

This is what I got back:

Code: Select all

mintupdate:
  Installed: 5.3.2.5
  Candidate: 5.3.2.5
  Version table:
 *** 5.3.2.5 500
        500 http://packages.linuxmint.com sylvia/main amd64 Packages
        500 http://packages.linuxmint.com sylvia/main i386 Packages
        100 /var/lib/dpkg/status
And yes....I'll be more careful and pay more attention to the changes that are triggered by an installation. :)

By the way, this is the one I have (just checked the software manager):
software manager.png
Virtual Guest Additions were installed from the VB from a running Winx XP OS.

User avatar
smurphos
Level 8
Level 8
Posts: 2050
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher...

Re: Software updater has disappeared from the system

Post by smurphos » Thu Oct 25, 2018 1:48 am

Yeah that's fine - the Oracle repo doesn't provide the virtualbox-guest* packages in any case - they are in the Ubuntu repos.

They shouldn't be there at all in my opinion, but hey-ho I'm sure the Ubuntu maintainers know better :roll: :wink:

Elysium
Level 2
Level 2
Posts: 60
Joined: Sat Nov 24, 2012 5:01 pm

Re: Software updater has disappeared from the system

Post by Elysium » Thu Oct 25, 2018 1:59 am

smurphos wrote:
Thu Oct 25, 2018 1:48 am
Yeah that's fine - the Oracle repo doesn't provide the virtualbox-guest* packages in any case - they are in the Ubuntu repos.

They shouldn't be there at all in my opinion, but hey-ho I'm sure the Ubuntu maintainers know better :roll: :wink:
Alright. Then again....thanks a lot for the insight!!

Have a good day.

Post Reply

Return to “Newbie Questions”