HP network printer won't work after upgrade

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
jollyjack
Level 4
Level 4
Posts: 299
Joined: Sat Aug 16, 2014 10:25 am

HP network printer won't work after upgrade

Post by jollyjack » Mon Oct 29, 2018 3:08 am

LM19 with XFCE, and an HP Envy 5540.

The printer was showing in the printer folder and it had an IP address. It wouldn't print, so I reinstalled HPLIP. No change. I added the printer again with a different name. No change.

I deleted all the printers, restarted my PC, then added a new printer. I tried to print a document from LibreOffice, and got an error message"Status Message - Filter Failed". So, I ran the debugging tool - no help.

Can anyone help?

Thanks

User avatar
kc1di
Level 14
Level 14
Posts: 5342
Joined: Mon Sep 08, 2008 8:44 pm
Location: Maine USA

Re: HP network printer won't work after upgrade

Post by kc1di » Mon Oct 29, 2018 5:38 am

to to a terminal and type this command and install the printer via the hp installation guide

Code: Select all

hp-setup
I'm assuming your using the printer in wireless mode. You may need to set a fixed IP address on your network for the printer also.
I believe the envy allows you to do that on it's setting. set the IP address well above the normal range of units that will be on the network that way DHCP will not change the address with new things are added to the network. If none of that works you may need to downgrade the kernel in other words boot to the last kernel before the update and see if that works. or the hplip drivers for now.
good luck.
Easy tips : https://easylinuxtipsproject.blogspot.com/
Linux Mint Installation Guide: http://linuxmint-installation-guide.rea ... en/latest/
Registered Linux User #462608

jollyjack
Level 4
Level 4
Posts: 299
Joined: Sat Aug 16, 2014 10:25 am

Re: HP network printer won't work after upgrade

Post by jollyjack » Mon Oct 29, 2018 5:49 am

OK, tried that command and got an error message: "No Module named PyQt5 installed"

Cheers

jollyjack
Level 4
Level 4
Posts: 299
Joined: Sat Aug 16, 2014 10:25 am

Re: HP network printer won't work after upgrade

Post by jollyjack » Mon Oct 29, 2018 5:57 am

Progress. I looked up HPLIP in Synaptic, and there was another package that wasn't installed - GUI frontend,it appeared. So I installed it, and yes, we're off. Now, I'll start the installation process.

Thanks

jollyjack
Level 4
Level 4
Posts: 299
Joined: Sat Aug 16, 2014 10:25 am

Re: HP network printer won't work after upgrade

Post by jollyjack » Mon Oct 29, 2018 11:37 am

Not good.

I followed all the instructions to install the printer, and it all seemed to work. Now it has its own ip address. But, nothing happens when I send it a print job (either a test page, or a small document from LibreOffice).

So, I switched it off. I deleted all the printers in LM19, then rebooted both machines and started again. Same result.

I'm stuck. Any advice will be appreciated.

Cheers

jollyjack
Level 4
Level 4
Posts: 299
Joined: Sat Aug 16, 2014 10:25 am

Re: HP network printer won't work after upgrade

Post by jollyjack » Mon Oct 29, 2018 11:46 am

I stumbled across another post re problems with an HP printer. It recommended running a CL command "hp-check". I did, and it says I have LOTS of missing programs/libraries.
error: libjpeg libjpeg - JPEG library REQUIRED - - MISSING 'libjpeg needs to be installed'
error: cups-devel CUPS devel- Common Unix Printing System development files REQUIRED - - MISSING 'cups-devel needs to be installed'
error: cups-image CUPS image - CUPS image development files REQUIRED - - MISSING 'cups-image needs to be installed'
error: libpthread libpthread - POSIX threads library REQUIRED - b'2.27' MISSING 'libpthread needs to be installed'
error: libusb libusb - USB library REQUIRED - 1.0 MISSING 'libusb needs to be installed'
sane SANE - Scanning library REQUIRED - - OK -
error: sane-devel SANE - Scanning library development files REQUIRED - - MISSING 'sane-devel needs to be installed'
error: libnetsnmp-devel libnetsnmp-devel - SNMP networking library development files REQUIRED 5.0.9 - MISSING 'libnetsnmp-devel needs to be installed'
error: libcrypto libcrypto - OpenSSL cryptographic library REQUIRED - 1.1.0 MISSING 'libcrypto needs to be installed'
python3X Python 2.2 or greater - Python programming language REQUIRED 2.2 3.6.6 OK -
error: python3-notify2 Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL - - MISSING 'python3-notify2 needs to be installed'
python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4 OPTIONAL 4.0 4.12.1 OK -
python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x) REQUIRED 4.0 4.12.1 OK -
python3-dbus Python DBus - Python bindings for DBus REQUIRED 0.80.0 1.2.6 OK -
python3-xml Python XML libraries REQUIRED - 2.2.5 OK -
error: python3-devel Python devel - Python development files REQUIRED 2.2 3.6.6 MISSING 'python3-devel needs to be installed'
python3-pil PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL - 1.1.7 OK -
python3-reportlab Reportlab - PDF library for Python OPTIONAL 2.0 3.4.0 OK -

--------------
| COMPILEDEP |
--------------

error: libtool libtool - Library building support services REQUIRED - - MISSING 'libtool needs to be installed'
error: gcc gcc - GNU Project C and C++ Compiler REQUIRED - 7.3.0 MISSING 'gcc needs to be installed'
I'm sorry it's not clear to more read. It's a cut/paste from the terminal screen. Maybe it'll help

Cheers

jollyjack
Level 4
Level 4
Posts: 299
Joined: Sat Aug 16, 2014 10:25 am

Re: HP network printer won't work after upgrade

Post by jollyjack » Tue Oct 30, 2018 7:47 am

Even worse.

Installing these programs didn't help, so I decided to roll back to LM18, using Timeshift. That didn't work - after I set it off, it reverted to a blank screen. So, I tried again, this time from the live media DVD - same result.

OK, in desperation, I decided to revert to loading LM18 from live media, then using Timeshift. That worked to an extent.

I can get to a log-in screen where it offers me the choice of LM18, LM18 Emergency Mode (or something like that) and System Settings (again, something like that). Finally I get to CL like screen, saying "welcome to emergency mode" and offering me several choices, none of which I understand.

Is there a quick fiix, or am I condemned to rebuilding LM18.3 from scratch? It's a rainy afternoon, so that's not too bad an option....

Thanks

XP-refugee
Level 1
Level 1
Posts: 31
Joined: Mon Jan 01, 2018 2:41 am

Re: HP network printer won't work after upgrade

Post by XP-refugee » Tue Oct 30, 2018 11:00 am

Downloading and following the long list of easy instructions* from

https://developers.hp.com/hp-linux-imag ... g/gethplip

has got things working here.
Though whether we had the same problem I don't know.
* Note: Screen shot shows previous version number.

As I understand things this is not an ideal solution as it trains me and others to use software off the net as opposed to the checked software in the Linux Mint Software Manager.
Which I'm told is a big no-no in terms of security.

jollyjack
Level 4
Level 4
Posts: 299
Joined: Sat Aug 16, 2014 10:25 am

Re: HP network printer won't work after upgrade

Post by jollyjack » Tue Oct 30, 2018 12:40 pm

Thanks for the pointer, XP-refuge. I took the decision to try and stick with LM solutions, as you would like to. So I'm staying with LM18, for the time being. Maybe, at LM19.1, HP printers will work.

Mind, to get back to LM18.3 wasn't easy. To get Timeshift to work, I remembered I'd had the same problem in July, when I first tried LM19. The advice was to, from live media, empty/format the /root partition, then use Timeshift to restore. THAT worked, except I found that Timeshift doesn't save personal data (photos/music), only system settings. Which was why my restored /home partition was strangely empty. Fortunately, I've been backing up /home every night, so I could restore it. WRONG. My backup stopped working in July, so I had to try and remember what had happened since then.

I now have a system that's pretty close to what it was on Saturday (the printer even works), and I've learnt something.

TEST YOUR RESTORE PROCESSES

Cheers

Post Reply

Return to “Newbie Questions”