Metacity Global Keybindings [solved]

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
User avatar
Level 5
Level 5
Posts: 933
Joined: Fri Feb 06, 2009 5:05 pm
Location: Boston College

Metacity Global Keybindings [solved]

Postby Kaye » Tue Jun 23, 2009 2:59 am

Hey everyone,

I ran into a strange problem a few minutes ago. I've set up my metacity global keybindings so that <Control>h should run a small bash script I've wrote. The problem is that metacity isn't recognizing my keystrokes for some reason. If I hit <Control>h normally, nothing will happen; however, if I run metacity --replace and then hit <Control>h, th script runs flawlessly as it should. Anyone have any idea why this would happen and how I can fix it? I have metacity running as the default window manager (nothing like Emerald running, although I do have Compiz enabled). This worked perfectly for me in Felicia, if that makes any difference.


Edit: Well, messed around a bit. I got it to work by applying the shortcut through the Gnome keyboard shortcuts interface. Although the problem isn't solved completely (I'd like to know what the problem was with the metacity method), for all intents and purposes it works.
"In somnis veritas"
Antivirus or defragging?

Level 8
Level 8
Posts: 2158
Joined: Thu Feb 26, 2009 8:58 pm

Re: Metacity Global Keybindings [solved]

Postby emorrp1 » Fri Jul 10, 2009 3:52 pm

Hi kaye, it will be compiz interfering, as the metacity --replace method which solves it replaces compiz. Not exactly sure why this is affecting the ctrl+h shortcut directly, but compiz is known to mess about/intercept things like that, and if the replace method works, then the only thing which will change is the disabling of compiz.
If you have a question that has been answered and solved, then please edit your original post and put a [SOLVED] at the end of your subject header
Hint - use a google search including the search term

Return to “Newbie Questions”

Who is online

Users browsing this forum: No registered users and 15 guests