Is it possible to go from version 18 to version 19 by downloads alone?

All Gurus once were Newbies
Forum rules
There are no such things as "stupid" questions. However if you think your question is a bit stupid, then this is the right place for you to post it. Please stick to easy to-the-point questions that you feel people can answer fast. For long and complicated questions prefer the other forums within the support section.
Before you post please read how to get help
Post Reply
Punchy71
Level 3
Level 3
Posts: 128
Joined: Tue Aug 21, 2012 6:48 pm

Is it possible to go from version 18 to version 19 by downloads alone?

Post by Punchy71 » Thu Nov 08, 2018 3:38 pm

Hi,
I'm currently running Linux Mint 18 "Sarah" on my PC. I'm also currently downloading the packages to update it to 18.3 "Sylvia".

However, I'm wanting to know once I update fully to 18.3 "Sylvia", is it then possible to go ahead and download packages and update my system fully to 19.0 "Tarah"?
Thanks

User avatar
xenopeek
Level 24
Level 24
Posts: 24026
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Is it possible to go from version 18 to version 19 by downloads alone?

Post by xenopeek » Thu Nov 08, 2018 3:44 pm

It's not trivial but yes, you can: https://blog.linuxmint.com/?p=3615
Image

User avatar
karlchen
Level 20
Level 20
Posts: 11074
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Is it possible to go from version 18 to version 19 by downloads alone?

Post by karlchen » Thu Nov 08, 2018 4:08 pm

The real instruction on how upgrade in-place from Mint 18.3 to Mint 19, however, is here: How to upgrade to Linux Mint 19.
The same URL can be found in the blog post as well, but it is easily missed, because it is not really highlighted. :(
Image
Linux Mint 19.2 32-bit xfce Desktop, Total Commander 9.22a 32-bit
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.22a 64-bit
Windows? - 1 window in every room

redlined

Re: Is it possible to go from version 18 to version 19 by downloads alone?

Post by redlined » Thu Nov 08, 2018 5:12 pm

hi Punchy71!

I'll add a note (since your question was answered already above). The one hiccup I had was dbus error(s), the workaround mentioned by jancoffee in the upgrade blog post is what fixed it for me:

Code: Select all

I just upgraded from Linux mint 17->18->19 and it worked great but during the 18->19 upgrade I got this error after running the "mintupgrade upgrade"

I got repeating error message:

dpkg: error processing package gconf2 (--configure):
dependency problems - leaving triggers unprocessed
dpkg: dependency problems prevent processing triggers for gconf2:
gconf2 depends on dbus-x11; however:
Package dbus-x11 is not configured yet.

My solution was to run the commands:
sudo dpkg --configure -a
sudo apt-get install -f

and then re-run the "mintupgrade upgrade" and it worked like a charm to upgrade to Mint 19 :-)
I would also recommend install locales-all package beforehand (I believe this will help prevent the dbus errors during upgrade).

and... if you have encrypted /home please do read xenopeak's swap fix post as well, it will be necessary after upgrade to 19 from 18.3

the above was included in my notes on recent 18.3 to 19 upgrade as posted here: viewtopic.php?f=90&t=280889

Hope this helps!

Post Reply

Return to “Newbie Questions”